Jump to content

AXON & FXO (SPA3000)


Recommended Posts

[ UPDATED ]

 

The problem with my SPA3000 has been fixed and through my research, assistance and experimentation, I have produced what I call the Ultimate guide to setting up your Sipura/Linksys FXO adapter for use in Axon here: http://nch.invisionzone.com/index.php?showtopic=5091

 

The guide is designed for any user (novice to expert) who is looking for how to setup their SPA FXO adapter with Axon or someone who has tried to setup and is unable to get it functioning correctly.

Link to post
Share on other sites

My 3102 works fine with the latest firmware.

You can download my configuration from this link: http://test.ct-x.net/franco/spa3102.zip

To load it in your 3102, open the html file with a text editor and change "<FORM action=asipura.spa" with "<FORM action=http://your_sipura_ip_address/admin/asipura.spa", save the html file and click Submit Configuration.

The "Regional" tab has Italian settings, but everything works with default settings, too. You can change tones depending on your country, if you want.

You should also check the "PSTN Line" tab, International Control, because it may differ a bit from your country.

On the Axon side, I have created two extensions, 107 (for FXS interface) and 108 (for FXO interface), with passwords 107 and 108. The Default external line uses my 3102 IP (192.168.1.7) as proxy, with random user name and password. The default dial plan has a rule to place calls on the default external line (in this case, I place emergency calls on PSTN, but this rule can be changed, of course).

Changing IPs according to your configuration should be enough to make this setup work.

Link to post
Share on other sites

I am using the 3000 (not 3102), and I was not able to import the settings configuration you provided. However, I tried to copy it over manually as best I could.

 

After some modifications, I was finally (and still am) able to dial out on the PSTN line. However I cannot receive calls through the PBX from the PSTN line. Axon logs show no recognition of any inbound call.

 

Below is a link to the configuration settings I have used

http://scorptek.org/MISC/advanced.htm

 

What am I supposed to do in Axon to receive calls from the FXO adapter?

Link to post
Share on other sites

Thank you everyone for your help. With the combination of the NCH SPA setup guide, a third party user guide, a little help on the forums, and experimenting, I finally got a fully working FXO adapter.

 

I have to say that the NCH guide is not very good and does not include many of the important steps to follow in order to setup a Voip to PSTN and PSTN to Voip gateway.

 

Therefore I have decided to create a full user guide on how to set it up for other users having problems, and I will post it shortly.

Link to post
Share on other sites
  • 1 month later...

Yes, inbound and outgoing PSTN calls work perfectly fine. I have my Linksys FXO adapter connected to my Vonage line (since it doesn't allow third party clients to connect to main vonage accounts) and now I can phone from any axon-connected phone in the house. And receive calls as well. Please see my other topic (the tutorial/step-by-step instruction guide to getting 2 way answer & dial with your linksys adapter.

Link to post
Share on other sites
  • 4 weeks later...

the nch guide needs an update, we're addressing that currently.

 

your guide is quite good, however your methodology is not the way we intended - while it does work of course, our idea is just a little simpler and is summarised like so: (this is very brief)

 

- create an external line in axon with a nominated username/password and blank server field, set it to ring on a nominated group

- enter those username/password details into the sipura's PSTN section User ID and Password fields

- set the FXO dialing plan to forward to the line you configured in axon - [username]@[axon ip address]

- save the changes in the FXO and then wait for the FXO to register with Axon (you will see the log message 'External Line [name] is at : [ip address]:[port])

- in axon edit your dialing plan and create a new dial rule and set it to use axon's sipura line

- edit any relevant extensions and set them to use the sipura dial rule

 

we deliberately want the sipura device to register with axon, that is definitely not a mistake in our guide, the whole 'let the other device register with axon' design was very carefully thought out and its quite useful once you understand how it works.

 

using this method you also won't see any 'Register attempt failed' log messages ever.

 

this is how i configured my own sipura box at home and it works great for me.

Link to post
Share on other sites

Interesting, I'll have to experiment with that method, I tried for ages to get the adapter to work with Axon with pretty much no success whatsoever. Finally through information I found on this forum and elsewhere on the internet, I managed to piece together a method that did work to an extent. Actually, everyone I contacted and found online who got their FXO adapter working with Axon did it pretty much the same way as me and also had the register error for some reason and they all complained that following the NCH guide did not get it working.

 

The limitations of my method that I have noted so far are:

1) If caller id is turned on, Axon simply does not want to answer the phone call, but its fine if the caller id is not forwarded

2) The register error appears often

 

When I have time, I'll look over the steps you described above and try to adjust my settings to those. If I can get it to work, I'll try and re-write / simplify some of the guide with the new NCH supported method.

Link to post
Share on other sites

yea at this stage i have not got the caller ID thing sussed out yet, I can't figure out how to get the sipura to forward the ID information. but other than that its working nicely for me.

 

but yeah like i said i'm going to update the guide, and if you feel it is ok i will incorporate elements of your guide into the NCH guide. who knows, i may find i went through some steps that i thought were obvious but weren't obvious to anyone else, which is why a lot of people are having problems.

Link to post
Share on other sites
  • 4 weeks later...

Hi all!

Can somebody help me?

I use the instruction that find above to use axon and SPA 3102 (last firmware). And only have incoming call. When i decided to use PSTN line and press 0 (in axon i have dial plan for SPA) i only hear several shot tone signal and no outbound call.

Link to post
Share on other sites

Same issue here, this guide must be an older firmware version.

I have set the 3102 back to factory defaults and same thing it does not work.

you can see the guide was set for a older version (Fireware)

Can someone look at the last two firmware versions and fix this dang thing or send a link to the firmware version the guide is supported under.

Link to post
Share on other sites

The guide I wrote was written for the SPA-3000 with firmware version 2.0.13(GWg), however I tried to make it so the guide was compatible with the 3102 and other slightly different firmware versions. What version are you using, and what problems are you encountering?

Link to post
Share on other sites

Right now nothing works right. I have the axon on a public static ip address and the spa3102 on the internal ip 10.33.15.112.

 

if you goto www.habershamwoods.com/line1.htm or /pstnline.htm you can review my setup.

 

if you need to see anything else you can email me d1rage5@ yahoo .com

Link to post
Share on other sites
  • 2 months later...

Dear Friends,

 

I am a new user on AXON Virtual PBX, I got it through website, But there are some question in my mind, can you help me/

there are as follow:

 

1- Is it possible to use FXO adapter with th axon Virtual PBX software freeware?

2- Is it possible to use Modem as PSTN line and provide dialling plane for accessing it?

3- How can I configure my FXO adapter(S404 4FXO Taiwanian Made) to work with the Axon?

 

I have some more but wait to receive some note about the above,

 

 

Regards.

 

Ali

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...