Jump to content

Another Masking question

Recommended Posts

I am still trying to make it through my current project before I reload my system (due to VP suddenly started acting erratic). But I am having some issues with using animating masks that I'd appreciate some feedback about.

As you know, the way it's supposed to work is that you create a keyframe, move the points around to create your mask, then move forward to another point in the timeline, create a keyframe, move the points around to the new shape, repeat, etc. Then when you move through the clip using the scrubber, you see the mask smoothly "move" as it goes from point to point.

The issue I am having is that it is either doing 1 of 2 things: It doesn't animate from point to point, but just suddenly changes over to the new shape when you reach the next point. Or it will animate, but then when you slide past point B the mask suddenly reverts back to the shape from point A. It doesn't retain the point B shape as you slide through the rest of the clip as it should.

I had about 5 minutes to test this morning and what I found out is: if I leave the clip preview window (where you're adding the points) to normal size within the VP interface, it worked perfect after doing 3 or 4 tests. But when I tried moving the points around while the clip preview window was maximized (double clicking in the window) that's when the issues would occur.

So I don't know if:

1. this is a bug.

2. VP wasn't designed to create points when the window is maximized (which would be really inconvenient)

3. or if this is just  another symptom of my unstable VP load.

BTW, I using the latest version - 7.00.


Link to post
Share on other sites


Tested this with V7.0 as follows. Here it seems to work OK

  • Placed a Video clip on Video Track 2 and a black blank black clip on Video Track 1.
  • Made both tracks same length.
  • Set preview cursor at start and Opened Effects for the Video clip.
  • Added  an Effect  Mask. (Rectangle Polygon mask).
  • Set keyframe
  • Moved preview cursor cursor along the clip to middle and changed mask outline to a triangle.
  • Created second keyframe.
  • Moved preview cursor along the clip to end and recreated a rectangle.
  • Set last keyframe.
  • UNTICKED the mask inside option
  • Added a transparency effect set to zero opacity.

The video clip on Track 2 correctly animated from a rectangle that transformed into a triangle  and then back into a rectangle. This also worked in reverse.(Triangle to rectangle and back) Also worked with Mask Inside set.

I also repeated the test using an enlarged preview screen to set up the mask.(By dragging out the sides of the undocked window to a suitable size...Full screen cannot be used as the effects pane is hidden.) The animation also worked OK when created on this window. It was however infuriatingly slow as VP had to regenerate the clip for every point change. (This might have been my rather slow PC however.)

In short I haven't manage to reproduce your experience. It is annoying if things go slowly but did you move points etc. before the last action had been registered by VP (Green bars completing etc.)



Link to post
Share on other sites

National and borate,

Thanks for checking it out. I have the feeling it's another symptom of my wonky VP install. I'll have to decide if I just need to reinstall now and finish the project later or try to push through. I have one clip to redo the masking (the finished video I have now is not very  smooth) and then possibly another clip to apply masks. So, I don't know....

Couple of things for National: 1. I don't think it's a PC performance issue as I just upgraded recently and can process the masking even in full screen fairly fast. 2. I know going full screen for the clip window hides the effects pane... but what I was doing was only moving the points while in full screen and then going out of full screen to go back to the effects window.. to set keyframe or move to the next position, etc. Speaking of which, I'm glad you brought this up. I have tried this both ways... You have to click to create a keyframe initially to get it started, but then after you slide scrubber to new position and immediately click to create a new keyframe, then move the points; *or* after sliding scrubber to new position and move the points first, which seems to create a keyframe automatically. But sometimes it only creates 1 keyframe instead of 2 as it does when you manually click to create one (I'm not sure if it's the feathering or position that it creates). I have also tried to manually click keyframe after one has already automatically been created and then usually I'll have both. I hope that's clear enough... I tested both ways this morning when working with the "normal window' and it seemed to work either way, but is one way more correct than the other?

I'm going to write out that last part in bullet points so it will be clearer.

Choice A

1. Click to create keyframe

2. Move points to create mask shape

3. Move scrubber to next time point

4. Click to create next keyframe

5. Move points, etc, repeat


Choice B

1. Click to create keyframe (has to be first step to get it started)

2. Move points to create make shape

3. Move scrubber to next time point

4. Move points to change mask shape (which sometimes automatically creates a keyframe)

5. Click to create keyframe for mask shape you just made

I'm not sure if VP sometimes automatically creating a keyframe when you begin to move points (when you release the first one) is supposed to happen or just my wonky system.. but putting that aside for the moment: is it more correct to move point then create that keyframe, or create the keyframe first and the move the points?

Link to post
Share on other sites

Okay, that answers that part of it. Thanks, borate.

Do you know if pressing it again hurts anything, or is just redundant? I looked up the instructions for animating a mask on NCH page and it said to hit the + to create each keyframe point. Those instructions were from some time ago, so maybe outdated now.

Link to post
Share on other sites

Okay, I started over on the clip I've been working on and it's now working again even when creating the masks in full screen. Hopefully I can get through the rest of it before it starts messing up again.

Link to post
Share on other sites

Hi Miggy

I tend to look at it this way....

  1. Move cursor to required place in the preview and set the position and shape of the mask
  2. Create a keyframe 1 when happy
  3. Move cursor to next preview position
  4. Move points if mask is to differ from keyframe 1. If it's not going to change shape just leave it alone.
  5. Create keyframe  2 when happy..

Carry on in this way. So it's.... Create/Move/Create etc.The mask will animate between the keyframes.  After the last keyframe it will not change but I generally click the button at the end of the clip although a keyframe is in fact actually made.


Link to post
Share on other sites


 I finished processing the clip without problem. At first, I took your advice and went slowly with moving the points to make sure that the clip fully processes (green bar fills). Even though it only takes a second, I was previously moving the points a little faster than that. I thought that had been my problem, but then later I experimented and moved the points as fast as I was before, and it's still working properly. I tried every combination of pre-creating points, letting it automatically creating them, creating them after moving the points, full screen, regular screen.. and I can't get it to exhibit the behaviors I described when I made this post. So I have no clue what was causing it to start with. The stability of my VP install just seems to vary from day to day (it also hasn't crashed last few days), so I'm hoping a system reinstall will bring it back to normal.

Link to post
Share on other sites

Hi Miggy  :D

" . and I can't get it to exhibit the behaviors I described when I made this post. .."

Par for the course! I can check something out and find a problem that's been mentioned and all of a sudden the problem goes away and I can't repeat it. Current problem is  Exporting all sequences from the File menu. Borate can..I can't although we both have the (apparently) the same version of VP and I am following exactly the same steps. . I even find with some actions I lose the option from the menu as well..Weird! . Still, it's working for the main job of editing and when there is a problem or advice needed we try to help out.




Link to post
Share on other sites
2 hours ago, Nationalsolo said:

Hi Miggy  :D

 Still, it's working for the main job of editing and when there is a problem or advice needed we try to help out.




And I greatly appreciate that!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...