Jump to content

Starting Videopad beyond v13.81 from the command line with in MP4 as an argument


Recommended Posts

I'm not sure if this is a bug or just a change in the code. Version 13.81 was the last version that allowed me to click on a MP4 file and use the option "open with" videopad. It would take the MP4 file and put it in the bin directory allowing me to then choose other selections. Now it treats the MP4 like it's stabilizing the video which is one of the options in the menu. This file does not need to be stabilized.

All versions since 13.81 seem to do this. I just downloaded a new version today v16.15 and is still present. Is this a bug or is this the way is normal operation now.

I could change all my scripts to handle this if it is permanent.

Link to comment
Share on other sites

From the command line, this code works on this PC. using version 16.15 (64).

"C:\Program Files (x86)/NCH Software/VideoPad/videopad.exe" "C:/Users/<PC name>/Videos/static.mp4"

Or, from Windows Explorer (file manager), right-click an mp4 and then Add To Videopad Project or Open With Videopad.

  No stabilization offered either way.

Link to comment
Share on other sites

Thanks for clarifying that I didn't think it was a bug it looked more like a characteristic. So instead of l listing the MP4 file on the command line I will open it up and then use control M, add the file inside of videopad. So now apparently all MP4 files on the command line are treated that needed to stabilize.

I don't know if you remember but I have a procedure script that uses both PhotoStage and videopad in combination that can handle up to 100,000 slides in one procedure that calls PhotoStage with 200 slides each. Then it glues everything together with videopad.

Link to comment
Share on other sites

I just tried it with my MP4
videopad.exe small.mp4

And it brought up the stabilization dialogue. But I know that will go away once I load videopad alone and then just say control M and bring the file in that way.

Link to comment
Share on other sites

  • 2 weeks later...

You must be running Windows 11. I have verified all my systems Windows 7 and Windows 10 and on the MP4 files I say open with videopad and always comes up with the image stabilization. I thought this was a commandline issue but it's not I just say open with on the old versions it worked fine but now it always comes up with image stabilization on Windows 7 and Windows 10.

Most of my systems are not compatible with Windows 11 and I don't want to go there anyway. I have several Windows 7 machines that Microsoft in their wisdom thought they were fixing things when they went the Windows 10 but made things impossible. Example, you cannot format any type of media greater than 32 MB as FAT32. That is they are trying to push NTFS when certain machines like a chrome book does not support efat. I can still use third-party routines on wpm7 to format media up to any size I want FAT32. Microsoft has figured out how to get away from that and Windows 10 and 11.

Also you cannot turn off updates on Windows 10 and 11 easily.
 

Link to comment
Share on other sites

Success!!!!!!!

I just tried it with version 16.15 same problem with Windows Explorer right clicking open with "videopad".

I then check for an update v16.19 and tried the same problem again and it's gone!!!

So there must've been some type of problem. I will now try mice scripts to make sure they all work with 16.19.
 

Link to comment
Share on other sites

Bad news for Windows 7. :(

Apparently the program does a version check for not Windows 10. Rather than greater or equal to Windows 10. All Windows 10 versions seem to work but my older Windows 7 which I keep around because I don't want Windows 10 on that machine.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...