Jump to content

Axon fails to register with SIP server


Drarok
 Share

Recommended Posts

We're new to the VoIP scene, but after moving office we've gone totally VoIP.

 

We've tried a few softphones (SJPhone, X-Lite [aka eyeBeam] and Express Talk), and Express Talk seems to be the best of the bunch. The others were clunky or had issues such as a 5 second delay answering a call - not good!

 

We want to use a virtual PBX to be able to transfer calls between all the office staff (only 6 of us) and to share our 3 SIP "lines".

 

I installed axon on a test machine (my workstation) to try it out and it seemed to work pretty well. I forwarded port 5060 (both TCP and UDP - is that right?) and port range 10000-30000 UDP to my machine and set Axon accordingly.

After my tests, we decided to use it live. I installed Axon on our "server" computer (in reality just another WinXP Pro box) and this is where things took a turn for the worse.

 

Axon fails to register to the SIP server, saying that the server did not respond, yet inbound calls arrive.

Outbound calls are attempted, work briefly, but die after 10 seconds.

 

The server has no 3rd party firewall installed, and Windows firewall is switched off. It did used to have ZoneAlarm, but I removed that after we had trouble getting VoIP to work in conjunction with it.

 

Has anyone got any ideas what to try?

 

Edit to add this line from the logs:

23:50:32 Server [the SIP server] did not respond to register (sip:[username]@[the SIP server])

Link to comment
Share on other sites

Check, and check again your SIP settings in Axon. You need TCP ports 5060-5065 and UDP 8000-8020 open. Opening up TCP and UDP for both those ranges also helps. Custom port settings in Axon are possible but not recommended.

Link to comment
Share on other sites

The computer / server that you are hosting AXON on, does it happen to be sharing the internet connection with the rest of your office?

 

I have noticed that i am unable to route VoIP traffic between the extentions in 192.168.x.x through to the outside world on an XP machine, however, I removed the router and setup AXON on a Win2k3 server running DNS and ISA Server, worked a treat.

Link to comment
Share on other sites

Check, and check again your SIP settings in Axon. You need TCP ports 5060-5065 and UDP 8000-8020 open. Opening up TCP and UDP for both those ranges also helps. Custom port settings in Axon are possible but not recommended.

 

I have checked and rechecked, retyped all the settings more than once, and I know for a fact that the port forwarding is correct as it works for my workstation. All I change on the router config is the destination IP of the forwarded ports.

 

Mark: No, we don't use ISA or ICS as we have a proper ADSL router (Draytek Vigor 2600VG). I don't think it's a problem inherent to Windows, again because it works fine on my workstation.

 

If I could, I'd just run Axon on my computer, but it's decidedly underpowered and I need every CPU cycle I can get! :)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...