Jump to content

Transparency and Effect Masking Issue


Vixen
 Share

Recommended Posts

When adding images with a transparent background, videopad adds a black drop shadow to the image when it is placed on the timeline. Generally I just try to work with this but it caused an issue on the current project.

As an attempted work around, I tried to use the Crop tool with an effect mask to remove only the section with the issue, but it appeared to refuse to crop any part of the image while an effect mask was active.

During an attempt to work around this second issue by replacing the Crop tool with the Motion tool to simply move the affected area off-screen, I found that the actual issue is that when using an effect mask, Videopad was creating a duplicate, unaltered version of the image beneath the original while applying the effect to the selected part of the clip.

I have included a link to a project with each of these issues demonstrated-https://drive.google.com/drive/folders/1ANjDhSD7uUAbUEKaDTUV-TFi8481jyrr?usp=sharing

Is there any way to fix either of these issues either with the tools available or via a bugfix?

Link to comment
Share on other sites

Not seeing that here.  What VP version is being used.  Try the latest.  For licensed users upgrades are free for up to six months from purchase date.  After that, VP will continue to fully function but a fee will be required in order to register the newest.  Retain your old install file and registration info.

If you want to add effects to a mask, click the Clear Mask icon (to the right of the mask icon on the toolbar) first.

Snapshot - 1.pngSnapshot - 2.png

Link to comment
Share on other sites

I have paid to update to the latest version as requested- issue still persists.

I have updated the above google drive folder with two videos demonstrating the issue existing both in the editor preview and the exported file

Link to comment
Share on other sites

After further testing, the offset can be seen in preview, but not in export.  See the attached mp4 exported from v10.88.

The first half is pure white PNG lettering over a pure white background.  Thus, no lettering is displayed.

Then your slightly gray Example Text.png appears over the same background.  There's no edging or black border.

In your linked example very slight edging is evident on the motion/scaled word TEXT.  Seems pretty insignificant in normal usage

But your report has been forwarded.  So stay tuned for any further developments.

If preview outline bugs you, try this version, which looks clean in preview.

Link to comment
Share on other sites

If you want to apply a CROP to a masked area, try something like this...  image.png

 

As to the red boxes, to simplify...

  • Took a snapshot of a red blank clip.
  • Load the snap, place it on track 1 and Scale it to .25.
  • Load the same, place it on track 2, scale it to .25 and animate a Motion effect.

This may be about as clean as it's going to get with this saturated color, which likely isn't a common usage.

Still, your edge observations will be passed along.

You can also file a bug/suggestion.  Be specific...  https://www.nch.com.au/software/bug.html

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...