Jump to content

Old version required 6.29


Jason A
 Share

Recommended Posts

I bought an older version of VideoPad, and am constantly having to roll back to it due to auto-update issues that then tell me I need to pay for a newer version. Very annoying! The Support team told me to install an older version and sent me a link to a page that doesn't even have my older version. See here: http://www.oldversiondownload.com/oldversions/  I need 6.29, safe install, no additional ware or viruses. Can anyone help? Thanks. 

Link to comment
Share on other sites

There's a six-month grace period after purchase when updates are free.  The 6.x series is very dated. Newer versions can always be test driven, unlicensed.

6.29 is available here.  It's safe;  ignore any virus warning.

Link to comment
Share on other sites

Many thanks for your reply Borate. I only need the version I purchased. The link you provided doesn't do anything. I click and nothing happens. Even copy and paste, the exe file does not download. 

Link to comment
Share on other sites

Many thanks for your help again! I've managed to download it, avoided any prompts to update, and it downloaded successfully, however it looked different to my version. I then put in the Registration Code for my version, and got the message: "Invalid Old Version Code: The code you are attempting to use is not valid for version 6.29 of VideoPad (it was for version 5.xx or previous versions)." This is once more annoying, as the email I received from the VideoPad team, who checked my account, told me to download 6.29. Do you have a similar link for version 5? Maybe that will work. Thanks again. 

 

Link to comment
Share on other sites

Many thanks again Borate. Your second link provided a link to the version I purchased. I downloaded and installed, without clicking on any update options, and it still installed the latest version. I can't seem to get it to stop doing this. 

-0-0-

Stop press! I just tried one final option before giving up. Instead of uninstalling the version I have and reinstalling, I just tried installing the old version on top of the new one... and it worked.  Registration was successful. Thanks again!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...