Jump to content

Video artifacting/blurring on import of file and remains post export.


Recommended Posts

Sorry for another post, I am unable to locate my last one posted. I wasn't able to upload large files but have figured it out.

Problem: I boot up VideoPad, wait for it to fully be loaded, go to video files, add my file, wait for the buffering blue line to do its thing, then play the video to watch in the program and it has this heavy artifact and smearing.

Info: This happens randomly. It happens to .flv  .mp4   .mov  any video it will distort at random.
         I have nothing else running on my computer. JUST VideoPad.
         Videopad has been set to use graphics card via windows (this has made no change problem occurred before and happens after)
         Windows 10 desktop pc
         Happens with screen recording as well as files from my GoPro Hero 8 and Canon 80D camera - no files are safe to the glitching! 😮
         
Stills:  https://i.gyazo.com/7bab28a5f3edd10b742221ab8c84e85a.png 
           https://i.gyazo.com/be361a36045f2ac0e16dd3c3772ce905.png (it shows in the thumbnail on the timeline artifacted as well)

           https://i.gyazo.com/3affbd631af9eafc5770c35195f87a79.mp4

           https://i.gyazo.com/2e4ef948ad95ad8608a2143a8235f72a.mp4

Links to video:

The file as I see it just watching it normal with VLC or Movie player or whatever :   http://www.mediafire.com/file/5htdpuflos6x4ae/2020-08-31_17-49-50.mp4/file
How the file is after exporting it not even editing it just putting the file into the program and hitting export:  http://www.mediafire.com/file/lk1g5d5z41ky437/file
Ok - weird: The exported file doesnt have the artifacting. THIS TIME it has in the past. Now I'm even more confused 😧 
And here it is again (for giggles I tried an ez edit (placed a black .png over the names for blocking) and exported. Distortedddddddd >,<   :  http://www.mediafire.com/file/825v0e1bb2ptfnp/glitchy+again.mp4/file

Here is an example where the distortion DID keep:

Original: http://www.mediafire.com/file/jxcxbeacfbs7kyi/2020-07-29_15-39-48.flv/file
Export: http://www.mediafire.com/file/z5vqiegzuuwpym3/clip+with+distortion.mp4/file

I'm at a loss as to what to do. In the past I've been able to 'luck out' by rebooting my computer and keeping all other processes off or low and MAYBE sometimes it'll read a file right. I had one out of five GoPro .mp4 files that smeared like this and then did some rebooting and it 'suddenly' fixed itself. But now more and more files are just crapping out like this and it really disheartens me. I like this program, I had a lot of fun editing a clips compilation on it, an 18 min video with over 100 clips and so much tracking and animation... But now I can't even load a single 4 minute game clip to trim down? Nothing has changed with my PC, I have a computer than is more than capable of running it and has in the past.. I dont know what changed or how to fix it.

Any and all help or thoughts are much appreciated. 
Thank you for your time.

-V

Link to post
Share on other sites

Things you can try...

Shut down VP.  Restart.  Before loading the project click OPTIONS | DISK tab and Clear Unused Cache Files.

Under OPTIONS | EDITING, toggle the Use Hardware Acceleration item, to see if that makes a difference.

Install the latest version.  For licensed users upgrades are free for up to six months from purchase date.  After that, VP will continue to fully function but a fee will be required in order to register the newest.  Retain your old install file and registration info.

Update the PC video driver and Direct-X, if necessary.

AMD / ATI users:    http://support.amd.com/us/gpudownload/Pages/index.aspx
Intel users:              https://downloadcenter.intel.com/default.aspx
nVidia users:           http://www.nvidia.com/Download/index.aspx?lang=en-us
      
Update DirectX:    http://support.microsoft.com/kb/179113

You can also upload a short project that demonstrates the issue and share it here.  Someone will check it out. Just follow this procedure...

1.  With your project on the timeline, click on MENU at the top-left.  Click FILE|BACK UP PROJECT FILES TO FOLDER.  Choose a folder and SELECT FOLDER.
2.  Locate the saved, numbered folder and upload it to a free server - Google Drive, MS OneDrive, etc.*  (Don't upload the export or just the VPJ file.)
3.  Get a shared, public link. If using Google Drive click GET SHAREABLE LINK. Click the blue "Change to anyone with the link..."  Then click COPY LINK | DONE.
4.  Paste that link here, or click the folder, above top-right in this forum, and message it to me.  This is private and won't be shared.
*    Before uploading, right-click the folder, click PROPERTIES.  Look at the File Size to confirm that it's not too big for the free space on the server.

Link to post
Share on other sites

Clear Unused Cache Files is used often. For this process after every instance I have to do this as I get the popup I'm low on space which is odd as it's not happened before and that folder has been emptied manually to ensure space.

Toggled hardware Acceleration (It was on so i turned it off) - same results with artifacting.

Update my drivers regularly and double checked to be sure via Geforce experience and their web site. All is current.

Link to project: http://www.mediafire.com/folder/0buc1z5doqie6

Link to post
Share on other sites

There appears to be something funky with the file itself.  In the MPC-BE media player it's clean;  In VP it's a mess;  in another editor there's no video whatsoever.

How was the file created?  Try alternatives, if available.

Link to post
Share on other sites

The game/screen recording was recorded with Streamlabs OBS, though this happens with files created in any way.  
Here are the settings in Streamlabs OBS: https://i.gyazo.com/c8a48a8ad015b4aa50fcfb6cdae0c188.png
The file type is currently flv but had the same issues when recording in mov and mp4

Which makes it even weirder since it's not just one source of video but 3 different devices. (PC, gopro, canon) I have other editing programs and putting the same files in them I get no  problems at all. The video is fine, but i don't use those programs.

The file you sent back goes into VP no issue. It works smooth, no artifacting. 

This fishing video I took of my dad on the Gopro did the same thing in VP and it smeared etc, did the reboot song and dance a few times, gave up, came back a few days later and oddly the file works fine. I've even pulled the file itself (it was in a project) into its own project to test if it'd glitch, and even did so just now, and the file works still. I have no idea why it appears to 'fix' itself at random, and for random files.  http://www.mediafire.com/file/j52c242pmkdfjzv/GH010185.MP4/file here is the file if you want to take a look at it as well. Its a 1 min clip off the gopro.

Again, thank you greatly for the help I know this is a weird issue and I appreciate the time taken.

Link to post
Share on other sites

Nothing 'fishy' about that file here.  Previewed and exported without a glitch.

As for no problems in other editing programs, note that the game file was loaded into another very competent NLE here.  The video track was blank.

  Some things were never meant to be known...

Link to post
Share on other sites

Long story short, hire a young and old priest and get the salt.. GOT IT!!  LOL

Using small low quality clips worked fine. Or has in the past. I changed the quality from med/low to high in SLOBS and since then has been an issue. But a hit or miss issue. Which is beyond frustrating because I never know if I file is going to be good to edit or not based on the programs mood. And considering the gopro files do it as well I'm just at a loss as to whats wrong.

Sometimes a 4 minute clip works, sometimes it doesnt. Sometimes a 45 minute clip loads fine, sometimes it doesnt. I was even willing to throw down hard cash to upgrade my PC but a buddy of mine looked over the specs and said there really shouldn't be an issue. I thought I needed more RAM or a better processor for thinking but apparently they are still good to use.

This causes me some stress as I've been shooting HD stock footage for resale and I'm anxious I wont be able to use VP for the trimming and cutting out the audio to add music. So the most basic of editing really..

At this point I think I'm going to dig out my old Win 7 rig and see if there's a difference. It was a surprisingly hefty beast before I moved onto this rig (which has only been troublesome since i bought it tbh..)

Like you said, sometimes things just don't work and I need an exorcism on the whole shebang however I do need to find a solution even if that means having to learn yet another video editing program AGAIN. (I don't want to ugh)  I learned VP for a project in like a weeks time and have been loving it when it DOES work, but I need to move out of potato quality if the work is to be taken seriously, be used for profit and not be grainy against my clear graphics/overlays etc.

I'll also try messing around with the settings in SLOBS as the files coming from it have the issue more than naught, as well as the other computer and see if the results change.  The only other thing I've done that's 'helped' has been to put the files in a basic editing program and either chop it in half or into smaller clips and or do that plus lower the quality :(

I'll touch base in a couple of days after tinkering with things again and see if it yields any other results. 

Thank you again!
 

Link to post
Share on other sites

Ran test with the other editor.

The 2.17GB file would not display video - blank screen.  VP did better.

'Glitchy again' played, but had the same errors as in VP.

'Fishy' was dandy, as in VP.

So neither the NLE program nor the PC's resources appear to be at fault.

Many other projects reviewed here have had GoPro source files.  No pixelation.

Time to call in the Rabbi?

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...