Jump to content

How to Sign in PhotoPad Image Editor

Recommended Posts

Where is the page that allows the user to sign in to Photo Pad?  I can't find it.  I assume a password is required.  Where is it supposed to be entered?  If I enter "PhotoPad," it cannot be opened, which tells me that a password is required.  I will appreciate any guidance members can provide.

Link to comment
Share on other sites


PhotoPad doesn't have a password or any kind of sign in mechanism.

You might be referring to the registration code (numbers-letters) that is entered into the program in order to license it.
After you purchased your license you should've received an email with a 12 or 13 digits serial number that must be activated at https://secure.nch.com.au/activate/index.html  in order to generate the registration code. Sometimes you'll receive the registration code up front.

The registration code is entered by going to File > Register Software...

Link to comment
Share on other sites

  • 2 years later...

I have just Paid for Photopad pro and I need to license it. NCH requires a registration code (numbers-letters) inserted into a box. However I was sent

a code the had numbers then a dash then lower case letters. 

Example 266459-zknzzjvj    

this is a fictitious code

I have tried to enter the numbers and no dash then five of the lowercase letters to add up to the 12 required. 

after about 6 combinations an error message came up each time. 

Please Help as YOU HAVE MY MONEY  and I cannot use the Pro program 

I have tried to ring (the Australian Number) and message told me to enter my passcode 

where do I get a copy from


Looking forward to your reply 

Edited by ETH
Link to comment
Share on other sites

38 minutes ago, N_C_H_josh said:

We'd need to see the error message. What did it say? 

IT said that the numbers entered is incorrect 

Regards you need to see error message  I have tried copy and tried to paste in this reply DOES NOT WORK 

What next !!!!!!!

Link to comment
Share on other sites

Hi Josh 

your post I'll message you. The registration code that you posted is off by a character. I edited your post to remove that code.

what and where is your message 

I think I saw somewhere the last 3 letter juj were wrong ??? 

this is frustrating and I am 80 year old, and I need that pro as I am writing a book and I need to edit some scanned photos.

being 80 does not mean I have lost my mind. it works very well 



Link to comment
Share on other sites

Thanks Josh But when I tried to enter it  as 4596336zunzzjvj as in your message said I got an error message 

www.nch.com.au says 

Please enter a valid serial number. It should be 12 or 13 digits and contain only numbers  

what am I doing wrong  I could send you a copy via email if this would help


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...