Jump to content

Exported Video MTS Is Freezing


Recommended Posts

New topic here, as the thread was dated.


  • Videopad 12.28 64 bit (which I believe is the latest build)
  • Win10 machine (64-bit operating system, x64-based processor)
  • AMD Ryzen 3 3200G with Radeon Vega Graphics       3.60 GHz
  • 32 GB RAM

Video Files

  • From a Canon Vixia HF M41 Camera
  • File Type -- .MTS
  • Individual File Size/Length - Just under 2 gigs each/11:24 in length (the camera splits the scene into individual files)
  • Resolution - 1920x1080 at 29.97 fps

Problem Definition

  • When I butted 2 sequential files together on the same track, the preview in VP played fine, however, on export to an MP4 file at the same resolution, the video on the first minute or so froze. Audio continued as normal. After a minute, the output file UN-froze and played normally.

What I Tried   -- Everything I could think of, including (not in order)-

  • Updating (I was already at the latest and, presumably, greatest)
  • Restart
  • Clear Cache
  • Reboot
  • Start a new project with JUST the 2 files butted against each other (same result)
  • Output to a different file type (.mpg)

Same result on all of these

Eventual Resolution

  • Convert the files to individual .MP4 format
  • Start a new project butting the two MP4 files together, and exporting to a new continuous  .MP4 file
  • Import the resulting MP4 into my original project and use that in place of the segment that butted the 2 .MTS files together
  • Export the entire project as .MP4 (1920/1080 29.97fps)

That worked!!! Hooray - but what a pain in the ass!!!

Anyway, I hope this helps somebody. What should have been a 1-2 hour job turned into about 4-5 hours of frustration. 

Good luck, and let me know if questions

Link to comment
Share on other sites

  • borate changed the title to Exported Video MTS Is Freezing (NH_Nick)

Using version 12.28(64), three MTS files were butted together here and exported at 720 mp4 default settings without problems.

Please share the project here or in private, and someone will check it out.  Takes but minutes.  Just follow these steps closely...

  •     Back up --- With your project on the timeline, click on MENU at the top-left.  Click FILE|BACK UP PROJECT FILES TO FOLDER.  Choose a folder and SELECT FOLDER.
  •     Upload ---  Use a free server - Google Drive, MS OneDrive, etc.* - to upload the saved, numbered FOLDER.    Do NOT upload the individual VPJ or export file. 
  •     Get link --- Get a public link.  If using Google Drive click GET SHAREABLE LINK. If necessary change "restricted" to "anyone with the link can view" 
  •     Share ---     Click COPY LINK | DONE.  Paste that link here, or click the folder at the top-right of this forum to message it privately to me.  It won't be shared.

          *    Before uploading, right-click the folder, click PROPERTIES.  Look at the File Size to confirm that it's not too big for the free space on the server.

Link to comment
Share on other sites

I overwrote the original project where the problem initially manifested, but recreated it (the problem) with a simpler project (just 2 MTS files). I followed your instructions and placed the backup in a Google folder at:


Please note  -- Contrary to your instructions, I also uploaded an exported  .mp4 file from this project. I'm not sure how else I would show the problem. That export file is in the same Google folder as ProblemDemo_113022.mp4, The issue manifests at around the 1:15 mark of this file (this is where the 2 files butted against each other on the timeline)

Please let me know when you grab that so I can free up space on the Google drive.

Thank you for your attention to this.


Link to comment
Share on other sites

Replicated that fault, using your project VPJ file.  But got a clean export when simply butting the two files together.

That said, with a thirty-second snippet containing the join between the two files, the second file froze when the frame rate was 29.97.

At most other frame rates, there was a slight discontinuity at the join but no freeze.

Suspect this to be a file issue - perhaps the manner in which they were split - and will pass it along to the developers.

This could be of interest.

Thanks for sharing.

Link to comment
Share on other sites

That's rather unsatisfactory. I understand that software often has bugs, but I feel like I'm beta testing something that I pay a substantial fee for using. To be told to "stay tuned" and we might get around to fixing this, is NOT a satisfactory response.

Is there some slightly higher life form than a mysterious "borate" that I can hear from?  I feel like I'm owed some compensation for my beta testing efforts.

Link to comment
Share on other sites

Nothing mysterious about 'Borate', who is but a helper in this peer forum.

There will always be some bugs, which are quickly addressed if confirmed.  Your concern is being seriously looked into by a 'higher life form.'

'Stay tuned' means that if further info surfaces it will be reported here.

Unfortunately, a fix for one issue sometimes can be detrimental overall.  So, no guarantees.

As mentioned, another NLE also displays a slight 'bump' at the juncture of the two files.

Link to comment
Share on other sites

I can appreciate and celebrate your efforts, especially if you are but a "helper" in this forum. I had assumed you were associated with support at NCH. I apologize for any grief I've given you based on that assumption.

Can you advise on how to get in touch with somebody at NCH that can provide some insight and potential resolution?  Perhaps that's the "higher life form" I seek :) 


Link to comment
Share on other sites

Done. I don't have a contract with them, so I'm expecting a response about 10 o'clock next summer :) :) 

Again, my apologies for any grief I gave you based on a my mistaken assumption. I can just imagine the headaches associated with running this forum - especially having to deal with jerks like me :) - and I now have a deeper appreciation for the service you're providing with this.

Have a great day!!!

Link to comment
Share on other sites

No grief.

Can't comment on NCH official support, but this forum may be just as, or more, effective in many cases.  Many eyes - including programmers.

Bugs and observations are passed along to developers.  That's about as high as it gets.😉

Out of curiosity, does the Canon Vixia offer other formats, frame rates, or file-splitting methods?  They might be worthy of experimentation.

Link to comment
Share on other sites

Quick update re: your suggestions

  1. There doesn't appear to be an option in the camera to change formats - I guess I'm stuck with .MTS
  2. I tried another Frame Rate. The "standard" rate on the camera is 60i, but it also offers PF30 and PF24. I had been shooting at 60I, but I did some experimentation with PF30 and got the and same result
  3. I haven't found anything for file splitting methods, or, for that matter, file size/time, as of yet, but may be missing something. Stay tuned n that one.

Stumper, huh? Again, thanks for your help. 😀


Oh, BTW - I provided all the files and a link to this thread to "Emile" on the Customer Support Team at NCH in late November, but no joy from them as of yet. I'll update when/if anything happens.

Have a great holiday if we don't connect before then!!

Link to comment
Share on other sites

  • 2 weeks later...
  • 3 weeks later...


Just this morning (at 1:55AM) I received the following from programtrack@nchsoftware.com:

"You previously filed the bug-report or suggestion:
 VideoPad: After export, the 2nd MTS file freezes (only happens if the frame rate matches the original files)
This has now been implemented or fixed and a new version has just been released. You can download the new version using this link.......:"(Not sure it's appropriate to share the link)

I'm still feeling that I'm owed something for a) the frustration, and b) my beta-testing efforts. Anybody have an opinion?


Link to comment
Share on other sites

Thanks, borate.

I'm actually pretty frustrated with NCH. I thought the link they provided lead to a download of the latest version (as did the one I just realized you sent me before the holidaze), but it brought me to a page of NCH Software Beta Prerelease Versions and I only see Ver. 13.00 on that page.

This is one of the most frustrating companies to deal with. You've been orders of magnitude more helpful (and more friendly) than they ever have been. 

It may be time to find a new editing application.

Again, thanks much for your assistance.


Link to comment
Share on other sites

  • borate changed the title to Exported Video MTS Is Freezing

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...