Jump to content

95 - 100% CPU Usage when using the H265 Encoder for .mkv file

Jeff Neumann

Recommended Posts

I have 2 machines with Debut and for the last year or so when using the H265 encoder recording a mkv file  with default video and audio quality, the CPU is close to max on each machine when recording the screen.  These are not slouch machines, one is a Dell XPS 9570 with an Intel(R) Core(TM) i9-8950HK CPU @ 2.90GHz, 2904 Mhz, 6 Core(s), 12 Logical Processor(s), 32 gigs of ram and the other is an Lenovo m98 desktop with an Intel(R) Core(TM) i7-4790 CPU @ 3.60GHz, 3601 Mhz, 4 Core(s), 8 Logical Processor(s), 32 gigs of ram.   Both have Nvidia video cards, the desktop is an NVidia Quadro P400  with 3 screens, the laptop has a GTX 1050 Ti with Max-Q.  I feel neither of these machines should be sweating while recording with the H265 compressor, but both do.  Is this normal?  This doesn't happen with the H264 compressor, and I don't really use any other compressor besides these.  Debut has this thing it does sometimes when it updates where it switches the file type back to mp4 and the compressor defaults back to h264, which is really annoying because I record screen 8 hours a day in 2-4 hour segments.  And we're not talking gaming, this is everyday IT system and network administration.  Not something that requires a ton of screen updates at 24 fps.  


This issue is mostly a problem on the laptop because when i'm in a meeting, the fan on the laptop is screaming away because of the maxed processor.  You can't tell me this is normal, if it was, every newer DVR on the market would be equipped with a huge cooling solution to record 8+ cameras at once.


Can someone please explain this and let me know if they are experiencing the same processor loads?

Link to comment
Share on other sites

  • 9 months later...

HI @Jeff Neumann,

You can limit the CPU usage of a process which would use CPU 100% down to 50% (or any percentage you like). You can try the following steps:

- Go to Control Panel.
- Hardware and sound
- Power options
- Edit plan settings
- Change advanced power settings
- Processor power management
- Maximum processor state and lower it to 80% or whatever you want. Using software that measure CPU temperatures like 'Speed fan' you will see that temperatures drop.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...