Jump to content
Sign in to follow this  
webvault

Some Users on Extensions are Constantly losing their calls - HELP!

Recommended Posts

I have a problem that will see me quit using Axon & IVM unless I can get a solution for this problem!!

 

Quite a few users using extensions on our Axon server are constantly losing their calls. The calls do not hangup, instead they just go quiet.

 

We are using Engin as the SIP carrier for most of our outbound/inbound calls configured as an External Line in Axon. I have played with the two SIP compatability options for this external line, and it does not seem to make a difference either way!

 

Research in whirlpool and various SIP related sites, indicate this is a probably a NAT issue, as most of the calls lose/timeout about 5:32 seconds, or 7 minutes. The axon server is NOT behind a NAT router (public IP).

 

However the users on the extensions ARE behind various NAT routers on several DSL networks, using either Sipura-ATA 3000 or Grandstream GXP2000 handsets. I have tried every conceivable setting related to NAT on these devices, as well as switching NAT routers and settings up a DMZ for the users IP phone.

 

If I take Axon out of the picture and setup the IP phone to register and make calls via Engin directly, they no longer experience the problem! So either the problem is with Axon, or Ive missed something!

 

Im willing to pay for a solution to this one, or purchase Axon support if I could be assured they knew what the problem is. I just bought IVM, so I'll be disappointed if I have to switch SIP PBX's.

 

Thanks in advance to anyone with a suggestion!!

Share this post


Link to post
Share on other sites
I have a problem that will see me quit using Axon & IVM unless I can get a solution for this problem!!

 

Quite a few users using extensions on our Axon server are constantly losing their calls. The calls do not hangup, instead they just go quiet.

 

We are using Engin as the SIP carrier for most of our outbound/inbound calls configured as an External Line in Axon. I have played with the two SIP compatability options for this external line, and it does not seem to make a difference either way!

 

Research in whirlpool and various SIP related sites, indicate this is a probably a NAT issue, as most of the calls lose/timeout about 5:32 seconds, or 7 minutes. The axon server is NOT behind a NAT router (public IP).

 

However the users on the extensions ARE behind various NAT routers on several DSL networks, using either Sipura-ATA 3000 or Grandstream GXP2000 handsets. I have tried every conceivable setting related to NAT on these devices, as well as switching NAT routers and settings up a DMZ for the users IP phone.

 

If I take Axon out of the picture and setup the IP phone to register and make calls via Engin directly, they no longer experience the problem! So either the problem is with Axon, or Ive missed something!

 

Im willing to pay for a solution to this one, or purchase Axon support if I could be assured they knew what the problem is. I just bought IVM, so I'll be disappointed if I have to switch SIP PBX's.

 

Thanks in advance to anyone with a suggestion!!

 

 

Hi there,

 

Don't know how much help i can be, but here goes...

 

I have a Sipura 841 hardphone behind an NAT, which I'm assuming will be kind of similar in set up to the ATA you're using.

 

I actually had trouble with the phone registering to engin WITHOUT the software - all good now.

 

I think the main thing has to do with the login intervals and NAT settings.

 

Try this...

 

Make sure NAT Mapping enable = NO

NAT Keep Alive = NO

Register Expires = 900

Proxy Fallback Intvl = 3600

 

I have no problems making calls for as long as I like. I'm not staff, nor am I a techie, but I do know how frustrating these things can be and also how good they can be when you get them worked out.

 

Good Luck!

 

Hope this helps :)

Share this post


Link to post
Share on other sites

Thanks for the response.

 

Unfortunatley Ive already tried these settings you suggest, and it hasnt helped.

 

Since this post, ive tried extension to extension calls with Axon, from the affected user(s) handset, and the same problem occurs. So I know the issue is not with the SIP carrier.

 

Im convinced the issue is NAT related, or something else related to SIP packet loss, but it must have something to do with Axon in particular, or my network with these users. Does Axon send some kind of Keep alive packets, which are easily dropped by some routers/networks, which would cause lost calls? Why is Axon sensitive like this?

 

Go figure.

Share this post


Link to post
Share on other sites
Im convinced the issue is NAT related, or something else related to SIP packet loss, but it must have something to do with Axon in particular, or my network with these users. Does Axon send some kind of Keep alive packets, which are easily dropped by some routers/networks, which would cause lost calls? Why is Axon sensitive like this?

 

You are using hardphones, and you tried moving them to a DMZ so as to rule out the NAT firewall from the picture (ie. phones and the Axon server are both directly accessible from the Net with no NAT in between), but calls still fail at some point. So I would guess that Axon is the culprit.

 

FWIW, here's what I observe using 1.09:

- sometimes, clients that are located behind a NAT can no longer register to Axon accross the Net

- sometimes, Axon no longer reports incoming calls that are routed by a Linksys SIP gateway.

 

In both cases, restarting Axon solves the issue. That doesn't definitely confirm that Axon has a bug there, but as a test, you could restart Axon every hour or so, and see if calls no longer go quiet.

Share this post


Link to post
Share on other sites

Have you tried asking your SIP carrier to set up IP Authorisation?

 

This requires you to have a static IP address from you ISP, you the tell your SIP carrier your IP address, then AXON PBX doesn't have to keep checking for registration from you SIP carrier.

 

Works for us with Voipfone.co.uk

 

Regards

 

Ray

Share this post


Link to post
Share on other sites

There's  a better way

Log on to your axon web panel 

navigate to external dialing 

click on your external line 

click advanced line settings

Scroll down to sip compatibility 

and select Disable call activity polling (only use if call breaks after 60 seconds)

then click save changes

and click save changes again

and you are now ready to go

 

Thank you 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...