Jump to content

VEC footpedal & Mac OS X (10.3.9)

Margaret King

Recommended Posts

I am using Express Scribe 4.03, and am unable to use my VEC USB footpedal. Under Apple's System Profile, Hardware, USB the following information is listed...

VEC USB Footpedal:


Vendor Name: VEC

Speed: Up to 1.5 Mb/sec

Product ID: 255 ($ff)

Bus Power (mA): 500


When I open Express Scribe and go to the Preferences, under Control, I have "Use USB Foot pedal Control" checked, but none of the actions defined do anything. I tried setting all the Pedals to the action of "Minimize Express Scribe" and still nothing happens. I have also tried using the other USB port, no change.


Am I missing something? I was thinking I might need to upgrade to Tiger (10.4), but many people in the forum seem to be running Jaguar (10.3).


If anyone can provide any help, it would be much appreciated.



Link to comment
Share on other sites

Guest nchpm



Unfortunately the VEC foot pedals do not work with the Mac. The Order Hardware web page for foot pedals states in the description of each foot pedal model what the system requirements are, and for the VEC USB model says: "Requires: Windows, USB port and Express Scribe Software."


Only the VPE USB model says: "Requires: Windows or Mac OS X, with a USB Port."


The "more info..." link in the foot pedal descriptions also takes you to www.nch.com.au/hardware/pedals.html where there is more information about the VEC and VPE foot pedals and operating systems that they can be used on.



Link to comment
Share on other sites

  • 2 weeks later...
Guest Norbert Rillera

Good day. A friend of mine recently bought a big box of footpedals by Sanyo. It turned out that the connectors were designed for PCs but for cassette players. I converted one of the foodpedals for connection to a serial port using the Express Scribe suggestion to connect pin 1 for play/forward, pin 6 for reverse, and pin 4 for ground and it worked.


However, when I converted the rest of the footpedals for serial port connection, the same Express Scribe footpedal setup wizard is not responding when I press the pedal for reverse as prompted. I checked the connections from the microswith to the designated pins using a tester, and it works.


I can't figure out why first converted footpedal works while the rest that have the same pin configuration do not. I really appreciate some help here. Thanks.


By the way, the casing of Sanyo FS-92 looks quite similar to that of VEC Serial Footpedal.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...