Jump to content

Recommended Posts

I've just recently reinstalled Videopad on my Windows 10 Asus laptop. I paid $70 (that includes the taxes) for the Master's edition, and the version that I currently have right now is 10.78. I used Videopad for over a year and that was last year, so I perfectly know how to use Videopad. Unfortunately, I decided to uninstall it because it was starting to anger me with all the bugs and glitches that I had to suffer with it. At certain points it became so bad that it would literally even CRASH on me and close out the application by itself. But now I decided to reinstall it; but the problem is that the audio doesn't work. What I mean is that it won't fully process the audio clips, and it comes to the point where it feels like it will never fully process the audio clip. I decided to reinstall Videopad once again, but the problem was still there. I even checked the video files and the photo files to see if those wouldn't work as well, but they worked perfectly fine. I was also capable of editing them too.  I even waited for 30 minutes straight to see if it would take a long time to process the audio since it's been a while since I've used Videpad, but it never fully processed. It would just keep saying "processing." And it's a problem because I can't look at the actual soundwaves of the audio that I'm importing into the editor, and I can't use any of the audio effects either because a message pops up saying, "Can't edit effects while audio clip is still being processed." Now keep in mind that Videopad is already on my bad side due to the bugs and glitches that I constantly had to put up with for over a year. And no, I did not install Videopad from a random website; I literally installed it from the NCH website. But now that I decide to give it a second chance and REPAY $70 in order to get the masters edition, it doesn't even work properly? That's completely ridiculous. I shouldn't have to waste my hard-earned money on something that doesn't even work properly in the first place. I just wrote a message to techinal support about half an hour ago to see if they would help me with my problem, but I felt like it would take a long time before they even see it. Not only that, but I even checked on forums to see if people were suffering with the same problem that I have, and I saw that there were people who also suffered with this. Those forums were from last year, but quite frankly I didn't really get anything out of those people. Because the people that were helping out didn't really give any real solutions or actual steps on what you can do yourself in order to resolve this issue. They were basically just saying, "Oh, just install this version of Videopad and let me know if the audio still doesn't work." They just left a link for you to click on and it would just be the videopad setup all over again. That is not help. That is just being lazy and not going into the roots of the problem. So I apologize for the very long post, but if anyone could help me and provide me with real steps on what I can do to resolve this issue, I'd really appreciate it; because I do not want to have to refund my money because of a software that doesn't even work properly when you just got it. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...