Jump to content

Sipura 3000 Configuration


Recommended Posts

Guest Peter Egan

I am assuming you want to be able to dial out via the Sipura PSTN line.

There does not seem to be a way to configure the PSTN port as an Axon exchange line.

 

By enabling VoIP->PSTN in the Sipura and having the PSTN Line register on its own extension, you could try this (untested):

 

FXS extension: 101

FXO extension: 102

 

To dial out the FXO via Axon, you would dial 102,xxxx where xxxx is your desired destination. The theory here is that the Sipura will answer the 102 the , will insert a pause and then the number xxxx will be dialled

 

Peter

 

Hello,

 

Does anyone have a configuration guide for the Sipura-3000 with Axon? I'm very close in configuring the Line 1 FXS port, but I just can't understand how to configure the PSTN-FXO.

 

Thanks!

Regards...

 

Mario.

Link to post
Share on other sites

Got it :D

 

First create an Extension and External line account in AXON. After that, register the Sipura 3000 with these details (Subscriber Information). After that, add a dialplan like (<sip:ExtensionNumber@IP-ADDRESS-FROM-AXON-SERVER:PORT>)

See for correct extension number the status screen from AXON.

Link to post
Share on other sites

Hi Peter and Ferry,

 

I appreciate your help but I'm still unable to make it work.

 

Maybe if you could help me giving me a detailed configuration example (what exactly to configure in Axon and what exactly to configure in the SPA, including Extension, Dialing Plans, External Lines and PSTN tab on the SPA) I could make it work.

 

Thanks again for your help.

 

Regards,

 

Mario.

Link to post
Share on other sites
  • 4 weeks later...
Hi Peter and Ferry,

 

I appreciate your help but I'm still unable to make it work.

 

Maybe if you could help me giving me a detailed configuration example (what exactly to configure in Axon and what exactly to configure in the SPA, including Extension, Dialing Plans, External Lines and PSTN tab on the SPA) I could make it work.

 

Thanks again for your help.

 

Regards,

 

Mario.

 

I cant use pstn to outgoing calls from an extensios i call 101(number of sipura pstn extensios) pause and phone number but the sipura don't use pstn

why?

Link to post
Share on other sites
  • 2 weeks later...
I am also unable to configure Axon to use the FXO in SPA3000 as an external line.... any suggestions would be greatly appreciated !

 

I've got it working with one bug (I'll go into the bug at the end)...

 

In Axon you'll need to set up two accounts for the SPA3000, I've called mine FXO1 and FXS1.

 

In your browser, goto the ip of the SPA3000 and login as admin and advanced. Goto the Line 1 tab (this is the FXS).

 

Keep everything factory default except:

 

- under Proxy and Registration set the Proxy to the IP of the machine running Axon, leave "Use Outbound Proxy" off. (or turn it on and set the outbound proxy to the same value).

 

- under Subscriber Information set the Display name to FXS1 (Or whatever you want), User ID = what you set in AXON and Password = what you set in AXON.

 

That's it for Line 1, it should be able to log into Axon... Now goto the PSTN Line (FXO) tab.

 

Keep everything factory except:

 

- under Proxy and Registration set the Proxy to the IP of the machine running Axon, leave "Use Outbound Proxy" off. (or turn it on and set the outbound proxy to the same value) - same as above.

 

- under Subscriber Information set the Display name to FXO1 (Or whatever you want), User ID = what you set in AXON and Password = what you set in AXON.

 

- under Dial Plans, set one to "S0<:sip>" without the quotes - sip is the extension number that you want incoming calls to ring on, i.e. the extension of a VOIP line in IVM...

 

- under VoIP to PSTN Gateway Setup, Enable = Yes, VoIP Caller Auth Method = none

 

- under PSTN to VoIP Gateway Setup, Enable = yes, PSTN Caller Auth Method = none, PSTN Ring Thru Line 1 = no and PSTN Caller Default DP = 8 (whatever you used above).

 

- The only other thing I've changed on the SPA3000 is under the System tab, HostName to SipuraSPA1 because I'm planning on using more than one of these devices...

 

That's it for the SPA3000, the pstn should also log into Axon... Now onto Axon:

 

You've already setup the two extensions now you need to configure an external line. I've renamed Default to Default1 because of the multiple SPA3000's (you don't need to) so under External Line:

 

- Line Name = Default1

- Server = <ip of the SPA3000>:5061 - 5061 is the default port for the FXO

- User = User

- Password = Blank

- Incoming calls on = None - The dial plan on the SPA3000 takes care of this.

 

Dial Plan: Nothing Special, just change the plan for 9 and 0 to use Default1.

 

 

This is working for myself... Now the bug...

 

The External Line is configured for a server and Username/Password so AXON tries to register that username with the SPA3000 and reports and error (but still works because the SPA3000 is set to require no auth user). When I "hover" my cursor over the Server entry in AXON it says to leave blank and then use the FXO line number as the ID (I'm guessing to leave the password blank also).

 

This makes sence - the FXO is configured as an extension so you're simply telling AXON that that extension is the external line... Bug = this doesn't function...

 

Am I doing something wrong???

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...