Jump to content

Incoming connection does not support proper SIP codecs


Recommended Posts



I'm trying to get IMS to work with the Axon, IVM setup.


Axon & IVM works perfectly without any problem. But whenever i dialed the extension 197 via IVM or tries to have the MOH of my SPA device setup to load from 197.


There is this line that reads "Incoming connection does not support proper SIP codecs" in the console of IMS.


I could not think of what codecs its referring to and could not find any resolution to this problem anywhere.


I really hope someone could help as i'm currently evaluating this group of software.



Link to comment
Share on other sites



I received this response from development:


"Basically, this means that the SPA device while negotiating how audio will be sent did not offer any options that IMS supports. We offer the following options (codec/sample rate):







If a phone (SPA) is configured to not allow the formats listed above then the call cannot be connected because there is no encoding we can send that they will be able to receive and vice versa. This can be seen by turning on SIP trace in Axon and then looking for the INVITE message sent by the SPA when attempting to connect to the MOH server. My guess is that his SPA is requesting either different codecs (G729, etc.) or a different sample rate (16000, 11025, …).


The message should actually read “RTP codecs” rather than “SIP codecs” to be more clear."


If you have additional questions or concerns, or you would like to get more information regarding this response, please log a ticket in our tech support system at this link: Log IMS Support Ticket



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...