Jump to content
Nick V

Still images replaced with black screens.

Recommended Posts

Greetings all!

I'm hoping that someone may be able to help with an extremely frustrating and baffling problem. I've experienced it before, but never as badly as I did today.

I'm compiling a video project approximately 14.5 minutes long. It consists of video clips interspersed with still images (video track 1). Early on, a group of other stills is superimposed (with semi-transparency) over the main video track (video track 2). A group of voice-overs runs in parallel (audio track 1), and the project has music from beginning to end (audio track 2).

The problem was that today, Videopad seemed to break its links to certain still images in the project. When this happens, the affected still image is replaced by a black screen in the exported video. Sometimes you can see this in preview mode, other times not, but it's always obvious in the exported video.

In Timeline view, I've been right-clicking the offending clips and trying to use the 'Replace selected clip' option to replace them with the same clip. Sometimes this helps, but I've re-compiled the video four times now, and each time I use this method, Videopad just 'black-screens' the relevant clips at other points in the video. As I said, it's happened before, but now it's gotten to the point where the exported video is almost unwatchable. Links are breaking faster than I can fix them.

More observations that may help solve this:

  • Audio tracks are unaffected in the exported video.
  • Only a specific handful of still images are affected by the 'black-screening'. Video clips are not affected.
  • Image format: I'm using a mixture of approximately 80% *.PNG images, 20% *.JPEG.
  • Sound format: the VOs are exclusively *.WAV. I can't remember if the music track is *.WAV or *.MP3 (I live and work in different cities).
  • I'm exporting in *.AVI format, YouTube 720p. I THINK the codec I'm using is H264.
  • All source material I'm using to compile this project is on the computer's local hard drive. No external drives or servers are involved, expect for source file transfer between computers.
  • When exporting, I tried setting the frame rate to constant and variable, 30 FPS and 25 FPS. None of these options make a difference.
  • The source material is stored several folders deep in the file structure. I don't know if VideoPad has any restrictions on file path length that I might be violating without knowing it, but I really would prefer not to move the material if I can help it.
  • The computer is a new Dell Precision 7520 laptop. Core i7 CPU, 500 GB SSD and 16 GB RAM, running Windows 10 64-bit.

Thanks for any help, guys! It would be greatly appreciated.

Nick

Share this post


Link to post
Share on other sites

Videopad 5.11 is now available for Windows.

To help solve your issue, isolate a portion of your project that has the black frame problem.  Here's how...

On the timeline, make a split about ten seconds before and after a black frame.

Right-click on the newly created clip and COPY.

Click the + sign at the right of the sequence 1 tab that's above the timelne.  This will create a blank sequence two.

Right-click in the track area and PASTE.

While still in sequence 2 click FILE|SAVE AS PORTABLE PROJECT.

Upload the result (folder and the files it contains) to DropBox, Google Drive, MS OneDrive or the link.  Make it public and post the link here.  Someone will check it out.

If you like, you can do this with several problem areas and post a link to each, discretely.

Share this post


Link to post
Share on other sites

Hi again Borate! Thanks for the help so far.

I managed to solve the problem. Just before I sent my call for help, I trawled the internet for any information that might describe the problem and possible solutions.

I found threads on this forum that detailed being unable to play exported videos in Windows Media Player after being encoded using H264. That was also one of my issues, so on a hunch, I changed the encoding type to MPEG. Problem solved: no more black-screening. :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×