Jump to content

ExpressTalk Crash on call

Recommended Posts

I was able to use the trial BE version of ExpressTalk with our VoIP setup but the app expired and I forgot about it. Recently the need came up to use it so I came back and paid for the license only to find out that the app doesn't work anymore.


I can use SIPCommunicator to place calls and talk so I know that the server and my network are OK.


With ExpressTalk, when I place a call, the other party rings, then the application crashes in a rather funky way as soon as the other party picks up.




This is on Mac OS 10.5.3. I did notice the app is only PPC; I don't care as long as it works but I'm starting to wonder if this product has been abandoned. I tried contacting Support but never heard back from them.


Is anybody having this problem?



Link to comment
Share on other sites

It's a bit strange if it only works on PPC considering this product is primarily built to run on Intel based PCs (meaning it'd be a lot easier for them to port it to Intel Macs).


If indeed it only runs on PPC, I would have to take a guess and say the Mac version probably a bit old and has a low demand, thus is not being actively worked on to resolve bugs and provide updates.


I don't have a mac, so I can't really test the software.. however I do have an OS X Intel vmware emulator and every time I try and run Express Talk it takes up 100% CPU and I literally can't do anything (I can see the GUI but the app is basically frozen solid).

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...