Jump to content

Wrong Private IP address selection


MageMinds
 Share

Recommended Posts

Hi I have recently installed Axon, but when I start it it doesn't get the right Private IP address. This is because I have VMWare Server installed and it install two virtual interface and Axon takes the ip address of one of them.

 

It would be great to allow the user to select the interface to bind to ... The server listen on all interface, but SIP signalling doesn't contain the right IP address so devices on the network doesn't work properly since they can't find the server at the specified address inside the SIP signaling packets.

 

I managed make Axon to get the right IP address by disabling all adapters in the network management console and only keeping the one that should be used.

 

Also, I have a dynamic IP address with a dyndns.com updated automatically, but I can't seem to be able to use a FDQN in the Static IP address field, it takes it but can't register with SIP Trunks Provider, like FWD. I don't want to use uPnP since it's a security threat to allow any software to punch hole in your firewall, what's the point of having a firewall is any hacker can install a software that open ports itself. And STUN doesn't work either since it return the wrong outside port that is not open in my firewall. I want to be able to open and forward the ports manually in my NAT router/firewall and use a FQDN to resolve the external ip address.

 

Since I'm on cable my IP address doesn't change very often, so I have written my actual ip address as if it's a static one.

 

I'm saying all that, not to complain, it's for you to make a better product, and since that's the problem I got making the server to work properly, mabye that can be avoided by little changes and if nobody say it, nothing could be done... Can't complain, it's free!

 

MageMinds

Link to comment
Share on other sites

  • 4 weeks later...
Hi I have recently installed Axon, but when I start it it doesn't get the right Private IP address. This is because I have VMWare Server installed and it install two virtual interface and Axon takes the ip address of one of them.

 

It would be great to allow the user to select the interface to bind to ... The server listen on all interface, but SIP signalling doesn't contain the right IP address so devices on the network doesn't work properly since they can't find the server at the specified address inside the SIP signaling packets.

 

I managed make Axon to get the right IP address by disabling all adapters in the network management console and only keeping the one that should be used.

 

Set one of the virtual interface "metric" to 1, and the other "metric" to 4 (any number greater than 1). The computer with Axon will always select "metric 1" as the first priority gateway.

 

 

Also, I have a dynamic IP address with a dyndns.com updated automatically, but I can't seem to be able to use a FDQN in the Static IP address field, it takes it but can't register with SIP Trunks Provider, like FWD. I don't want to use uPnP since it's a security threat to allow any software to punch hole in your firewall, what's the point of having a firewall is any hacker can install a software that open ports itself. And STUN doesn't work either since it return the wrong outside port that is not open in my firewall. I want to be able to open and forward the ports manually in my NAT router/firewall and use a FQDN to resolve the external ip address.

 

Since I'm on cable my IP address doesn't change very often, so I have written my actual ip address as if it's a static one.

 

In Axon option->network, select "use stun servers to find the external IP address and port. not the static IP because you don't have one.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...