Jump to content

Can't register Nokia E51 with Axon 1.30


lmdata
 Share

Recommended Posts

I've been trying to register my Nokia E51 with no success.

In the phone it just shows: "could not register".

In the Axon admin site, Status shows it as registered with new expire time each time I try to register,

but the port doesn't show as it should.

I've also tried to change port to 5061. Not good. It hangs.

If I try to make a call it only makes a new attempt to register.

It seems like it does get registered, but the phone doesn't recognize the registration. Any help would be appreciated.

 

 

These are the setting I use, assuming Axon computer is called "axonserver" with ip of xx.xx.xx.xx

 

Profile name: Axon

Service profile: IETF

Default access point: "My network"

Public user name: sip:103@axonserver

Use compression: No

Registration: Always

Use security: No

 

Proxy server

Proxy server address: sip:xx.xx.xx.xx

Realm: axon@axonserver

User name: 103

Password: ****

Allow loose routing: Yes

Transport type: UDP

Port: 5060

 

Registrar server

Registrar server address: sip:xx.xx.xx.xx

Realm: axon@axonserver

User name: 103

Password: ****

Transport type: UDP

Port: 5060

Link to comment
Share on other sites

On the registration request Axon replies: (EE.EE.EE.EE = my ip)

 

12:39:59 UDP Packet Sent to EE.EE.EE.EE:5060 >>>>>>>>

SIP/2.0 200 OK

Via: SIP/2.0/UDP 192.168.1.51:5060;branch=z9xxxxxxu2r;rport

To: <sip:151@servername>

From: <sip:151@servername>;tag=39xxxxxxxx2a3

Call-ID: a8Sxxxxxxnuvi-4RM

CSeq: 539 REGISTER

User-Agent: NCH Swift Sound Axon 1.30

Contact: <sip:151@EE.EE.EE.EE>;expires=60;q=0.5

Contact: <sip:151@EE.EE.EE.EE>;expires=60;q=0.5

Contact: <sip:151@EE.EE.EE.EE;transport=UDP>;expires=1605;q =0.5

Contact: <sip:151@EE.EE.EE.EE;comp=sigcomp>;expires=2038;q= 0.5

Content-Length: 0

-----------------------------------------------------------------

It looks as if it got registered, but the phone doesn't understand it.

Link to comment
Share on other sites

Unfortunately, I can't be of much help. But I can tell you that Nokia VoIP/SIP phones are infamous for having problems connecting to various VoIP systems (not just Axon). In fact some VoIP systems have patches that they have to install to have compatibility for the Nokia phones.

 

I can tell you that I believe one of the issues with Nokia has to do with codecs. Apparently Nokia is very picky about the codecs you can use, and if the codec it wants isn't available, then it simply doesn't work. Another known issue has to do with having to connect calls early or something, I'm not exactly sure what the issue is but I have used another PBX that had a "earlyconnect" option specifically for Nokia handsets.

Link to comment
Share on other sites

Hi

 

I have finally got my E61 working and more than a year of trying!

 

Delete your exisiting sip profile ( I say delete becasue proxy should be blank, and you cannot empty it once there is something entered)

 

create a new one

 

for example - extention 307 with axon server @ 192.167.7.7 with an access point set called "Home"

 

 

Profile Name : 307

 

Service Profile : IETF

 

Default Acces Point : Home

 

Public User Name : sip:307@192.168.7.7

 

Use Compression : No

 

Registration : Always On

 

Use Security : No

 

Proxy Server : DO NOT ENTER ANYTHING HERE

 

Registrar Server :

 

Reg Serv Add : sip:192.168.7.7

 

Realm : axon@nameof server

 

Username : 307

 

Password : ****

 

Transport Type : Auto

 

Port : 5060

 

---------------------

 

Hope this helps

 

Regards

 

Paul

 

Island Computers

islandcomputers.com

Link to comment
Share on other sites

  • 2 months later...

I have just found new software that enables SIP and other things (skype,msn,yahoo,googletalk etc) on the Nokia e-series and other mobile.

 

My previous instructions above enabled connection Axon from a local wireless LAN - I could never get it to work from remote wireless networks

 

This new software enables connect from any wireless LAN, also mobile GPRS, 3G networks -- so now I can connect where I am - and receive or make calls via the Axon!

 

software is fring

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...