Jump to content

How registered Axon to Teliax


Recommended Posts

It's very simple,

 

1) Log into your Axon web control panel

2) Click 'External Lines'

3) Click 'Add New External Line'

4) Set 'Line Name' to anything of your choice (just for your reference)

5) Set 'ID or Username' to your Teliax username, and password to your Teliax password

6) Then choose the extension or ring group incoming calls should go to

7) Select 'Use Gateway Server' and enter voip.teliax.com into the textbox

8) Save changes and you should be good to go

 

Note: Incoming calls should start to work right away, outgoing calls require you to setup a dialing plan (like Asterisk)

 

To setup a dialing plan,

1) Click 'Dialing Plans' in the Axon web control panel

2) Click the Edit icon on the default dialing plan

3) At the bottom of the page, set 'If none of the above applies, dial on line' to your Teliax line. If you want a more advanced dial plan you can come back later and add additional dialing rules (so for example you can call internal extensions.. the way it would be setup now is all calls our routed through to Teliax).

Link to post
Share on other sites

I do exactly what you suggest me, and I obtain this:

 

23:04:28 Restarting web server

23:05:31 Attempting to register sip:rmorffi@voip-co4.teliax.com

23:06:06 Server voip-co4.teliax.com did not respond to register (sip:rmorffi@voip-co4.teliax.com)

23:06:07 Check server details for that line

 

What do you think?

Link to post
Share on other sites

Strange.

 

Are you sure the server is voip-co4.teliax.com? (Just because all the demo configurations and such on their website use voip.teliax.com) All the correct config details can be found in your Teliax control panel under support.

 

If you are still having a problem, I suggest that you go to the 'logs' tab in Axon's web control panel and turn on SIP trace logs and then post your log here so we can perhaps try to identify the problem.

 

Also, on another note.. make sure in your Teliax control panel that you only tick 'ulaw' and 'gsm' under the Codec settings (in account details).

Link to post
Share on other sites

If I am for sure that is the proxy server, because Teliax tell me that and also because that use in Asterisk and I am able to register me.

 

This is the detail of the SIP trace logs.

 

That do you think?

 

08:38:37 UDP Packet Sent to 63.211.239.2:5060 >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

REGISTER sip:voip-co4.teliax.com SIP/2.0

Via: SIP/2.0/UDP 172.16.1.2:5060;rport;branch=z9hG4bK06792

Max-Forwards: 20

To: <sip:rmorffi@voip-co4.teliax.com>

From: <sip:rmorffi@voip-co4.teliax.com>;tag=7828

Call-ID: 1195047506-6792-NET-COMM-01@172.16.1.2

CSeq: 2 REGISTER

Contact: <sip:rmorffi@172.16.1.2:5060>;expires=3600;q=0.90

User-Agent: NCH Swift Sound Axon 1.20

Content-Length: 0

Link to post
Share on other sites

Is there more information in the log (there should be for example a received packet from Teliax, if not.. it looks like they're completely ignoring your register attempt for some reason.. or sometimes it happens because the VoIP service is not running, or the server is not reachable (possibly because of a port forwarding issue).

 

I'm not an expert in this field (i.e. sip traces, etc.), so I hope others on these forums will help solve the problem since I'm really not sure why the server isn't responding.

Link to post
Share on other sites

Place two NIC to the server, a to the publish network and another to the private network and I could register Axon PBX to Teliax.

But I now have a problem it is that not where register my CALL ID, because the Teliax username doesn't coincide with my CALL ID.

Then when I called from my private network the CALL ID that I see am the generic of Teliax not mine.

In Asterisk had an option where assigning the DID number, but in Axon don't find it.

 

Do you know something on this?

Link to post
Share on other sites

They have informed me that the current version of Axon doesn't incorporate DID number, which is necessary for the configuration of Teliax.

 

Is that correct?

 

pythonpoole said -- "Axon doesn't support setting the Caller-ID yet. I know this is a feature in other PBX systems, but Axon will just default to your VoIP provider's CID. Some VoIP providers let you set the CID on their end (e.g. Voicenetwork.ca through their online control panel), and other VoIP providers automatically set it to the DID number you purchased (e.g. Vonage.com).

 

In any case I don't believe there is a work-around for this, and you may have to suggest it (although I'm pretty sure it has already been suggested) and hope it will be available in a future version of the program."

Link to post
Share on other sites

Yes, Axon supports incoming DID numbers. Just so long as an 'External Line' (which is the same as a 'Trunk' as some other PBX systems call it) is setup with the SIP account, you should be able to make outbound calls and receive inbound calls on your DID. However, as I said you won't be able to actually set the Caller ID (CID), it will default to what Teliax uses.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...