Jump to content

Need to be able to change time till registration!


pythonpoole
 Share

Recommended Posts

Hi, I recently signed up for new VoIP service. Axon registers with it fine and calls in and out are no problem. Unfortunately, after a while (only about a couple minutes I'm estimating) incoming calls stop getting routed through to Axon. If I close and re-open Axon it works perfectly fine again for a little while and then simply stops responding to incoming calls and the caller is taken to an unavailable/voicemail message.

 

At first I thought it was a registration timing problem, but that however is incorrect as TJ has said below, Axon adjusts its registration frequency to what the service requests. (For some reason this version of IPB doesn't let you change your topic title for some reason (old versions of the board do let you)).

 

I have gone through the Axon Network wizard and went as far as to portforward all ports to the Axon computer and even tried with the router's firewall off for a little while. Still no luck, Axon shows know recognition of incoming calls after a few minutes.

 

 

Thanks for your time and help,

 

~pythonpoole

Link to comment
Share on other sites

the fundamental issue here isn't about registration times, its networking. what many don't realise is that we honour the registration expiry times returned by the VoIP server, so whatever frequency Axon is using that is what your VoIP service is asking it to do.

 

so when people are asking 'how do i change the registration expiry time?', the real question should be 'how do i keep my NAT/router ports open in order to receive registration responses and call requests from the outside world?'

 

the answers can get complex (just like networking as a whole), but the suggested ideas are:

 

1) run the axon networking wizard and see what it says - it will try the uPnP and STUN lookup options and see if any of them work. if STUN doesn't work it means you have a symmetric router which is the most difficult type to have, and you will have to setup port forwarding on your router (see next option)

 

2) port forward all responses coming in to port 5060 on your router to the Axon machine. this will mean that you don't have to worry about router ports closing and any incoming call/registration requests getting blocked. also you can try port forwarding on 8000-8020 in case axon has to relay audio through its machine, but only do it if you are experiencing audio issues - if you aren't then don't worry about it (sometimes it causes extra problems).

 

contact me at tj [at] altoedge.com for a test version of the next axon too, i would very much appreciate someone like yourself (an active member in the community) to test out new versions and give feedback on how things are working on your system/networking setup.

Link to comment
Share on other sites

Thank you for the heads-up on the automatically adjusting registration frequency, I didn't realize it did this, and I guess I just made the assumption (because I had a similar problem a long time ago with some VoIP hardware I had and changing the timer fixed the problem).

 

Here is a copy of a section of the email I sent you, TJ

My third problem I have posted on the forum and its to do with a VoIP service I'm using that works fine when Axon has just been opened, but after a while (couple of minutes I'm estimating), incoming calls stop coming through to Axon and go to a voicemail/unavailable message from the provider. At first I thought it had to do with timings, because I have had problems like this with other VoIP equipment and changing the timing to 60 seconds fixed the problem, but as I see Axon automatically adjusts the timings, that isn't the problem. I looked at your TJ's suggestions (above), but I have portforwarded all the mentioned ports to the Axon computer and run the setup wizard and still no luck. In fact I went as far as turning off the firewall on the router (temporarily) and keeping all ports forwarded to the Axon computer, still no change. All other VoIP accounts were working as normal, but this one still had (and has) the problem after a few minutes.
Link to comment
Share on other sites

the fundamental issue here isn't about registration times, its networking. what many don't realise is that we honour the registration expiry times returned by the VoIP server, so whatever frequency Axon is using that is what your VoIP service is asking it to do.

 

so when people are asking 'how do i change the registration expiry time?', the real question should be 'how do i keep my NAT/router ports open in order to receive registration responses and call requests from the outside world?'

 

the answers can get complex (just like networking as a whole), but the suggested ideas are:

 

1) run the axon networking wizard and see what it says - it will try the uPnP and STUN lookup options and see if any of them work. if STUN doesn't work it means you have a symmetric router which is the most difficult type to have, and you will have to setup port forwarding on your router (see next option)

 

2) port forward all responses coming in to port 5060 on your router to the Axon machine. this will mean that you don't have to worry about router ports closing and any incoming call/registration requests getting blocked. also you can try port forwarding on 8000-8020 in case axon has to relay audio through its machine, but only do it if you are experiencing audio issues - if you aren't then don't worry about it (sometimes it causes extra problems).

 

contact me at tj [at] altoedge.com for a test version of the next axon too, i would very much appreciate someone like yourself (an active member in the community) to test out new versions and give feedback on how things are working on your system/networking setup.

 

 

My router is set-up to forward port 5060 to my Axon machine, and I have run the Axon networking wizard. 99% of the time I do not have any problems with the registration with my VOIP service. However, several times a day, Axon will fail to register, and then waits 10 minutes before trying again. If there was an option to set the registration time to a short time (eg 60 seconds), like 3CX, Call Butler and my IP Phone, I would not miss incomming calls for 20 minutes each day.

 

Wayne

Link to comment
Share on other sites

the fundamental issue here isn't about registration times, its networking. what many don't realise is that we honour the registration expiry times returned by the VoIP server, so whatever frequency Axon is using that is what your VoIP service is asking it to do.

 

I've been checking the SIP messages generated by Axon. They show that my VOIP service provider is sending the expiry time to Axon as 60 seconds. Yet Axon only re-registers after 10 minutes if it loses contact with the service provider.

 

The log is:

 

19:14:26 UDP Packet Received from 195.189.173.12:5065 <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

SIP/2.0 200 OK

Via: SIP/2.0/UDP xxxxx:5060;rport=5060;branch=z9hG4bK27752

Record-Route: <sip:195.189.173.10:5060;lr=on>

Record-Route: <sip:195.189.173.12:5065;ftag=1593;lr=on>

From: <sip:xxxxx@sip.voipfone.co.uk>;tag=1593

To: <sip:xxxxx@sip.voipfone.co.uk>;tag=as0740f7b7

Call-ID: 1175277915-752-DELL@192.168.1.11

CSeq: 25 REGISTER

User-Agent: Voipfone Sip Network

Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER

Expires: 60

Contact: <sip:xxxxx@62.3.222.210:5060>;expires=60

Date: Fri, 30 Mar 2007 18:14:46 GMT

Content-Length: 0

 

Would it be possible to not only set the registration time, but to set the time before re-trying to connect if there is a connection failure?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...