Jump to content

OGM puts my callers onhold in het PBX from my provider


Recommended Posts

Hi

I'm using 1.09 Axon with IVM and IVS.

I have a sip account with my provider and that is working fine.

Now I have setup a OGM (language choise and stuff) and when the caller presses a number normaly the OGM should go to the next menuoption but instead the call is put onhold and the caller hears the commercial music from my provider.

 

It's like the command is not staying inside MY pbx but is heard by the PBX of my provider and he puts it onhold.

My provider is working with an Asterisk system and he is asuring me that it is the fault of the NCH software.

 

Any suggestions? The helpdesk can't help me either even I spend more then 300$ for al the software.

 

Tom :unsure:

Link to post
Share on other sites
  • 10 months later...
  • 2 months later...

I've noticed that AXON actually sends a CALL ON HOLD signal to the provider when the audio is transferred to the music on hold application.

 

By doing so, some providers have different repercussions. I do not think its a good idea for axon to send this signal whilst the user is sent to the music application. The only advantage I see to this, is for the providers like mobile phone providers who do not charge for on-hold time. It will deduct the time for the callers who stay on hold. However this causes alot of incompatibilities with various SIP providers. I believe there should be a checkbox that the CALL ON HOLD signal can be switched off.

 

Just my 2 cents.

 

 

 

Hi,

 

IVM is registering with AXON only, which is running on the same computer. I have testing this with another VoIP provider and the problem disapears.

 

For reference, the provider i was using, is VoIPtalk

 

Mark

Link to post
Share on other sites
I've noticed that AXON actually sends a CALL ON HOLD signal to the provider when the audio is transferred to the music on hold application.

 

By doing so, some providers have different repercussions. [...] I believe there should be a checkbox that the CALL ON HOLD signal can be switched off.

 

I agree. I have heard several problems with users saying when they put their customers on hold either they get music from their Telecommunications provider or they get dead silence. I am also having problems with external calls getting dead silence when transferring with IVM (but internal extensions hear the ringing or music just fine).

Link to post
Share on other sites

Its 1am right now... still trying to find a solution to this problem...

 

I don't know if something suddenly happened from my provider or if its the new version of axon. Whatever it is, it is a change that happened these last few days.

 

I have tried several options. Even setting the group for ringing sound only, however the groups are not working correctly. The call disconnects as soon as its answered.

 

I agree. I have heard several problems with users saying when they put their customers on hold either they get music from their Telecommunications provider or they get dead silence. I am also having problems with external calls getting dead silence when transferring with IVM (but internal extensions here the ringing or music just fine).
Link to post
Share on other sites

Well I do know they are working on a new quick release of Axon that supports video calls, but I don't think it has been released yet, at least I haven't seen any announcement yet, and the last release hasn't been for a while. I've also heard of this problem long before a few days ago, so I'm thinking it probably is something to do with your VoIP provider.

 

If the call is disconnecting as soon as you answered, I think it means there is a codec problem. Make sure your provider (in case it has changed in the last few days) still supports the codecs G711 (alaw/ulaw) and/or GSM. Some providers let you choose the codec to use in their web control panel.. I suggest you check if there is an option / if they've now added one.

Link to post
Share on other sites
  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...