Jump to content

One or more sound clips is still processing...


Recommended Posts

I just installed VideoPad. New installation.

I loaded a MP4 file, 10 minutes with spoken text sound.

In VideoPad, when I try to preview/play the clip, it says:

"One or more sound clips is still processing, you will not hear hear these clips until processing finishes".

This is not going away, and I have no sound. It is a normal MP4 file, which I can play normally on various other video players.


Link to comment
Share on other sites

How large is the file?  Install this release and see if that helps.  If it doesn't please share the project.  It's easy and can be private.  Follow these steps...

Share your project.  Someone will take a look and come up with a fix.  The process is easy, quick and can be done privately.  Just follow these steps...

  •     Back up --- With your project on the timeline, click on MENU at the top-left.  Click FILE|BACK UP PROJECT FILES TO FOLDER.  Choose a folder and SELECT FOLDER.
  •     Upload ---  Use a free server - Google Drive, MS OneDrive, etc.* - to upload the saved, numbered FOLDER.    Do NOT upload the individual VPJ or export file. 
  •     Get link --- Get a public link.  If using Google Drive click GET SHAREABLE LINK. If necessary change "restricted" to "anyone with the link can view" 
  •     Share ---     Click COPY LINK | DONE.  Paste that link here, or click the folder at the top-right of this forum to message it privately to me.  It won't be shared.

          *    Before uploading, right-click the folder, click PROPERTIES.  Look at the File Size to confirm that it's not too big for the free space on the server.

Link to comment
Share on other sites

Thanks for sharing.  Loaded fully within seconds here in version 12.28 (64-bit).

Did you install the release linked above?  If so, and there was no change, right-click the Videopad executable and RUN AS ADMINISTRATOR.  Then load the project.

Did that help?

Link to comment
Share on other sites

Yes, I did install the version you supplied.

And Yes, when I run it as Administrator, it works... IMHO that is a design fault, I am not sure what drivers it tries to load, but it should be possible to do this running just as normal user...  Where is the audio file/driver located which only Administrator has access to?

Many thanks, Bart (Also software developer)


Link to comment
Share on other sites

It's unknown why that succeeds on the few systems that require it.  Have never run across the issue here.

The files are in...

"C:\Users\<PC name>\AppData\Roaming\NCH Software\Components"   and

"C:\Program Files (x86)\NCH Software\Components"  (or the same path without the x86)

You might try first closing VP, and deleting all files in those folders.  Then reinstall VP.

As an aside, MS Quick Assist worked for years w/o administrator authorization.  Now, after a mandated upgrade, it needs it.

Link to comment
Share on other sites

Thanks for that. Just to be sure: The program is not attemping to use an audio driver which could also already be installed by another program, and to which location a system PATH has been set? Overriding the one which is supplied by the installation?

"lame.exe" would be a prime example... I am currently doing a search for it, as I am sure there must be several copies of that on my system..


So finally: Yes, I do have in fact a copy of "lame.exe" on my system, in "C:\Program Files (x86)\Lame For Audacity", and I disabled it.

Then I started VideoPad in standard mode and it worked this time. BUT then enabled the other copy again, and now VideoPad still works normally _without_ administrator level 😀

Maybe you can make sense of it, I don't 😀

Thanks again, all good here now.


Link to comment
Share on other sites

I shared the file with 'borate' and he tested it, and it worked okay.

The problem (and I update it now) is this:

1) I start a new Project, and I load a mp4 file.  The sound system is stuck.
2) I close the program and start it with Administrator privilages. Now it works. I save the Project.
3) I close the program and start it as normal user. I load the saved Project.  Everything now works normally.


Link to comment
Share on other sites

Question: I am a software developer myself, and my own software produces a Debug file (one per day). Users can email this debug file directly from the software as a 'Bug Report'. Almost always I can find the problems by checking this Debug file. Especially when actual system errors occur.

Is something like that not possible in VideoPad?

Link to comment
Share on other sites

Hi Bart,

I've tried your test project. It looks fine here and doesn't seem to related to Lame at all.

If you can reproduce the issue constantly, would you mind if I send you a debug build so we can have a look what's in the trace log?



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...