Jump to content

Problem using videopad and with Mac computers

Russ Croucher

Recommended Posts

I have a business of transferring older videotapes to the modern world to MP4 and flash drives.  I have submitted this bug which was 10.52 already but I thought I would throw it out here and see if anybody else's had a similar problem.  For customer privacy reasons I have shortened my example to 1 minute in length.

My procedure is: transfer all analog into videopad using Debut in the largest format.  Then import all the files into videopad to image stabilize them.  Then once all the stabilization is complete I steal the image stabilize files from the temporary directory that videopad uses.  Then I passed the entire collection of image stabilize files to it open source handbrake to downsize it to the appropriate size necessary so no loss occurs in the process.

That process works great with the exception that all my flash drives are forced to be "FAT32".  All flash drives 64GB and larger are formatted "exFAT".  Some computers do not accept this format.  I found out a way I can force all flash drives to be formatted FAT32.  The problem with that is it does not support files greater than 4 GB.  So I use videopad and split the file into 2 pieces after the end of the entire process.  I make an A and B version.  Now for the problem, all these files cannot be read on some Mac computers because they were finally process in the end by videopad and not handbrake.  My customer that has a mac says the video quits about 8 to 10 seconds.

Here is the 1 minute video segment from the latest version of video.

Here is the same 1 minute segment process with handbrake

Maybe you guys can give me some enlightenment on this problem.

Link to comment
Share on other sites

I only export MP4's which Mac computers read.  The links appear to be the same but they're not.  1 of them was exported with videopad and the other one was exported with the open-source handbrake which is the one that works on the Mac.  I did try the MP4's with a new iPad with no problem.  I submitted a bug request but got nowhere.  Only the videos that are modified by videopad cause a problem with Mac computers.  I know MOV's would fix the problem on the Mac but I'm not going to export the videos twice.  Especially since the workaround is to make sure everything runs through handbrake after videopad.

Link to comment
Share on other sites

Each of your links appears to contain exactly the same two Handbrake and a VP files.

Try the mpeg4 encoder for mp4.  Perhaps the Mac will handle that better.

Click the Default Quality/Filesize blue link in the export dialog box.  image.png

You might also test various Video Bitrate settings, in lieu of "Default Quality."

Link to comment
Share on other sites

The reason I do not want to choose any other output export from H264 MPEG is because then I could not use the "lossless" mode.  All operations with a video pan use lossless.  This would mainly be to split a file in the 2 pieces writing an A and  B version.  If I would take the exact same MP4 file and then run it through handbrake it would work.  So please explain to me why I must run a lossless export through handbrake to work.  There must be something in the header that makes it not desirable for Mac computers.

All outputs from videopad are always output in the full resolution with the max size.  Then they are sent to handbrake and used to set the encoder rate to the level that makes sense for the input that was originally used.  I would expect any output after that like splitting the file into 2 pieces would be lossless and not affect the encoder scheme.  Explain to me if this is not true.  It should work with Mac computers unless there is something in the header that makes it not work.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...