Jump to content

Configuring the Linksy SPA-3102 for Axon?


Recommended Posts

Hello

 

The 3102 just got here, I plugged it into the hub, fired a web browser... and I'm stuck :-)

 

Can a kind soul who has successfully configured this SIP gateway for use with Axon tell me how to get started?

 

FWIW, I will only use the Phone and LAN connections, as I already have an Internet router. The Linksys is just there to handle PSTN incoming and outgoing connections

 

Thank you

Fred.

Link to post
Share on other sites

Axon still doesn't display any message when I call the Linksys 3102 FXO from my cellphone, but at least, the Linksys does send some information to a syslog server (cellphone number partially obscured to protect the innocents):

 

Aug 16 07:00:59 Romance Daylight Time,,192.168.0.1,local2,DEBUG,,"FXO:Start CNDD "
Aug 16 07:00:59 Romance Daylight Time,,192.168.0.1,local2,DEBUG,,"FXO:CNDD name=, number=062805XXXX "
Aug 16 07:00:59 Romance Daylight Time,,192.168.0.1,local2,DEBUG,,"FXO:Stop CNDD "
Aug 16 07:00:59 Romance Daylight Time,,192.168.0.1,local3,DEBUG,,"FXO:CNDD Name= Phone=062805XXXX "

-------- HUNG UP CELLPHONE-----------------

Aug 16 07:01:15 Romance Daylight Time,,192.168.0.1,local2,DEBUG,,"AUD:Stop PSTN Tone "
Aug 16 07:01:15 Romance Daylight Time,,192.168.0.1,local2,DEBUG,,"AUD:Stop PSTN Tone "
Aug 16 07:01:21 Romance Daylight Time,,192.168.0.1,local2,DEBUG,,"AUD:Stop PSTN Tone "
Aug 16 07:01:21 Romance Daylight Time,,192.168.0.1,local3,DEBUG,,"FXO:On Hook "
Aug 16 07:01:21 Romance Daylight Time,,192.168.0.1,local2,DEBUG,,"AUD:Stop PSTN Tone "
Aug 16 07:01:21 Romance Daylight Time,,192.168.0.1,local2,DEBUG,,"FXO:Stop CNDD "

Aug 16 07:01:37 Romance Daylight Time,,192.168.0.1,local2,DEBUG,,"CC:Clean Up "
Aug 16 07:01:37 Romance Daylight Time,,192.168.0.1,local2,DEBUG,,"--- OBJ POOL STAT --- "
Aug 16 07:01:37 Romance Daylight Time,,192.168.0.1,local2,DEBUG,,"OP:RTPRXB =  96 ( 96  192)   "
Aug 16 07:01:37 Romance Daylight Time,,192.168.0.1,local2,DEBUG,,"OP:RTPREB =  40 ( 40   48) "
Aug 16 07:01:37 Romance Daylight Time,,192.168.0.1,local2,DEBUG,,"OP:RTPTXB =  64 ( 64  108)   "
Aug 16 07:01:37 Romance Daylight Time,,192.168.0.1,local2,DEBUG,,"OP:TIMEOU = 110 (120   40) "
Aug 16 07:01:37 Romance Daylight Time,,192.168.0.1,local2,DEBUG,,"OP:SIPCOR =   0 (  1   28)   "
Aug 16 07:01:37 Romance Daylight Time,,192.168.0.1,local2,DEBUG,,"OP:SIPCTS =  32 ( 32  568) "
Aug 16 07:01:37 Romance Daylight Time,,192.168.0.1,local2,DEBUG,,"OP:SIPSTS =  32 ( 32 3492)   "
Aug 16 07:01:37 Romance Daylight Time,,192.168.0.1,local2,DEBUG,,"OP:SIPAUS =   5 (  8  588) "
Aug 16 07:01:37 Romance Daylight Time,,192.168.0.1,local2,DEBUG,,"OP:SIPDLG =  10 ( 10  148)   "
Aug 16 07:01:37 Romance Daylight Time,,192.168.0.1,local2,DEBUG,,"OP:SIPSES =  12 ( 12 7936) "
Aug 16 07:01:37 Romance Daylight Time,,192.168.0.1,local2,DEBUG,,"OP:SIPREG =   2 (  4  292)   "
Aug 16 07:01:37 Romance Daylight Time,,192.168.0.1,local2,DEBUG,,"OP:SIPLIN =   0 (  2  140) "
Aug 16 07:01:37 Romance Daylight Time,,192.168.0.1,local2,DEBUG,,"OP:ÿ"
Aug 16 07:01:37 Romance Daylight Time,,192.168.0.1,local2,DEBUG,,"OP:STUNTS =  16 ( 16   68) "
Aug 16 07:01:37 Romance Daylight Time,,192.168.0.1,local2,DEBUG,," "

 

FWIW, I followed the instructions in the following documents...

 

FXO Adapters Installation Guide

Sipura 3000 Configuration

External Line to SPA3000 DONT WORK, SPA3000 configuration problem

AXON with SPA-3102, SPA-3102 is the new SPA-3000 + router

 

... and uploaded a copy of the Linksys configuration:

 

http://codecomplete.free.fr/linksys.html

 

Me thinks it's really something basic in the Linksys configuration, but any help much appreciated :-)

 

Thx

Fred.

 

PS : Here's what I did (Axon = 192.168.0.2, Linksys = 192.168.0.1)

 

1. In Axon, in Extensions, create an account fxo/fxo so the Linksys can register its FXO port (I don't care about the FXS at this point)

 

2. Still in Axon, in External line, modified the Default item, Server = 192.168.0.1, ID = fxo, Password = fxo, Group = 701). This triggers the familiar "Attempting to register sip:fxo@192.168.0.1, Register attempt for sip:fxo@192.168.0.1 failed, 501 Not Implemented) that others have seen. Using or not using a password makes no difference. I don't see how Axon could possibly use the FXO to make outgoing calls without knowing the IP address of the Linksys, though...

 

3. In Linksys, in "PSTN Line", changed the FXO port from 5061 to 5060 (and FXS from 5060 to 5070), filled the "Proxy and Registration" and "Subscriber Information" with relevant information : The Linksys successfully registers with Axon. Also modified the "Dial Plan 1" with "(S0<:701@192.168.0.2:5060>)" (w/out the quotes).

Link to post
Share on other sites

Great news! The 3102 finally notifies Axon of incoming calls :) The trick is to ignore the documents above (either they're specific to the 3000 or they no longer apply to the latest firmware, 3.2.10), especially the part about dial plans.

 

From what I've seen, I get the impression that the Linksys was built, foremost, as an ATA, not as an SIP gateway. This would explain why incoming calls are first sent to the FXS, and will only be forwarded to Axon if setting it up that way in the User 1 section.

 

For those interested, here's what needs to be done in Axon and the 3102 to handle incoming FXO calls:

 

AXON

 

Launch Axon, and aim your browser to its web server (http://localhost:81). Create an extension for the FXS device (eg. fxs/fxs)

 

Modify the default external line to create an account for the Linksys to use to register with Axon, eg. fxo/fxo. Don't put the Linksys IP address in Server: Either Axon 1.08 doesn't support this yet, or the relevant info must be added somewhere in teh Linksys but I haven't looked into this yet as I don't need the Linksys to make outgoing calls.

 

In Extensions, click on "Setup Details" for extension 101, and write down the password. You'll need it to set up the X-Lite free softphone next.

 

X-Free softphone

 

Next, download and install this application. Register with Axon using 101 as UserID, and the password for this extension. The softphone will register with Axon and be ready to receive calls.

 

Linksys

Finally, aim your browser to the Linksys embedded web server, log on as admin/advanced, and change the following parts in the Voice section:

 

Line 1

"Line Enable" = yes (or the 3102 won't notify Axon)

"Proxy and Registration" : Proxy = IP address of Axon

"Register" = yes or no, it worked either way (but I guess it should be yes for the FXS to be reachable)

"Subscriber Information" : "User ID" and "Password" must match an extension in Axon

 

PSTN Line

Proxy and Registration : Proxy = IP of Axon, Register = yes

Subscriber Information : User ID and password must match the information entered in Axon for the default external line

 

PSTN-To-VoIP Gateway Setup : "PSTN Ring Thru Line 1" = YES (important!), "PSTN CID For VoIP CID" = yes (important! otherwise, caller ID from the phone company won't be passed on to the IP phone)

 

User 1

Call Forward Settings: Cfwd All Dest=ID that matches the one that you set up for the default external line in Axon (it means that all incoming calls will be forwarded from the FXS to the FXO)

 

NB: By default, the FXS ("Line 1") uses UDP 5060 and the FXO ("PSTN Line") uses UDP 5070. I read here that Axon expects the FXO to use 5060 to be usable for outgoing calls. As I only need the Linksys to handle incoming calls from the PSTN line, I haven't tested this yet.

 

Now, call into the Linksys from a remote phone: The Linksys should detect the call, see that all incoming calls should be forwarded from the FXS to the Axon server, which should ring extension group 701 that includes 101 and 102. Since the softphone is registered as extension 101, you should get a ring.

 

Outstanding issues

- When the softphone goes off-hook, I can hear the remote caller, but the remote caller can't hear me (yes, the cables are OK, and I can see the MIC volume going way up in X-Free when I talk into it): Is it due to some RTP business? Incidently, how do two SIP devices (here, the Linksys and the X-Free softphone) know which UDP ports to use with RTP? They send this information during the SIP call setup?

 

- When a call comes in, the Linksys goes off-hook immediately, and then calls the softphone: As a result, even if the softphone never takes the call, the caller will be charged for the call. I didn't find how to change this.

 

Any help appreciated for the last two items :)

 

Fred.

Link to post
Share on other sites

Outstanding issues left

 

- When the softphone goes off-hook, I can hear the remote PSTN caller, but the remote caller can't hear me through the headset microphone (Skype works fine, so it's not the hardware or software part of the sound card.)

 

=> I still can't figure that one out. There's no firewall between the Linksys and the PC where Axon and X-Free are running, both are connected on the same switch through the Ethernet port. There are so many settings regarding ports, RTP, etc., that I don't know where to look, what to try.

 

- When a call comes in, the Linksys goes off-hook immediately, and then calls the softphone: As a result, even if the softphone never takes the call, the caller will be charged for the call. I didn't find how to change this. By default, Axon intends to play music on-hold. Either because I didn't install IVM or because of the issue with sound above, I got silence. Changing its default to RING solved the issue: Axon tells the Linksys to go off-hook only when the SIP client actually answers the call.

 

Thanks for any hint

Link to post
Share on other sites
  • 2 weeks later...

Did you also solve the problem that in the log-window of AXON every 11 minutes an error line is coming by to tell you that the SPA can't register? If not, how did you solve this.

 

In the link you are providing http://wiki.pbxnsip.com/wiki/index.php/Lin...PA-3102_FXS/FXO , the writer is talking about firmware version 3.4x and 3.6.x. If I look at the linksys server, the only firmare for the 3102 is 3.2.10(GW). Which version are you using?

Link to post
Share on other sites
Did you also solve the problem that in the log-window of AXON every 11 minutes an error line is coming by to tell you that the SPA can't register? If not, how did you solve this.

 

Nope. I guess the Linksys doesn't allow SIP devices to register with it?

 

Which version are you using?

 

Upgraded from 3.2.6 to 3.2.10.

 

At this point, I'd like to get rid of the Axon (:-))... and have the Linksys call the IP phone directly through the Net. It works when they're both on the same LAN, but it doesn't work over the Net. I'm looking into this, but if someone has already done it...

Link to post
Share on other sites

I also have some problem with Axon & Linksys SPA3102.

 

 

I can call from outside line to PSTN and the call is transfered to Axon extensions (in group 701 for example), the extension rings but I don't see the Caller ID: however the softphone displays the name I gave to the gateway and the User ID for external line in Axon. I set "PSTN CID for VOIP CID" to yes, but the same.

 

The other problem is how to dial from my Axon extension to an outside line via Linksys gateway. I try setting the dial plan with several settings, but no success. The phone dialed, Axon reports as "answered" and after that I can hear just the dial tone from outside line. It seems as Linksys doesn't pass the number to the outside line to be dialed.

 

Some ideas what to do?

Link to post
Share on other sites
I can call from outside line to PSTN and the call is transfered to Axon extensions (in group 701 for example), the extension rings but I don't see the Caller ID: however the softphone displays the name I gave to the gateway and the User ID for external line in Axon. I set "PSTN CID for VOIP CID" to yes, but the same.

 

It might be due to wrong regional settings. You'll have to find someone in the same country as yours and copy/paste his settings. This is especially true for caller ID encoding.

 

The other problem is how to dial from my Axon extension to an outside line via Linksys gateway.

 

No idea. I never used the Linksys for outgoing calls.

 

You'll get more help there:

 

http://forums.whirlpool.net.au/forum-threa...f=107&g=100

http://forum.voxilla.com/linksys-sipura-spa-users-group/

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...