Jump to content

VP fails to snapshot 1920x1080

Alan R

Recommended Posts

A very weird situation has arisen VideoPad will not take a snapshot at HD 1920x1080 the image saved is just plain green, or occasionally a green image (also experienced other dominant colours).

Was using v10.16 64 bit Masters  - Now upgraded to 10.35 (at cost) Masters ( knew you guys would suggest that so I now on latest release 😊  )

Same problem

Been using VP since last September

All other snapshot formats 4K et al no probs

Tried Custom and set for 1909x1080 - all good.

Just 1920x1080 either by preset or Custom - fails.

Tried with video files from Canon and Sony - no difference.

PC running Windows 7 - no bugs virusses etc - everything else I can think of continues to work videos games YouTube etc.

Just VP (any version) and just snapshots at 1920x1080 are the issue

Any suggestions?????  Going slightly mad here !!


My partner just suggested I use custom 1919x1079 nobody would notice - and she's right it works a treat - and I can't even tell the difference!

But the problem as detailed above is still bugging me.

Link to comment
Share on other sites

A variety of stills and video frames, with resolutions from 720 up to 4K were tested here. All produced snapshots identical to the source.

Were you capturing the clip or the sequence?  Please share a shot or two that has the problem and someone here will take a look.

Just upload the file/s to a free server, such as Google Drive or MS OneDrive, get a shared (public) link, copy the link and paste it here or to me in a Private Message via the mail envelope in the top-right corner of this forum.  When using Google Drive, if necessary change "restricted" to "anyone with link can view."

Also verify that the PC's video driver and Direct-X are up to date...    https://www.nch.com.au/kb/10265.html

Link to comment
Share on other sites

I was trying to capture the snapshot from the sequence  and it fails only if the snapshot resolution is exactly 1920x1080 (either by the HD choice or the custom setting)

Trying snapshot from the clip works as expected.

In my limited use of the snapshot I have always taken snapshots from the sequence window and they have up to recent always worked as expected.

When I try using ANY other resolution (even just 1 pixel different like 1919x1079) it works perfect.

I am running DirectX 11.0 - but cannot see if there's any updates as MS no longer support Windows 7

Trying to check my video drivers with NVIDIA and the driver for my graphics card is "temporarily unavailable", but again this looks a peculiar bug to be so dependant on a possibly out of date driver.

You will by now have received the link to the short video I have sent you on Google Drive

Look forward to your thoughts.


Link to comment
Share on other sites

Errrm - I'm confused - its very late here in the UK - so which source file do you want? 

You got the video ok? (of me showing the bug)

The source file of my original project is huge and nothing special as I can replicate this bug with a one clip project, which is also nothing special but it does demonstrate the issue to me.

Is that the source (.vpj) file you want?



Link to comment
Share on other sites

The VPJ is of no use;  it instructs videopad what to load.

Please upload and link a small video or image source file - or perhaps your "one-clip" project - so we can test it just as you do.

The process is easy, quick and can be done privately.  Just follow these steps...

  •     Back up --- With your project on the timeline, click on MENU at the top-left.  Click FILE|BACK UP PROJECT FILES TO FOLDER.  Choose a folder and SELECT FOLDER.
  •     Upload ---  Use a free server - Google Drive, MS OneDrive, etc.* - to upload the saved, numbered FOLDER.    Do NOT upload the individual VPJ or export file. 
  •     Get link --- Get a public link.  If using Google Drive click GET SHAREABLE LINK. If necessary change "restricted" to "anyone with the link can view" 
  •     Share ---     Click COPY LINK | DONE.  Paste that link here, or click the folder at the top-right of this forum to message it privately to me.  It won't be shared.

          *    Before uploading, right-click the folder, click PROPERTIES.  Look at the File Size to confirm that it's not too big for the free space on the server.

Link to comment
Share on other sites

Thanks for the test file via PM.

Looks normal and fine here at preset 1080 in both VP 10.35 and beta 10.36, whether snapped from Clip preview or Sequence preview.  Verified on a gaming-class desktop and an I3 laptop.  A number of other 1080 videos/stills also succeed.

This hints at a local PC issue.  What are your PC's specs:   CPU/GPU/RAM?  Hunt for that video driver once again.

Link to comment
Share on other sites

I see the "local pc issue" but would add that my PC has not changed since I purchased my very first Videopad last year.

I also can't quite get my head round this one very precise instance (1920x1080) in one specific operation (snapshot operation in Videopad) - is all that fails.  Even just one pixel away and all's well.

Tomorrow I will hunt again for the video driver, and will also collect the specs you desire.

This is almost as daft as your car left indicator fails when you drive precisely at 50kph and at no other speed!!!


Thank you.


Link to comment
Share on other sites

Have hunted again and NVIDIA say "Temporarily unavailable" for my graphics card, but then I noticed how I was misreading (a senior moment) their statement, so I have installed the latest driver for my graphics card.  All worked well but no change on the snapshot bug front.

In their defence my graphics card has worked perfect since long before I got Videopad and I have used snapshot in VP many time last year.

My CPU          Intel(R) Core(TM) i7-6700 CPU @ 3.40GHz

My GPU          NVIDIA GeForce GT 640

My RAM          32GB (16GB useable due to Windows 7 limitations)

All that data applicable since before Videopad first installed.

My workaround of choice for the time being will be to snapshot in 4K, unnecessarily large, but at least it works.  I do not think it will affect final mp4 render.

This is such a weird bug that defies all logic - thanks



Link to comment
Share on other sites

Try this beta release.

If the issue persists please delete all files in these two Windows folders...

"C:\Users\<PC Name>\AppData\Roaming\NCH Software\Components"

"C:\Program Files (x86)\NCH Software\Components"  (or similar, without the X86)

Then reboot and install Videopad.  This should replace any corrupted components.

Link to comment
Share on other sites

Good morning

D/L 10.36 - installed -  snapshot still fails

Cleared the two folders

Installed 10.35

tried snapshot - still faulty

Will repeat the exercise just to make sure I followed your instructions to the letter


Ok - done it all again - nothing solves the snapshot issue - thought your idea of corrupted component file(s) was a good one - but alas following your instructions produced no change.

I'm stuck for ideas at the moment, but all the time 99.99% of VP works brilliantly I will use Snapshot 4K as I said earlier.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...