Jump to content

Min. computer specs for VP?


NicoleB
 Share

Recommended Posts

Anyone know where I can find what the minimum computer hardware specs for VP versions 10.12 and the current version (10.24) are?

I have a pretty basic, off-the-shelf consumer-grade 4 year old computer.  September last year I found myself in need of a program that could primarily do closed-captioning (.SRT), but that I could also do basic editing in (crossfade to text overlay, mute a single audio track, blur a section of screen and the blur doesn't need to move).  I do not do this professionally.  It's for a private class I co-teach, and several of the students have needs that require we have closed-captions on our videos.  As the person, of the teaching group, with the most available time (my "real" job has been, and still is, closed because of the pandemic) and a bit of a obsession with attention to detail, I agreed to take on this project.

VP was absolutely the easiest to pick up and start using, and when I was originally using the free version (for the first couple months) it worked GREAT.  Since they've upgraded, and since I've paid for a license...the program is nearly always crashing on me.  (10.12 is the most reliably functional version, of the older versions that I can still get hold of, but I'd like to be able to use current versions.)  For a while I was getting the blue "buffering" box before the crash, then it would just crash with no announcement.  I've upgraded my RAM (32 on board, 23.2 available), but still have my original AMD A4-5300B APU with Radeon(tm) HD Graphics 3.40 GHz CPU.  All my other hardware would run Adobe Premiere Pro, if I was willing to make the jump, and if I knew for sure that Premiere would let me edit .SRT, in-program.

The computer only crashes during work on subtitles.  I know there are programs that are closed-caption specific, but of the (free-to-inexpensive) multiple ones I've tried, VP gives me the best combination of start/end point accuracy : ease of use : price.  The fact that it's a great, easy-to-use/intuitive editor is icing on the proverbial cake and I'd like to stay with VP as my only program, if at all possible.

Link to comment
Share on other sites

Your PC should have no problem with Videopad.  There are both 32- and 64-bit versions, offered randomly on the main server.  Mousing over the download link should reveal which is up at the moment.  If it doesn't say "64" it's the 32.  The 64 is recommended for very high-def, complex  and lengthy projects.

If a release is doing the job for you there's no urgency to update.  Give it time to see if there are quirks.  There's a six-month grace period after purchase for free updates.  But newer versions can always be test driven, though some features may be limited.  Retain your purchased installer and registration.

After recent releases significantly improved speed and file handling, one of those 'quirks' involving AMD hardware was discovered.  Though it surfaced mainly on export it is possible that your issue is related.  Try this beta version and report back whether it works better for you.

Also, click OPTIONS | Clear Unused Cache files before beginning a project.  You can do this at anytime during editing as well, to eliminate excess, unneeded cache files that may have built up.

Be sure to Save Project File AS routinely, giving it a unique # or name, so as not to overwrite prior saves.  Using Save Project Files (no AS) will overwrite.  From the HOME tab, that choice is available by clicking the chevron to the right of the Save Project button on the toolbar.

Link to comment
Share on other sites

One would think it wouldn't be a problem, but *shrug* here I am. 😔

None of my stuff is high def.  The class is recorded during a 2-hr Zoom meeting (imported to VP as an .mp4).  I close-caption it, do the above minor edits (including trimming a little time), and spit it on to a link-access only YouTube channel when I'm done.  My computer runs 64-bit Win 10, so I'm now wondering if running a 32bit version of VP on my 64bit OS may be part of the problem, and/or that the original .mp4 is nearly two hours.  Again, one would think that's not an issue but...I'm not willing to discount anything at this point.

I purchased my license on Dec. 7 last year (I still have a screengrab of the license info and the receipt through PayPal); the only "version" I see on those is "Master's Edition" - which I assume simply means "paid version".  (If you are able to tell me what version was running between late Sept - early Oct., I'd happily go back to it, because I did not (as far as I can remember) run any updates between the initial "free version" download and the license purchase date.

I have tried some of the updates since purchase date, and dumped, them so many times since then...that I honestly have no idea what version was the one that ran decently on my system.  (I wish I'd had the foresight to save the .exe, or at least the version number, of the free version that had run properly.  The crashing problem started just a couple days after I'd paid for the license.)

I've just been going back to 10.12 because it's the only "old version" I had been consistently able to find a link, on the internet, for. (I have since saved a copy of 10.12's .exe to my computer.)

For the last week+ I've been using the manual cache dump you mention, roughly every 20 minutes (yes, I have set a timer to do this).  While doing the manual dumps has prevented VP from crashing, it is irksome to have to stop and manually do something that (in theory) the program is already doing as well.  (Yes, I do get the spontaneous "dumping unwanted cache" from time to time, but I have learned to not rely on them.)  I will usually do a .SRT save, and a full project save, as well as my own backup save of the project as it is, just before doing the manual cache dump.

I've downloaded the 10.26 beta you linked me to, which -judging by the fact I'm not seeing a 64- I'm assuming is a 32bit version.  I'll be back in a few hours with an update.

Thank you.

Link to comment
Share on other sites

Update:
Ok, so I didn't even make it an hour and Nope, the 10.26 beta is worse.

In the subtitle work screen, after a single keystroke (say, adding a comma to a sentence) I'd have to wait up to a minute and a half for the timeline to come back up.  And heaven forbid I try to do anything during that time, or the program would freeze.

If I did multiple keystrokes (say, adding a word to a sentence) it would:
- take even longer for the timeline to come back up
- the subtitle work screen would disappear behind the main work screen, then come to the front again
and/or
- the preview pane in the subtitle work screen would go blank (all background-grey) or it would just be a blank black square on the grey background. (I actually have a screen cap of this because of how long it sat like that.)

If, while in the subtitle screen, I pressed play, while the timeline was still blank:
- the program would freeze (happened twice, but no failure)
- the audio would play but only a black square would appear in the preview pane
or
- the audio would start to play; the video would not play for a few seconds, but then jump ahead to where the audio was when the video would finally start up.

Going back to 10.12 for the time being.

If you have any other suggestions (shy of "go buy a proper computer"), I'd love to hear them.

Link to comment
Share on other sites

Hi

My computer specs are...

Windows Vista Home Premium 32-bit SP2
Intel Core 2 Duo CPU E4500@ 2.2GHz, 2.0 GB RAM
NVIDEA GeForce GT 730.

This runs VP 10.24 with hardly any problems. Admittedly my usual video clips are only up 1920 x 1080 at 60fps and not 4K etc. It nevertheless manages to handle most editing without crashing.  This is just an observation.

Nat

Link to comment
Share on other sites

The 32-bit incarnations run fine on 64-bit PCs, but with a project of that length the new 64-bit architecture would be preferable.

What you report is definitely not normal and could be a PC-specific issue.  How much free space is available on the C:\ drive, which is where the cache files are written unless you have changed the path via OPTIONS | DISK tab.  Is this a conventional drive or an SSD?

Try this release.  Latest versions do not necessarily offer more functionality.  Many releases are small tweaks, perhaps adding a new effect, reordering a menu or fixing a bug.  Waiting to update may be wise, if all is working well.  The latest can be tested when you're not under the gun.  Your registration should be good through at least May.  Licensed versions within that timeframe don't expire.  Go here for most any release.  Judging by your date of purchase, you likely got this 32-bit version.

If possible, we'd like to see the project.  The process is easy, quick and can be done privately.  Just follow these steps...

  •     Back up --- With your project on the timeline, click on MENU at the top-left.  Click FILE|BACK UP PROJECT FILES TO FOLDER.  Choose a folder and SELECT FOLDER.
  •     Upload ---  Use a free server - Google Drive, MS OneDrive, etc.* - to upload the saved, numbered FOLDER.    Do NOT upload the individual VPJ or export file. 
  •     Get link --- Get a public link.  If using Google Drive click GET SHAREABLE LINK. If necessary change "restricted" to "anyone with the link can view" 
  •     Share ---     Click COPY LINK | DONE.  Paste that link here, or click the folder at the top-right of this forum to message it privately to me.  It won't be shared.

          *    Before uploading, right-click the folder, click PROPERTIES.  Look at the File Size to confirm that it's not too big for the free space on the server.

Link to comment
Share on other sites

Hi Nationalsolo,
So, for comparison:
Windows 10 Home, Version 20H2, OS build 19042.867, Windows Feature Experience Pack 120.2212.551.0 (copypaste from computer settings)
CPU: AMD A4-5300B APU with Radeon(tm) HD Graphics 3.40 GHz
Video Card: AMD Radeon HD 7480D (mode 1920x1080, True Color 32 bit, 60Hz
Properties of original video file, according to VP: .mp4, dimensions 2144x1080, sample rate 32000
Properties of original video file, according to original video file: .mp4, dimensions 2144x1080, frame rate 25 fps (which, wtf? That's not something I set, that's unaltered, "all I did was hit download" from Zoom.

I'm now, additionally, wondering if the odd frame size and fps are issues.

On 4/6/2021 at 3:00 AM, borate said:

How much free space is available on the C:\ drive, which is where the cache files are written unless you have changed the path via OPTIONS | DISK tab.  Is this a conventional drive or an SSD?

The hard drive is a (afaik) conventional 465 GB with 265 GB available.
Cache folder address is C:\Users\Nicole\AppData\Local\Temp\

On 4/6/2021 at 3:00 AM, borate said:

Try this release

I tried 10.24 when it came out, had issues with it; it was part of why I went back to 10.12, before trying 10.26.

On 4/6/2021 at 3:00 AM, borate said:

Go here for most any release.  Judging by your date of purchase, you likely got this 32-bit version.

Thank you for the link to the older release list, I'll make good use of that; and thank you for the direct link to (what is, hopefully) the version I got when I made my purchase.  Between that, and the link for the older releases, I should be able to figure out what the original free version I downloaded in Sept/October was. 👍

On 4/6/2021 at 3:00 AM, borate said:

If possible, we'd like to see the project. 

Sure thing.  I'm waiting for it to finish uploading to my Google Drive right now.  I'll message you privately with the link when it's done. Right now, G-drive says the upload is going to take just over 9 hours. (My internet is crap.)

Thank you again for all the help and suggestions.  See you in a few hours, with the link.

Nicole

Link to comment
Share on other sites

Posted (edited)

I just finished uploading the files to G-drive...but realized I hadn't finished skewing the identity of one of the students (this would be normal procedure for this student, nothing to do with sending it to you), so I'm going to go finish that and then re-upload everything to G-drive and give you the link when that is done.  Sorry about the delay.

Apr. 7, 06:49 Pacific Time ETA: So, I finally got all the necessary identity edits done - including just cutting out about 5 min of video toward the end, which jacked up the timecode on the subtitles, but I'll deal if it means you can figure out what's going on.  The final edit of the video will be slightly shorter, by about 5 min.  I am uploading the file to G-drive now.  G-drive estimates just shy of 9 hours to upload.

For what it's worth, I'm not the kind of person who does a lot of fiddling around with program settings, partially because I'm not very computer savvy overall and I'm always concerned I'll screw something up if I fiddle with too many things on the computer.  (My career is mostly carpentry and electrical work based.)  I prefer to find programs that will "just do the thing, straight out of the box".  I mention this because, if you find weird settings, display configurations, anything like that in the files...I didn't set them that way. As I mentioned, I download the .mp4 file straight from Zoom, into VideoPad; the subtitle file is a .srt straight from Otter, into VideoPad...and then I do all the editing of subtitles - and their timestamps - and of the video in VP.

Edited by NicoleB
Update of update plus time stamp.
Link to comment
Share on other sites

Thanks for sharing.

Ran your project in both the 32- and 64-bit VP 10.26 releases.  No 'hanging' - even after rewording some captions.

When first loading, let it fully cache.  This can take some time.  When done there will be green bar atop each video thumbnail. image.png

Eventually, the blue timline ribbon under the preview window will change color. image.png

Video editing is very resource intensive.  The issues that you are experiencing hint at a resource problem, even though your PC seems capable of handling a non-complex VP project.  That said, this one is HD, nearly two hours in length and has many captions. 

See my PM for a link to a lower resolution revised project.  Quality loss will be negligable, considering the source.

That, and installing the newly released 64-bit 10.26 should improve things considerably.

Link to comment
Share on other sites

Posted (edited)

Thank you for the "wait until everything's done loading properly" info/admonishment.  I didn't realize I wasn't waiting long enough (I was usually waiting 10 min or so before starting) and this may have been the source of all my problems, and I apologise for that.

The projects are always going to be caption-heavy, there won't be any getting around that.  😒

I had no idea it was in HD.  If you have a guess, was this how I downloaded it from Zoom, or something I'd accidentally changed in VP?  We usually take a break in the class, around the hour mark, but we'd always simply paused the recording; I'll start trying to get us to take a couple more breaks and stop the recording at each break as well, thank you for the suggestion of breaking it into smaller chunks for editing.  It will probably also help make working on the project overall, feel less daunting.

Thank you for the adjusted files, and the 64-bit 10.16 link.  I'm downloading those now.  I will get back to you in a couple days with a report on how things are going.

Thank you for all your help with this.

ETA: the 10.16 link you gave me is actually 64-bit 10.26...hopefully that will be fine.

Edited by NicoleB
Add and ETA.
Link to comment
Share on other sites

Yes, 10.26.  My error.  2144x1080 is an odd resolution.

In the future you might investigate whether the sessions can be recorded at lower res for your download.  Lower load, better editing response, shorter export time.  You apparently got what they offered, at the resolution provided.  No Videopad import settings will change that though file converters like Prism are useful.

The project likely won't have to be broken up.   Good luck!

Link to comment
Share on other sites

I have VLC (I use as my music player) and another program (I was going to use as my "last resort" subtitle editor if this forum couldn't help) already, so if needs I'll try those for conversion first, but I'll also keep your suggestion of Prism.

I'll check the Zoom settings later tonight and see what I can find.  I've no idea why it's in 2144x1080 and there's absolutely no need for these to be HD, and if I'd known that's what we were getting I'd have sorted that sooner. *eyeroll*

The files you sent back to me just finished downloading. I'm going to plug everything into VP now and check for the green bar and the purple timeline after dinner.  We'll see how this goes! *fingers crossed*

Link to comment
Share on other sites

Hello borate and Nationalsolo,

Well, between the file borate sent me with the altered resolution, working in a smaller segment*, making sure I zoom back out on the timeline after making a video edit before pushing play in the sequence preview, and <sheepish look> making sure everything is fully loaded into VP properly </sheepish look> things are working significantly better now...at least as far as the "editing the video" part.  This last half hour has a lot of the identity-protected student in it, so I haven't gotten back to the subtitling yet.

I also went back to the first handful of videos I'd worked on late last year, to see what the difference was between then and now...and I'm ashamed to admit that some of the issues I probably could have figured out if I'd done that first but...n00b here didn't think of that.  The first few months of videos were all roughly the same length (2-ish hours) and a shite-tonne of subtitles all the way through...but it was primarily one person speaking during that whole time.  Also, originally, we were using one of the co-teacher's free, standard Zoom account; I assume those file download defaults are different than if you have a paid account, which we switched to in January. 

Breaking up the video into smaller chunks (and reassembling at the back end) is extra steps it would be nice to not have to take -and breaking up the .SRT file we get from Otter will be a pain in the butt- but at this point I'd rather that than fighting the urge to throw my computer into a wall.

My only objection to 10.26-64 is that sometimes when I hold down the "previous frame" or "next frame" button (if I'm trying to skip a handful of frames) I will suddenly find myself having jumped clips (and yes...I'm sure I'm on the right button because it only happens occassionally and I don't use the "clip edge" buttons), but I'm just going to train myself to use the arrow keys on the keyboard for that from now on. 😁

I still need to look into changing the resolution settings for the Zoom recordings, but the next class isn't for a week and I really want to get this video in the can.

I'll swing back by and let you know how subtitling goes when I get back into that for this half hour segment; hopefully it will do smoothly.  I'm sure y'all will be glad to be rid of me after that.

Thank you again for all the help, especially the info on the weird resolution and suggesting changing that -I definitely never would have figured that out on my own- and the pointer on knowing when VP is actually ready to start working (the purple and green bars)...and for your patience with me.

Nicole
* I copied the original Zoom .mp4, cropped it down to the last half hour that I still need to work on, and have been working on that independent of the original 2 hour project file.

Link to comment
Share on other sites

Hello again, I return to bring a final update.

The subtitling process on the re-spec'd, smaller chunk is going smoothly on VP's end (I'm having to manually reset all the times even though I imported a time-coded .SRT, which...pain in the butt, but 🤷‍♂️).  VP had a little "blue buffering box" fit a few minutes ago, but I also clicked a whole bunch of things in series, so I blame myself for that one.

Thanks again for all the help, suggestions, and patience.

Cheers!

Link to comment
Share on other sites

Unfortunately, they come pre-timed from Otter if I download them as a .srt.  But I can download a .txt or .docx transcription of the video, and then build the .srt myself...but but I'm trying to get these out within 2 weeks of the initial class date (basically, we meet every two weeks, and I'm trying to get each one done before we hold the following class.  That hasn't happened since January.)  But thank you for the heads up on that.

<musing aloud, left here as a note to myself>Ooooohh...I wonder if, at the beginning, after breaking the video into segments
I can run sections of .txt, with their associated video segments, (I tried generating my own .srt by hand timestamping a .txt....*crazed laughter* nope, never doing that again)
through YouTube,
to generate individual .srt's, that I can download into VP, (because 🤬🤬 trying to edit in YouTube)
and then just edit the captions instead of having to mess with timestamps and editing the captions.
That shouldn't affect the subtitles because I embed them with I export the final .mp4, and if I edit the final video to final length, out of the exported .mp4 lengths, that shouldn't affect the captions because they're embedded...
<wanders off>

Link to comment
Share on other sites

Subtitle code is related to track timing, not to the individual clips.

So, for example, if you have a production that's been subtitled and the first five minutes are deleted, then the subtitle file reapplied, the subs won't match up.

Sounds as if your best bet is to add all titles to the original video, then export segments if necessary, do final tweaks.  Since the titles are embedded they will be in sync with the content.

Link to comment
Share on other sites

7 minutes ago, borate said:

...add all titles to the original video, then export segments if necessary, do final tweaks.  Since the titles are embedded they will be in sync with the content.

I'll probably try this first, since "one giant video" is most of what got me here in the first place.  Thank you!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...