Jump to content

Problem resizing clips


Recommended Posts

Hi all,

Just hit upon a problem that is stopping me dead in my tracks ☹️ This is in my second project with VideoPad v10.12 64-bit, I never had this problem in my first project, or in any project using earlier versions. 

When I hover on the edge of a clip, a resize cursor appears (square bracket between two arrows) and I can drag the edge to resize the clip. But every now and then, for no reason I can think of, the resize cursor does not appear (anymore, it might have done previously) on the right edge of the clip, so I'm unable to resize it on that end. Instead when I hover, it shows the balloon with the clip info. The clip edges look totally normal at that position. Following images should clarify (inline images don't seem possible here ?)

Ok, resize cursor appears

Problem, resize cursor does not show

I did not find another way to resize the clip. Any ideas would be most welcome.



Link to comment
Share on other sites

Using 10.12 (64) unable to replicate that behavior.  Try expanding the timeline (slider at the bottom-right), to see if the bracket becomes available... image.png  Roll the mouse pointer over the bulky handles, not just the lines.

Test the current release.  For licensed users upgrades are free for up to six months from purchase date.  After that, VP will continue to fully function but a fee will be required in order to register the newest.  Retain your old install file and registration info.

Link to comment
Share on other sites

Thanks for looking into it Borate 👍 

But I'm not surprised you cannot replicate it.... It seems to happen to me quite randomly, after editing for a while. I already tried massively zooming in on the timeline (using the mouse wheel) but it did not help. Nor did saving the project and restarting VP. Just I downloaded the current version (10.17, right ?) but the problem persists. Unless I find another way to resize the clip this is a showstopper for me, preventing me from completing my video.

BTW You included an inline image ! How does that work ? I could not find the option.


Update ! I got the bracket icon back by zooming OUT the timeline ! Isn't that strange !! It now turns out the disappearing act happens when zooming IN on (i.e. expanding) the timeline. While this might just save the day for me it is hugely inconvenient, because to properly align video and external audio, I need to zoom out quite a lot otherwise it becomes a hit-and-miss exercise.


Update again.... alas it's not as simple as that. It also happens (sometimes) as a result of resizing a clip, without the timeline being zoomed in or out. I'm starting to have doubts about being able to complete my video, and am also starting to regret shelling out money for the upgrade to 64-bits 10.x, only to encounter issues where my 32-bits 4.x version worked without any issues.

Link to comment
Share on other sites

You can include a link to an image which, when clicked, will display it.  Upload the file/s to a free server, such as Google Drive or MS OneDrive, get a shared (public) link, copy the link and paste it here or to me in a Private Message via the mail envelope in the top-right corner of this forum.  Using Google Drive, if necessary change "restricted" to "anyone with link can view."

Did you test he current release, linked above?

It's possible to revert as well  Just retain your registration.  The installer was likely saved to "C:\Program Files (x86)\NCH Software\VideoPad" (or similar, without the X86).

Save Project File AS routinely, giving it a unique # or name, so as not to overwrite prior saves.  Using Save Project Files (no AS) will overwrite.

Share your project.  List specifics on your 'resizing.'  Someone will do the same - try to see what you see.  The process is easy, quick and can be done privately.  Just follow these steps...

  •     Back up --- With your project on the timeline, click on MENU at the top-left.  Click FILE|BACK UP PROJECT FILES TO FOLDER.  Choose a folder and SELECT FOLDER.
  •     Upload ---  Use a free server - Google Drive, MS OneDrive, etc.* - to upload the saved, numbered FOLDER.    Do NOT upload the individual VPJ or export file. 
  •     Get link --- Get a public link.  If using Google Drive click GET SHAREABLE LINK. If necessary change "restricted" to "anyone with the link can view" 
  •     Share ---     Click COPY LINK | DONE.  Paste that link here, or click the folder at the top-right of this forum to message it privately to me.  It won't be shared.

          *    Before uploading, right-click the folder, click PROPERTIES.  Look at the File Size to confirm that it's not too big for the free space on the server.

Link to comment
Share on other sites

Thanks for all the tips, and for editing my post to include the updates which seems good practice.

I did include links to the images on my OneDrive. Still don't see how you got an inline image in your post.
Yes I did test with release, as I wrote. The problem persists.
Reverting back to an old version is tempting, but I'd rather not have to do that. Especially as I paid for the 64-bit upgrade.

On the plus, I seem to have found out when this happens : it's after I have done one or more resizes with the shift-key (which is my habit). Since starting with a new project and leaving the shift key alone, the problem hasn't manifested. It's a bit inconvenient, but not a huge problem anymore. Fingers crossed though.

If you're interested I can backup and share a project with just two small video files, and instructions how to reproduce the problem.

Link to comment
Share on other sites

Using <shift> as you apparently are can cause unpredictable results - missing split lines, double Xs, odd lengths.

In most cases there is no need to use the shift key when dragging handles to change a clip's duration.

That said, to leave a gap when dragging a clip's right handle to the left, use <shift>.

To leave a gap when dragging the left handle to the right, use <alt>.

Link to comment
Share on other sites

Yes there is a need to use <shift>, as the video must be *exactly* aligned with the externally recorded audio. Without <shift> it takes much longer, and trial and error, to get it right. It amazes me that you say using <shift> can cause unpredictable results. I've used it intensively (as per the documentation) for many years without any issues whatsoever, and now find it's broken in the latest versions. Surely this is still a supported functionality ? If so, it is a bug plain and clear. Can I log a ticket with NCH to get this fixed ?

Link to comment
Share on other sites

You can certainly file a report...   https://tinyurl.com/yc26uooz

Illustrate, with link to video if possible, how it worked in the past and how it's broken now.  And point out the documentation that relates.  This, from the HELP files...

In Timeline mode, clips can be dragged left and right and move them earlier or later in the timeline, or up and down to move them to different tracks.

When either end of the clip being dragged is near either end of another clip, or the start or end of the sequence, it will "snap" to that position. Hold down the Shift key while dragging to temporarily disable this behavior.

When moving a clip so that its left edge is inside of another clip, that other clip will be split and the clip will be inserted at that point. Hold down the Alt key when dropping the clips to temporarily disable this behavior.

But documentation for snapping isn't always correct.  There has been much discussion on how to handle it.  Behavior can vary, even for the same release.

With the timeline expanded using the slider at the bottom-right, clips can be sized and dragged with precision without <shift> or <alt>, except for using those keys (if necessary in a particular VP build) to create gaps so a clip can be shifted left/right without affecting adjacent clips.

To share images, upload them to a free server, such as Google Drive or MS OneDrive, get a shared (public) link, copy the link and paste it here.  The image won't display in your post but the clickable link will bring up the page where it's stored.  To share a project see the instructions in the earlier reply.

Link to comment
Share on other sites

Yes, by sufficiently expanding the timeline it can be done without shift. Not a big deal now that I know about it, so I can live with that. From what you write it seems a bit of a sensitive area so I'm not sure sure if submitting a bug is worth it. You never know what side effects a bugfix could have ... better the devil you know 🙂

Thanks again for your help. Much appreciated.

Link to comment
Share on other sites

Someone is always here for you.  Agree that it can be annoying to find that familiar ways of doing things have changed.  There have been many changes since the 4.x series.

Be aware too that features (like the snap behavior) may act slightly differently with each, repeated install.  No need to re-download. And no mandate to update if what you have is working well.  There's a six-month upgrade grace period.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...