Jump to content

Videopad never stops processing audio - UPDATED


LJW
 Share

Recommended Posts

I've been noticing that Videopad quite often, when exporting (usually a video to computer file), shows that it is processing audio.

Problem is it never stops processing audio - it just gets into some kind of endless loop.

This has happened to me on a number of occasions and is destroying my productivity.

Please explain what 'processing audio' means and why it seems to hang up in this way so often.  I note that many others have similar problems.

Videopad is a great little editor  and i love using it - but its so getting so bad now that I may need to consider going elsewhere for a solution.

Please give me a solution! 

Link to comment
Share on other sites

Under OPTIONS | DISK tab, Clear Unused Cache files.  It's wise to do this prior to beginning a new project.

Not all "processing audio" issues are the same.  Update to the latest version.  For licensed users upgrades are free for up to six months from purchase date.  After that, VP will continue to fully function but a fee will be required in order to register the newest.  Retain your old install file and registration info.

If the issue persists please share your project.  Someone will take a look and come up with a fix.  The process is easy, quick and can be done privately.  Just follow these steps...

  •     Back up --- With your project on the timeline, click on MENU at the top-left.  Click FILE|BACK UP PROJECT FILES TO FOLDER.  Choose a folder and SELECT FOLDER.
  •     Upload ---  Use a free server - Google Drive, MS OneDrive, etc.* - to upload the saved, numbered FOLDER.    Do NOT upload the individual VPJ or export file. 
  •     Get link --- Get a public link.  If using Google Drive click GET SHAREABLE LINK. If necessary change "restricted" to "anyone with the link can view" 
  •     Share ---     Click COPY LINK | DONE.  Paste that link here, or click the folder at the top-right of this forum to message it privately to me.  It won't be shared.

          *    Before uploading, right-click the folder, click PROPERTIES.  Look at the File Size to confirm that it's not too big for the free space on the server.

Link to comment
Share on other sites

Videopad can be rather busy in the background. What exactly does "usually a video to computer file" mean?

What is your hardware and what is the resolution you are working on?

If you just cleared out the videopad cache it can take a long time for the audio working again.

I have had to wait well over an hour on a project to become "editable" again. (1080p video)

And I'm using a 6th generation i7 processor. But on older hardware it will probably seem like forever.

Link to comment
Share on other sites

Using the latest release, project loaded w/audio quickly and took about 15 minutes to fully cache before preview was seamless, owing to the 10GB file.

Thereafter, a test export at 854x480, at default mp4 settings, showed no audio processing delay,  Took about ten minutes.

As Uberprutser hints, hardware makes a difference.  Video editing is resource intensive.

When stabilizing, click ADVANCED and in column 1 specify the source pixel aspect if necessary.  In column three you might want to apply an edge compensation.

Link to comment
Share on other sites

My system is as follows

ACER TC-895, Windows 10 home 64 bit, i7 10th generation processor Intel UHD 630 graphics, 8GB DDR memory, 256GB SSD, 1TB HDD, WD MyCloud network drive. 

I think that should handle things.  The task manager never shows that the PC is under any particular stress.  I have noticed on some occasions that VP produces absolutely massive audio files and goes on all night without finishing.  Seems to get itself into a loop. 

I try to provide VP with files that it 'likes' to keep processing efficient, but sometimes it falls over.  Other times it's great and renders just as you found. 

What kind of gear are you using to achieve the results you mention above?

Any other suggestions?

Link to comment
Share on other sites

The underlying issue appears to be with Stabilized - GP031029_0001 fragment_0003.avi.   Media properties lists it as 49 hours long.  It's hanging VP.

Rather than 1080, to save time the GPO file was exported at 480, 25fps.  After importing the mp4 result into VP, it was stabilized with the NTSC setting.

This resulted in an AVI that had the correct file sizes.  That file was substituted for the original in the project.  It exported well as an mp4, 25fps @480. 

There was no processing hang or lag.  A 1080 export would likely have succeeded as well, with negligible quality loss on that content.

Don't import files that won't be used in the project.  Or, when editing is complete, delete them and Save AS to update the VPJ file.

Here, I7 (8th) Z390 CPU, NVidia 1060 GPU, 32GB RAM, 1TB SSD (ample free space on C:\).

Link to comment
Share on other sites

Stabilized - GP031029_0001 fragment_0003.avi was generated using VP Stabilize image from the original file GP031029.mp4 which is 58 mins long.  so the deshake process is corrupting the file!

All files used are PAL (not NTSC).

Further attempts at stabilisation using other files have also been leading to files with errors.

Any idea why the stabilised files are being corrupted?

Any ideas on how to fix it?

Also, after being stabilised the files are being put into the audio folder as audio files! - what is going on!

How can I make sure that Deshaker works correctly?

Link to comment
Share on other sites

Final analysis

GP031029.mp4, which was 12:00 long wasn't used in the project and was deleted to reduce unnecessary file loading.

The Stabilized Fragment.AVI file is bad and was hanging VP - audio is many hours long yet the video is only about 4:36.  It was replaced with a re-encoded version.  Can't say what went wrong with the original deshaking of that file because...

The Stabilized Test Video 2.mp4 file is good.  Both A and V are the same length.  Stabilizing creates an AVI but this was an mp4.  How was it done?

The Test Video Singling.mp4 was A/V UNlinked and being used only for audio but video was still a part of the load.  Under the BIN Sequences tab Sequence 1 was right-clicked to create a new WAV using Save Sequence to a New Audio File.  Singling.mp4 was deleted, which cleared the audio track, and the WAV file was added in its place.

Now the project contains two video files, one audio file and the VPJ control file.  Export at 1080 is quick and the program no longer hangs.

In the future, suggest that you pare down the original file, retaining only the segments to be used.  Then stabilize just those segments independently and load them into the final build.  Experiment with deshaker settings.  NTSC has worked well here, even when the final export is to be PAL.

Stabilizing a twenty-minute mp4 went flawlessly, so it appears that the GoPro files don't play nicely with the deshaker at 1080.  No firm conclusions.

Link to comment
Share on other sites

  • borate changed the title to Videopad never stops processing audio - UPDATED

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...