Jump to content

Audio/Video still out of sync when recording directly into VP

Recommended Posts


Since I've searched on older threads, and it clearly says each time "please start a new thread this is too old" here it comes again. Tried to find an answer, I have a paid license of VP on both PC and on a MacBook Pro. Have tried this on both win 7, win 10 and on Mac OsX 10.11. Recorded with one tiny webcamera (Logitech) through USB and then through a USB (and Firewire on mac) soundcard interface. All CPU's are modern ones so to speak with speeds over 3,2 Ghz. Nothing else running.

Even when recording video/audio at the same time, and a short one and a half minute of it, it doesn't sync audio video at all. I've tried 44 Khz settings 48 Khz, and whatnot. Immediately when playing up the recorded material, audio/video is waaaaaay out of sync with several seconds. The unlink doesn't really work, as it can be "nailed" at one sweet spot, but after 20 seconds it is so totally out of sync again. I tried use default settings too. And least common denominator to NOT record at high resolution *.avi right away. I have searched other threads and forums but I still can't find anything but that this is the program. Only. Period.

So how to fix this WITHOUT having to do unlink afterwards ? Even the old InterVideo program that came in the end of 90s beginning 00s did this. It came bundled with DVD burners. Cheapo, very limited program, but at least, it got in sync at once. Alas, it doesn't install anymore on modern OS.

Link to post
Share on other sites

What version of Videopad is being used?  Upgrade to the current release.  For licensed users upgrades are free for up to six months from purchase date.  After that, VP will continue to fully function but a fee will be required in order to register the newest.  Retain your old install file and registration info.

So it's out of sync imported to the bin, not just after export?

Take a minute to share a file or two that does this and someone here will check it out.  Just upload the file/s to a free server, such as Google Drive or MS OneDrive, get a shared (public) link, copy the link and paste it here or to me in a Private Message via the mail envelope in the top-right corner of this forum.

Using Google Drive, if necessary change "restricted" to "anyone with link can view."

Link to post
Share on other sites

Thank you!

it's the latest versions. However on MacBook pro it's 8.40. since the latest doesn't work with OsX 10.11. I can't upgrade to the newest OS since that will render all the rest of my programs unusable, and especieally since I have a posh FireWire Soundcard connected to that one. Later OS than 10.11 will not support any FW. But let's stick to win 7 then.

Now this has been going on since May 2020, where it - really - was the "latest" versions, back then, and it's nothing that is remedied or cured with the newest ones. It's out of sync right out of finishing the recording, and pressing play to review it. Really out of sync, not by milliseconds, but by several seconds, like 3-4. Export,  I haven't even gotten to yet since it is no use of exporting (and waiting a long time) something that is out of sync.

And thus, since I have not exported it, I don't find any reason to share the Mp4 or *.avi file to anyone yet, since it doesn't help me (or others here I've reckoned) a single bit. This will only make sense, if the recorded flick was really in sync, but the exported one ended up totally out of sync. Only then. I don't see the reasons why VP should record anything out of sync, while other older and simpler programs does without struggle. Even when I tested a video, recorded IN SYNC (perfectly) with ancient InterVideo program, imported it to VP, it reviews and plays out of sync there.

BTW it certainly isn't unheard of before, as someone else has already complained about this, and you certainly don't need another exported video to be able to scrutinize the details of it. If there's a solution to it before (settings or else) it should apply to this thread as well. I've tried changing resolution settings, and codecs and whatnot.

I've searched all other topics and threads about this, older and newer, around here, and it seems that everything regarding audio/video sync is still in limbo with the developers of VP.

Link to post
Share on other sites


"....Even when recording video/audio at the same time, and a short one and a half minute of it, it doesn't sync audio video at all....."

It does seem that you have a synch problem but I can't reproduce that here with a similar setup.

Using version 8.97 and a simple USB Hercules Blog Webcam with built in microphone I recorded a 2 minute video 800 x 600 at 15fps directly into VP using the Record Option. (Video and audio recorded together)


The main problem I found was during the recording when a delay between tapping and counting and the preview display during the "take" was evident. I am using an old Vista machine so I expect some lag between the VP record screen display (set at full screen) and the audio.

Nevertheless the mp4 that was produced and placed automatically in the clip bin and subsequently loaded to the timeline previewed perfectly and remained exactly in synch from start to finish. Granted that this is not a long test but it would seem to be similar to your description using a Logitec webcam.

The export as an Auto match content mp4 (800 x 600) was set at 15 fps (the default was 10fps variable) and played back in VLC perfectly......no de synch at all. 

I then used a silent webcam and a separate microphone to see if that might induce some desynch....



This recorded to VP without any desynch as before and exported perfectly also.-_-

Another shorter test for a minute with the same setup showed EXACT synchronisation between the tapping sound (ruler on a pen point) and the video.......Note cursor line on the audio "tap" and the ruler just touching the pen tip..... 


...and two frames later..note the gap between the ruler and pen point and position of red cursor line now....That's pretty exact to my mind.


Where your desynch is coming from but it does seem to originate with your method of recording, your system or some codec or format problem.



Link to post
Share on other sites

Don't need an exported video;  that wouldn't be of use.

But supplying an transferred file that is good elsewhere but not in Videopad just might - perhaps one that was recorded with the old software.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...