Jump to content

Video Pad only playing sound on MP4


Recommended Posts

I'm an old user of VideoPad that just started using again. I've seen several topics in this forum that shows the same problem I'm having. I can load an .mp4 file and can hear it but not see the video. I wanted to give a little more information on the issue.

VideoPad Professional v 8.96

But the interesting thing is it's not affecting all .mp4 files, just some.

Here's an .mp4 file created by an old version of VP about 3 years ago. It works fine. I can read the file and see the video when I play it back. It's an anhinga (Florida bird) eating a fish.

https://drive.google.com/file/d/14Px7PdAuuwN76pEWq5y6Q0MJt7Lde4Qi/view?usp=sharing

Here's an .mp4 recorded last week on my GoPro Hero Session 4. I can import it but when I play it I only get sound. When I export the video I get a message that the file is corrupt. It's a Pearl Crescent butterfly.

https://drive.google.com/file/d/1FtTpwfK_fRZjVh5fViOUYCaUbwwajdAV/view?usp=sharing

And if you were able to watch either of those you will find I like to record wild animals. Both of these videos play fine on my computer.

Thoughts appreciated.

Link to post
Share on other sites

I'm having the same problem. I have two videos, recorded on the same day, both with a GoPro. Both can be viewed on my media player, but when I drop them into the VideoPad editor, one has a black screen and audio and the other is fine.

Screenshot of editor screen with cursor on functioning segment: https://photos.app.goo.gl/2A6q5AKMZgCCyi3n7

Screenshot of segment not working: https://photos.app.goo.gl/upMMsmyx6jEk9wQR9

I have a non-commercial trial, thinking about purchasing, but having problems.

Link to post
Share on other sites
  • 2 weeks later...

I seem to have a similar issue as the OP though it may be all mp4 files files. I have been using 2.41 (free) on a Lenovo T520 running Win 7 the past 8 years with no issues. I just switched to a Lenovo W530 running fresh install of Win 10 1909 but discovered 2.41 won't install on Win 10 so I just tried 8.97 (free). First 2 times trying to get a small mp4 file (4 minutes of 1280x720) even loaded to timeline ended in me eventually killing the process as it pegged all 8 cores of the i7. Last attempt I added some pictures first (perhaps not necessary) and then a much smaller (30 sec) video which still pegged CPU but for shorter time. After waiting several minutes for it to settle down, it would play the audio but not show the video. I assumed it was a limitation of the current free version, but it appears it may be something else. Yes, it's an old machine but I didn't have any issues with the even older machine. I have no trouble playing the files with MPC-HC. Win 10 loaded Nvidia drivers for the K1000M from 2019 (what Windows installed) and DirectX 12. I tried getting the latest straight from Nvidia but only option I see provides DCH drivers and the installer says the system is configured to require standard drivers and I can't figure out how to get those from Nvidia. I could perhaps try uninstalling the drivers with internet off and then seeing if it will allow install of DCH ones but I'm looking for "cleaner" solutions first. I could also try not using the discrete graphics but that seems like taking a big step backward.

Link to post
Share on other sites

Smacks of a hardware issue, as some older, low-end machines do quite well with simple Videopad projects.  But we'll have to take a look to get to the bottom of this.

Share your project.  Someone will very likely come up with a fix.  The process is easy, quick and can be done privately.  Just follow these steps...

  •     Back up --- With your project on the timeline, click on MENU at the top-left.  Click FILE|BACK UP PROJECT FILES TO FOLDER.  Choose a folder and SELECT FOLDER.
  •     Upload ---  Upload the saved, numbered FOLDER.  Use a free server - Google Drive, MS OneDrive, etc.*  Do NOT upload the individual VPJ or export file. 
  •     Get link --- Get a public link.  If using Google Drive click GET SHAREABLE LINK. Change "restricted" to "anyone with the link can view"  Click COPY LINK | DONE.
  •     Share ---    Paste that link here, or click the folder at the top-right of this forum to message it privately to me.  It won't be shared.

          *    Before uploading, right-click the folder, click PROPERTIES.  Look at the File Size to confirm that it's not too big for the free space on the server.

https://www.nch.com.au/kb/10265.html

Link to post
Share on other sites

The project isn't the issue. 8.97 clearly doesn't like something with this somewhat newer hardware or Win 10 1909 as I can install 8.97 on my old Win 7 laptop (running DirectX 11) and don't have much issue with the exact same file being read from the same SD card. 8.97 does still use more CPU than 2.41 did and seemed to take 2-3 times as long on that laptop (I judged this on the Resource Monitor graphs) using a fresh install of each.

The new laptop is running DirectX 12 (as confirmed by dxdiag, which claims there are no issues), and I have finally been able to update graphics drivers for both discrete Nvidia K1000M and integrated Intel HD Graphics 4000 adapters. It doesn't matter which adapter I use and it performs just as it did with the Lenovo drivers. Upon adding the file to the project, CPU spikes to 98-100% and remains there for over 5 minutes. At about 6 minutes it starts to slowly comes down and will finally go back to nothing at 8-11 minutes (this is just for Videopad with nothing else running, of course). It won't display any video but will play the audio.

After another half an hour or so: Well, just letting Videopad sit doing nothing may have solved whatever was causing the issue. After a lunch break I started trying other video formats (3gp, avi, flv and wmv) and they were working so I tried MP4 again and it worked. The file I had already added still wouldn't play but deleting it and re-adding did work. WTH?!?!? I'm going to reboot for like the 20th time today and hope it still works.

Edited to add: it does seem to be working now. I have no idea what the issue was. Shouldn't have been Windows AV or anything like that as there was no disk (or really CPU either once VP settled down to < 1 %) activity. Something happened in that 30 minutes though.

Link to post
Share on other sites
3 hours ago, borate said:

Hints at a hardware issue.  Share the file and others will compare their performance to yours.

Perhaps you missed the 2 bolded items from my last post; it seems to be working acceptably at this point. I don't buy that it was a hardware issue either. I've seen a lot of weird stuff in my 30+ years of working with PCs (and I'm also an electrical engineer), but this did not act or resolve itself like any hardware issue I've ever encountered.

On an unrelated note, I don't understand why they removed the ability to remember the last Custom Export preset settings like 2.41 did and don't like the reduced number of quality levels on the AVI encoder settings. It used to be a slider from 1 to 51 and now it's just 7 bitrate options (or 4 "quality" levels). I'll have to see if they made anything else more difficult. I was looking into other free editors after my first bad experience with 8.97, but they all seem to make text overlays that fade in and out far more difficult than it should be so decided to give VP 8.97 one more chance.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...