Jump to content

Sound goes out of sync upon video export (more information)


Recommended Posts

I have reported this bug before, but now I have more information which may be helpful in reproducing it. Do with it what you will.

using VP 8.95
This is my system
produce 5 videos / week, each about an hour long
video raw footage recorded using a Hauppage Pro, which creates .TS files.
This bug has existed since at least version 8.91, probably earlier (I honestly don't remember when I first started encountering it).

Reproducing the bug:
Pull the raw footage (TS file) into VP. Add in my ancillary files (WAV track of equal time to the raw footage, plus intros and outros, generally either MP4s or AVI files of short duration)
Synch the audio to the video (game sound must be synched at both the front and back end [which requires a "speed change" in order to move the back end without moving the front]. The "commentary" WAV file need only be synched at the front and seems to always hold synch through the entire length once synched at the front).
Edit the file (a lot of taking out excess footage and removing extraneous noises from the WAV track)
Export the resulting project as an MP4 file (using preset "YouTube 1080p HD").

The produced MP4 file shows a slip of the audio by 0.3 - 0.4 seconds against the video compared to what is shown in the VP preview pane during editing. The audio is slipped forward (i.e. it must be pulled backward by that amount of time to resynch it). This is 100% reproducible, it happens every single time (5 times a week in my case). Interestingly, it seems to matter not at all how long the video is (all of mine are AROUND an hour (+/- 15 minutes), so I've not tested it with anything much shorter or much longer than that), it's always 0.3 - 0.4 seconds.

Return the created MP4 file to VP, unlink and realign the audio track to the video (no speed change is necessary to synch the back of the audit, once you resynch it at the front of the video, the audio is synched across the length of the entire thing), and re-export (using the same settings). The resulting MP4 file does not slip, the audio is synched the same as the preview pane of VP.

This is the way I have been working for some time now (some months?). It's kind of annoying, but it's workable.

All of this I previously reported. Now for the new information. This I sort of discovered by accident:

Alternative workflow:
Pull in the raw footage (TS file) into VP. Immediately export it to MP4 (no editing, synching or anything, just pull it in and export it, using the "YouTube 1080p HD" preset). My presumption is that this export will also slip the audio track, but who cares, I didn't synch it in the first place.
Clear the project to a new one, bring in the raw footage as the MP4 file (along with all the other ancillary files). Edit as normal (synch the audios, edit out the extraneous stuff, etc).
Export the resulting project as an MP4 file (using the preset as described above). This is exactly the same process as the original workflow, the only difference is there is no longer a TS file involved, everything is either MP4, AVI, or WAV files.

The produced MP4 files shows no slip of the audio, it is perfectly synched to what was shown in the VP preview pane.

As the only difference between workflow 1 and workflow 2 was the removal of the TS file before editing begins, my conclusion is there is something amiss with how VP encodes the MP4 export file when (and only when) a TS file is part of the input. I don't know why that would be (my assumption was when a file is pulled into VP, it converts it to its own format, and the original input format is no longer of any consequence, but that doesn't seem to be the case [or maybe there is something wrong with that conversion that doesn't show up until you try and export from it, I don't know]).

Well, I hope that helps. It sure would be nice if this particular bug was tracked down and squashed. It's not a HUGE deal (especially with my alternative workflow, which is significantly faster than what I was doing), but as I have to do this five times a week, extra steps are always annoying, so cutting out the extra exporting would be a good QoL improvement for me at least. Surely I can't be the only one using TS files, Hauppage is a pretty commonly used piece of hardware for this kind of thing.

I know you are going to want me to upload a sample project. You really should be able to reproduce this yourself (assuming you can create a TS file). But since I know you're going to ask, here is one I previously uploaded that should do just fine to reproduce the bug:

[EDIT: actually, scratch that file, I'm uploading a fresh one, I'll edit the link in when it's done uploading]

Link to comment
Share on other sites

Tested two low-res exports of that familiar project - one H264, the other MPEG4.  At 42:15 lip sync, and at 56:10, tearing the panel out, looked fine.

Then a 1080 export was created and it too was in sync, or close enough to not be annoying to my eyes.  If it is, to yours, the best alternative may be to first convert the TS file.  So unable to replicate your result in 8.95.

Link to comment
Share on other sites

Here is a link to a new project, if you would care to take a look


The fact that it is not happening on your system, yet is 100% reproducible and consistent on mine suggests there is something different about our set ups. Perhaps you could suggest some settings I could look into that might be causing this? I will update my video drivers (although the ones I have are not that old, I will check them). Is there anything else? Hardware acceleration, etc.?

Link to comment
Share on other sites

The nature of this content makes for tough analysis.  By 1:08:00 (suffragette) is out of sync on the timeline, so export will obviously be the same.  If that clip alone is speed changed to 92% it's pretty close.  So, no real conclusions.

Hardware acceleration can be toggled under OPTIONS | EDITING tab.  Future versions of VP promise to better utilize GPU, for faster performance.

Link to comment
Share on other sites

Thanks, I will give that a try.

[EDIT: Well, thanks for the attempt, I give up. I updated my drivers (they were more out of date than I thought, but now they are updated), I toggled on the hardware acceleration, and then tried both H264 and MPEG4, and I'm getting the same result. Guess I'll just have to do that conversion from TS to MP4 before I edit, that works fine. Not a big deal really. Thanks for trying. Perhaps this will go away when the 64 bit version arrives].

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...