Jump to content

Everything above track 1 missing (H265 failure) /Zoom response


Recommended Posts

I thought I just posted this. But because I have to wait till v.p. becomes responsive again I will do it again :)

I just exported a project using the h265 codec and everything above track 1 seems to be missing.

Any ideas how to prevent this? Because before I did a quick h264 export found some spelling errors fix them before the final export, and now this.

Seems like unreliable v.p. is wasting my time again :(

Update: I deleted the v.p. cache file and exported again using h256, this worked previous when I was missing elements. But this time no luck.

So thanks v.p. for another time wasting experience. And this is starting to really piss me off!!!!

Link to comment
Share on other sites

Thanks I'll give that a try. b.t.w. I use the same version.

I just did a h264 export, without making any changes, so directly after the h265, and that worked fine. Everything seems to be there.


I'm sorry but I do not seem to understand what you are saying Dangerfreak.

I only have on sequence so how do I export one after the other?

Link to comment
Share on other sites

There are three general areas where things can go awry...

1.  Unfamiliarity with VP specifically or editing in general
2.  Software glitches/bugs
3.  Hardware limitations

Most of your queries have been in the first category.  Takes time.  VP is relatively easy to master vs. high-end editors that exact a steep learning curve (and price).

Software bugs do creep in to the VP quick update cycle, yet most are obscure.  Those that can be described clearly and replicated by others are quickly fixed.  A  user is well advised to stick with a release that works well for them, and not chase the latest update - especially a beta - which may have undiscovered issues. NCH policy is generous:  a new release can always be trial tested with few limitations and no watermark.  The user's paid version can be reinstalled.

Higher-end hardware isn't necessary, but it helps greatly - especially when dealing with multi-effect/track, lengthy, high-resolution content.   A 64-bit release will eventually arrive but today 32-bit Videopad is subject to Windows memory constraints. This can result in issues on complex, lengthy projects.

To succeed, you can try several of the suggestions mentioned in other threads, such as splitting up a longer project, exporting with a different codec or lowering resolution.  The best way to get help is to share a project here.  Also be certain that a track has not be soloed prior to export.

Link to comment
Share on other sites

  • borate changed the title to Everyting above track 1 missing (H265 export)

In my opinion there is a bug in the function "Menu -> File -> Export all sequences...". So try to use "Menu -> Sequence -> Export video" (= CTRL + B ) or click the "Export Video" icon in the tab "Home". If you do so, only the current sequence in the timeline will be exported. However, it will export all tracks.

Link to comment
Share on other sites

You are right, it seemed to work well. But then I noticed that only one audio track (if there were more than one) was exported for some sequences. It happended several times with different projects, so I don't think it was coincidence. Unfortunately I can't pinpoint the problem more detailed yet.

Link to comment
Share on other sites

Hi Uberprutser

Relating to your H264 and H265 exports of mp4.

I checked a 4 track timeline having distinct clips that could all be seen on export and this included a title text on Track 2.

H264 Export....    

All the tracks exported and the result was perfect with no missing tracks or other errors.

H265 Export....   

This failed to initialize the output and produced a Windows message on a white screen. saying that x265enc3.exe  had ceased to function.    Should the encoder have failed?     ?Problem with 64 x 64 pixel blocks on the clips used? No idea. So can't comment on any loss of higher tracks.

MPEG4  Export       

This exported perfectly.

"...I'm sorry but I do not seem to understand what you are saying Dangerfreak.I only have on sequence so how do I export one after the other?...."

The word sequence I tend to reserve for timelines that that have been converted to Sequences and which placed in the Sequence Bin leaving the timeline empty. This process allows the user to work a large project in sections with many sequences being stored in the bin.  What is on the timeline I generally refer to as the Timeline or Sequence Line or make reference to individual tracks. Otherwise there may be a misunderstanding with the word sequence. To be strict of course you do have a sequence of clips on the timeline , and it means you can make a single export of those clips.

Sequences in the Sequence bin can also be exported but an option exists to export ALL the Sequences in the bin one after another.

I suspect that you were exporting a single timeline and not Sequences from the bin.


Link to comment
Share on other sites

After reinstalling the latest nvidia driver, the same version I was already using, the h265 export problem is fixed. They only thing I did on my system was trying out v8.95 but when I ran it to ssues I undid that upgrade using windows system restore. Somehow something get messed up?

But my zoom fx is now also working again and some other overlay issues that I noticed after I reverted the system back v.p. 8.91 are gone. Zoom fx is still a bit slow i.m.h.o. Changing the size box should be smooth but it is still rather laggy even at low cpu usage. Anyway I can continue and will stay away from future updates for now :)

Link to comment
Share on other sites

  • borate changed the title to Everything above track 1 missing (H265 export)


Windows Vista Home Premium 32-bit SP2
Intel Core 2 Duo CPU E4500@ 2.2GHz, 2.0 GB RAM
NVIDEA GeForce GT 730.

That seems about the speed and lag I get when setting the zoom on a 4480 x 2520  16:9 jpg image.  At this image size it's a bit annoying but to be expected on my PC but then I mostly shoot 1080p :)

Using a smaller 1280 x 720 jpg the zoom adjustment is normal with no appreciable delay at all.

Using A 1920 x 1080 mp4 . again, no appreciable lag either with resizing or moving the zoom rectangle.

I don't know how large your jpg image is but the speed would seem to be dependant very much on image size.


Link to comment
Share on other sites

I'm sorry I should have mentioned the picture size. Its 2608x2592 (a 16:9 crop on 16mpx sensor)

But should size matter, since v.p. makes low resolution cache files for everything?

The media is on a old spinning type HD but the v.p. cache is on a ssd.

The access time to the old HD could be a bottle neck in my system. But this was only one picture

b.t.w. I use windows 10, have 8 gb ram and a Gforce gt740 and a 3.6Ghz i7 of the 6th generation (I believe 10 is the latest gen)


Link to comment
Share on other sites


Nat said:  Using H265 on a short mp4...

Not seeing that here, Nat.  The video below was made using H265.  Image is 2560x1920.

Size does seem to matter.  Zoomed a 5472x3678.  More lag, but still workable.  Expect better GPU utilization in the future.

For best continuity here, please begin a new thread with a descriptive subject when the topic changes, or tack onto a recent, pertinent thread.   More on ZOOM responsiveness here...


Link to comment
Share on other sites

  • borate changed the title to Everything above track 1 missing (H265 failure) /Zoom response

Working on another project and I just did a quick h264 export to do some quality control.

And this time everything above track 1 is missing again!

The h264 export I did an hour earlier was fine. And I did not make any change to my computer. I will restart and try again.

So this is starting to behave like a random problem. Sigh.


ideas, suggestions?

Update: I just exported the project again, again using the h264 codec, and everything seems to be there again.

I only did a computer restart and used 3000 instead of 2500 bitrate.

Issues like this waste so much time. Because this looks rather random, and it might happen again next time :(

So not solved, and it might continue, as this was the third time! But at-leasts now I know it has nothing to do with the h265 codec.

Link to comment
Share on other sites

Share your project and someone will analyse it.  Little can be done without seeing what you are seeing.  What version of VP is being used?

1.  With your project on the timeline, click on MENU at the top-left.  Click FILE|BACK UP PROJECT FILES TO FOLDER.  Choose a folder and SELECT FOLDER.
2.  Locate the saved, numbered folder.  No need to upload the export or VPJ files.  Upload it to a free server - Google Drive, MS OneDrive, etc.*
3.  Get a shared, public link.  If using Google Drive click GET SHAREABLE LINK. Change "restricted" to "anyone with the link can view"  Then click COPY LINK | DONE.
4.  Paste that link here, or click the folder at the top-right of this forum and privately message it to me.  It won't be shared.
*    Before uploading, right-click the folder, click PROPERTIES.  Look at the File Size to confirm that it's not too big for the free space on the server.

Link to comment
Share on other sites

It's only a 23min video but it is 11.6GB data and that would probably take a couple of days to upload.

But I just did another export after making a slight editing change

And now the pictures (plus zoom fx) in track 2 are missing. The text clips in the same track are there. Although I did not thoroughly check, because I saved my project and now I'm going to retry again with the same setting

Going crazy here :)

Link to comment
Share on other sites

Sorry that your upload is slow.  Without seeing the layout of the project it's only a guess that VP memory is being maxed out.  The 64-bit release should remedy that (no target).

Many suggestions have been offered in other threads, such as exporting as lower resolution, breaking up the project, consolidating tracks, pre-producing looping segments, and how best to apply global effects.

You can test various releases, as memory handling has changed from time to time.  This version has proven to be dependable.

Link to comment
Share on other sites

After a restart the export at exactly the same setting is fine. All elements are there. I had to check carefully because I can not trust v.p. to things right. Next time I will restart my computer before I export a project. To bad closing v.p. can take a long time, and then I also need to reopen the project. My computer restarts quicker then v.p. closes. And that is a bit ridiculous i.m.h.o. But at-least I did not suffer any new issues? (picture zoom is still rather slow)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...