Jump to content

Second clip in sequence has audio, but no video

Softball Dad

Recommended Posts


Project here:


I am trying to paste the last 2 seconds of a gopro chapter with the first 6 seconds of the second.  Both clips are native 4k.  Workflow is simply copy both clips to the sequence timeline and then trim.

Behavior is that when playing preview, video freezes at the clip-to-clip transition.  Linked audio continues to play.  When pausing and dragging the cursor through the sequence, it is black/blank for the second clip.  Second clip shows green "buffering complete" line.  

I verified the second clip was good by playing the second clip standalone in windows video player.

I cleared cache, closed and reopened in new project, etc.

Link to comment
Share on other sites

My guess is that 7GB of 4K files have maxed out VPs 32-bit resources.  The 64-bit version will better handle UHD (no target date).

Suggest first converting these files to 2K.  HD (1080) would be even better.  Resulting quality should be fine for content of this nature.

Link to comment
Share on other sites

Yeah...  Except that GoPro chapters are all 4 GB regardless of frame rate or resolution.  And I have had no (real) issues with 1080P @ 120 fps or stringing 8+ chapters together to create complete games that are 36 GB.  Further, there are no issues if I just output the full 2 chapters together - only when I clip the 16 minute segment down to 10 seconds does the problem exist.  

Also -- this issue occurs PRIOR to the function that I really want to do - which is to zoom into the area of interest during this video.  Which is why the source is a 4k so that I can zoom and then output the zoomed result at HD resolution.  So downgrading the resolution first is not an option.

But, lets assume that addressable memory is the issue.  Each of these 4k chapters are a little less than 9 minutes long.  Are you suggesting that VP does not have the capability of editing 18 minutes of UHD video?  Or just that it is flaky working with these inputs?

And if the workaround is to convert each 4k video to 2k or HD individually and then paste the resulting HD video together then this makes the software completely unusable.  Just converting one of the 4k chapters to HD consumes 10+ seconds for each second of video - on a Ryzen 7 with 8 cores and 64 GB of memory (not to mention an 8 GB GPU that VP cannot make use of)

I really do appreciate the help and know that you are a rock star, but this is not really a useable workaround.  The fact that the error in output occurs exactly at the point that the two clips transition indicates an issue that is more than a function of addressable memory.

Were you able to duplicate the behavior on your machine?

Link to comment
Share on other sites

Your description and an initial corrupt project load here led to a false conclusion.  Subsequent attempts were fine:  no preview black or freezing.

Developers are working on maximizing GPU usage, which peaked at 10% during PV play of your project.  Under OPTIONS | EDITING tab, toggle the "use hardware acceleration" item to see if that has an effect.

So unable to replicate your results, using version 8.22.  Try a clean install, after first uniinstalling via Control Panel | PROGRAMS AND FEATURES.

Link to comment
Share on other sites

For uninstall, I just reinstalled windows.  I assume that this would have rebuilt the registry hive.  Now it is a fresh current version of the OS and the only application installed is VP.

First attempt to do something with this fresh config was to try to paste together the 12 GoPro chapters from the last game.  1 hr 38 min of 4k video that I have applied a slight zoom and autolevel to all clips in sequence.  Trying to export to 1080p with smartmax 60 fps.

Still a dog.  It has been crunching for 12 hours and has 17 minutes done.  Currently only using 8% of my CPU and 3% of my GPU.  Only using 1.5 GB of the 64 GB I have installed.  Is there anyway to make that application use the power of the machine that is running it?  (and yes, HW acceleration is checked in options - and no, there is nothing else hanging on -  in task manager, it shows TOTAL utilization of all processes at 10% of CPU, 11% of memory and 5% of GPU)

I am about to throw away the 12 hours of processing (plus the 24 hours of previous issues - more than a dozen crashes of the application) and the time to reinstall windows and try it with the zoom but without the autolevels.  See if that works.  Don't want to downconvert to 1080 prior to zoom and lose the resolution.  Will report back if that helps.

And actually, my strong preference would be to maintain the 4k resolution that I recorded in so that I could watch the game on my 4k tv.  

Question:  There was a post 20 months ago where it was said that there was a 64bit version being developed (but no timeline).  There was even a comment from one of the dev team that they hoped to put it out before end of year (2019).  It is now 3/4 through 2020 and still no 64 bit version.  Not saying that this would fix my issues, but there have been repeated comments that 4k video is not tolerated very well with 32 bit application, yet NCH marketing material continues to claim 4k compatibility and obfuscate that the application is "compatible with 64 bit OS" rather than outright state it is a 32 bit application and (may) have limitations on the handling of 4k video.

When might a 64 bit version be released?

Link to comment
Share on other sites

So just rebooted and loaded clips into a new project.  Application is repeatedly hanging "(not responding)" even though plenty of CPU and memory headroom.  Even when "not responding" the blue "wait a while" circle spins and nothing is actionable in the UI.

Now all the clips are in sequence.  No effects applied at all. But no caching occurring and the yellow banner on the bottom "One or more sound clips on your sequence is still processing."

Now the UI is grayed out and nothing is working.  Taskmanager showing 0.1% CPU.  So it is hung hard.  Kill task and waste another hour.

Link to comment
Share on other sites

Another reload.  While clips are being copied to sequence, CPU is at 50% for the first 20-ish seconds followed by a ramp down.  3 minutes later and CPU utilization is less than 1%.  No buffering occurring - little green lines above clips in sequence not filling out.

Green checks, movie icon, and music note show on all clips in bin.

Clicking on play in sequence preview yields the yellow banner warning about audio clips again plus a "building preview please wait" in the preview window.  CPU utilization increases to 5%.

If the application was consuming 80% of the resources and going slow, then I would be a lot more accepting.  But this is ludicrous.

Here is another thing -- click on one of the clips in the bin.  change preview window to clip preview.  Press play.  Nothing -- "building preview, please wait."  But the clip is a fully formed MP4 file.  I can use ANY OTHER player (MPC, VLC, WinVideo, etc) and it will load and play in seconds.  Why can't VP play the same clip?  

And now, while typing this, what little tiny green cache indicators there were on top of the clips in the sequence are now gone.  No green to be found anywhere. 

Going to just do a simple 1080p export on the sequence and go to bed. See what happens overnight.

Link to comment
Share on other sites

What type of drive is in use:  SSD, Hybrid, conventional?  If the latter, you may be in for a long, if not terminal wait.  Be sure that drivers are up to date.

VP runs on 64-bit systems, certainly, but lengthy, multi-effect or UHD work is known to have 32-bit limitations resulting in errors, often in export, that mirror your description.  While working with some of those projects here on an eighth-gen I7,  near steady 100% CPU utilization has been seen.

The load of your raw clips showed  image.png at the outset, tapering off to a steady 22% or so.  During an export attempt it was about 32%.

Yet caching those nine-minute clips in both the bin and on the timeline took in excess of an hour before the UI was fully responsive.  Adding effects necessitated re-caching, though response remained good.  Various resolution exports failed.


Softball Dad wrote:  Are you suggesting that VP does not have the capability of editing 18 minutes of UHD video?

Empirically, from a practical standpoint, yes, though the sequence of your short, edited test project cached in minutes and played fine.

The most recent comment from a company rep stated that VP 64-bit is under testing.  This isn't a one-trick pony:  NCH has been around for more than a quarter-century.  Many of their programs are reportedly slated for conversion.  No easy chore.

In the interim, test pre-conversion at 2K (or 1080), possibly at 30fps. Your reticence notwithstanding, that, and divvying the project into discrete exports are alternatives.  No guarantees.  Downsampling your two files to 2K with another app took 10-15 minutes.

Sorry, but can't offer more.  Report your concerns at https://tinyurl.com/y3mhbljb    No rock stars here - mostly just users who don't work or speak for NCH.

Link to comment
Share on other sites

Thanks, Borate.  Nice to see confirmation that the timeframes I am experiencing is not necessarily a function of my setup. 

The "simple" down-conversion export of the 4k video with (no effects/transitions at all) I started 17 hours ago has just reached 83.5% complete.  And only using 8% of CPU while still working. 

Absolutely baffling why CPU consumption would be so low, but I can't find anything that would be artificially throttling.  I am using conventional HD but disk utilization is also low, toggling between 0 and 4%.  Wish there was some way to force higher utilization.

I used to record at 1080p and processing took about 1 second for each second of video.  Might need to go back to that or find another utility.

When (if) this finishes, I will go back to another project with 1080 source files and validate baseline performance. 

Link to comment
Share on other sites

I am willing to entertain the fact that it might be.  At first, I thought the CPU was throttling because of temperature, but I just ran Cinemark benchmark to validate CPU and it immediately burned up 100% CPU during render, so I know the CPU will run higher if called upon. 

The question then is what is bottlenecking the CPU?  With 64GB of memory, you would think that the application would load both ~4 GB clips into memory and not even bother with the hard drive.  But memory utilization does not reflect this.  But this is the issue with 32 bit, right? - that max addressable memory is 4 GB?  So then it would try to use the HD as virtual memory?  Will run some other benchmarks... 

Link to comment
Share on other sites

Shooting with the H264 compressor instead of H265, if possible, should result in better VP responsiveness and caching speed.  At export you may still need to drop down to 2K to get accurate results on lengthy projects.

That said, after converting one of your files to H264, placing it twice on the timeline and adding slight zoom and auto level effects, the 18-minute 4K export did succeed using AVI format and MPEG4 compressor at 15fps.  No compelling reason to use high frame rates IMO.

Lapsed time was loosely comparable to that obtained in a 64-bit editor.  At 60fps export took several hours.  (At 60fps mp4/MPEG4 worked with a single 8' file.)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...