Jump to content

Missing / garbled video export


Recommended Posts

Dear Forum,

I'm using the latest free (unregistered) version of VideoPad 8.67.

My problem does not seem uncommon: I'm making a video clip of short videos over a soundtrack, and export is either blank or garbled. Also non-deterministic (e.g. add a few effects and the exported scene starts appearing / stops appearing / stutters).

Have been searching and reading dozens of similar forum posts about video exporting going wrong. So here are all the things I've read and tried - none helped:

  • Export in a plethora of containers (MP4, AVI, MPG, MOV, MKV, OGV, WMV) and codecs (H.264, H.265, MPEG4, MPEG2, MPEG1, Huffyuv, VP8, VP9, Theora, WMV8, WMV9)
  • Export in a large amount of combinations of resolutions, bitrates, refresh rates, including crazy large and crazy small
  • Export lossy as well as lossless (each with its own strange / arbitrary result). In the current final state of the project, lossless refuses to be exported altogether.
  • Install the latest k-lite codec pack
  • Clear software cache
  • Uninstall and re-install
  • Restart machine :)

I've noticed more than one of the posters like me received a response such as: "Interesting. The project you uploaded exported well on my machine."

I suspect the truth is simple: This software, while *absolutely incredible* in terms of features and ease of use, and for which I am VERY grateful for being free for non-commercial use (it is a one-time project for my father's 70th birthday :)), simply does not support or is only partially tested for many machine combinations - OS's, CPUs, GPUs, memory sizes, HDDs / SSDs etc. And frankly.. quite buggy as well (I can try to help with some bug reports, but not in this post).

Some of my machine's specs, if they help:

  • Core i7-2600k
  • 8 GB RAM
  • Windows 7 Ultimate x64, SP1
  • NVIDIA GeForce GTX 560 Ti (Intel HD Graphics 3000 as secondary, used together with Virtu.. used to be a thing :), mentioning in case this could be an issue)
  • VideoPad as well as the project are on my HDD. My main drive is an SSD, but it's quite full. If you have reason to believe this could make a difference I can install VideoPad and/or the project there.

I understand the next step would be to save my project as a "Compact Project", upload it online and link it here, so here is the link:


Any help at all would be appreciated! And if for you, dear helper, the file simply exports as expected on MP4, H.264 (or H.265), 1080p, 30FPS, using default video and audio quality - could I trouble you to upload your export to the same folder? Just PM me and I will temporarily open the folder for upload (unfortunately leaving this folder unprotected is inviting all sorts of trouble).

I've placed in the folder an exported MP4 / H.264 version of the project as well, to demonstrate the issue. Most of the video portion is blank, in the middle starts again, then stutters and blanks out again.

Thanks so much in advance!

My father's birthday is two days from now ;D



Link to comment
Share on other sites

Multi-tracks and heavy effects have maxed out program memory.  That should be overcome when VP 64-bit is released - in due time.  Should you attempt another multi-track project before then, suggest that you minimize the # of tracks used and perhaps break the project into segments.  Export each segment, then later import and merge them for the final export.  Lower-res exports may succeed when higher will not.

Please leave your project intact on the server for a week or so should the developers want to check it out.

Link to comment
Share on other sites

Hi borate,

Thanks a lot for your quick reply, and a whole lot of thanks for all suggestions and for your exports!

I should have mentioned - I've had this export issue since there were only three or four tracks in the project with almost no effects, so I don't believe this is about maxing out system resources :). This is easy to test, and I can help with that: I've now removed all the tracks, and left only three tracks - one video and two audio. I've removed all effects and transitions. I've uploaded this trimmed down project to here, together with three exports:

  • Lossless - video gets "stuck" after first clip
  • Lossy mp4/h264 - no video exported
  • lossy avi/MPEG4 - only last clip showing (strange..)

(I did also more exports, some in low quality / low definition, no real difference in results.)

Here's the link:



I forgot to mention my current workaround! For whoever reading this - might be useful:

I've downloaded a screen capture software, after a quick search I've settled for another great piece of free software from NCH :D - Debut! Then I've played back the video using VideoPad, and captured it using Debut. That worked!! Unfortunately: Among its other quirks, VideoPad also does not show me the video in full screen 😢 so I've clicked the little "undock" button on the top right of the preview, and enlarged it as far as the view still appears, which is ~1240x700 (after that the screen just goes blank). So I have this export. It's not perfect but it's viewable.

Regarding your video export - thanks again! - but I'm afraid I can't use it, for two reasons:

1. You don't have the Hebrew font I've used for the text in the first shot haha. And for some reason also some of the text is missing (only the first line, the second and third are gone). Strange.

2. The export is in 15 FPS, which makes it quite harder to watch than my own workaround.

I also found it interesting that your export is 1920x960 (so.. almost 1080 :)), but inside it only 1700x950 contain actual video, and the rest is black. I've never had this, with any of my exports. Is this exported via VideoPad?


I will try installing this older version right now, hopefully it is more stable. I hope my project file will be understood by it. Will report my findings for the benefit of the community.



PS forgot to mention - no worries I can leave the project(s) online for a while for the developers to review.

Link to comment
Share on other sites

Video editing is resource intensive and a minimum of 16MB RAM is often recommended.  But the issue here is not your PC's limitations, but that of the VP 16-bit architecture.  That is likely the reason that expanding the preview window goes black.  It's out of usable memory.

Then there's a second issue which came to light only yesterday.  Versions 8.66 and 8.67 have a bug that will soon be fixed.  Use this version on the short clip and export will be fine at 1080.

At this juncture even the release linked earlier probably won't give 100% results at 720 HD, which may be the highest resolution obtainable.  Your best bet now may be to break the project into parts, export each, import and merge them for final export.  In that way VP is working with composited single clips - a much easier task that may allow higher res.

One way to accomplish this is to isolate a section.  Then click the + sign to the right of the Sequence 1 tab to create a new blank sequence.  Back in sequence 1, click <ctrl-A> to fully copy only the isolated section.  Switch to Sequence 2 and click the Sequences tab in the bin.  Drag Sequence 1 into Sequence 2.  Export Sequence 2.  Do the same with the other sections.

Will experiment a bit more here.  Check back for further developments, if any.

Link to comment
Share on other sites

Thank you very much.

I've installed version 7.53 as you suggested. Unfortunately, in this version, the export is limited to AVI, other formats give me a message that this feature is only available in the pro version.

Still, I've exported an AVI + MPEG4 in 720p. It *kinda* worked, only a couple of minor hiccups here in there in the exported file. If I get nothing better, I might use that export, so already thank you for your help. First export in 1080p crashed (bug report sent, as requested by VideoPad), I'm now attempting a second 1080p export. Fingers crossed.

I will also try version 8.63, as you suggest. Splitting the files will probably work out for me, I'm a bit worried how to glue them together without losing quality (and I guess preferably without re-encoding). I seem to remember my previous attempt at gluing two videos (with same specs) was also not very successful. Could you suggest the best way to achieve that?


Edit: The second export in 1080p finished without crashing :D:D The same minor couple of glitches as the 720p export - so it might be a version incompatibility - I will try to see if the hiccups appear also in the project and fix them, then export again. Or alternatively install 8.63, and see if this lets me export properly as well.

Both successful exports (720p and 1080p) were done in 7.53 in one pass, without splitting the project. This could save me and other readers a huge amount of work in terms of splitting and merging :)

If I get any new findings worth sharing - I'll post back.

Thanks again!


Edit 2: The hiccups were related to how this version keeps track of audio gain timestamps (I've noticed there's a bug in the newer version where trying to click and drag on the waveform to change gain levels tends to think you are clicking somewhere else - so what I see kind of makes sense). So these were no export hiccups, but software version mismatches. I will try to export again. If it works then I have a perfect export :D don't have free choice of container / codec but this is definitely good enough for a free software!

Link to comment
Share on other sites

Hi borate, community,

I've fixed all the audio gain mismatches, and tried to export again.

I'd like to report that after quite a few long attempts (~20 or so) with actual export hiccups that were unrelated to version mismatch (missing frames / glitches / full blown VideoPad crashes) - I've managed to export via VideoPad 7.53 a full 1080p@30FPS AVI/H.264 (audio in MP3) rendering of the entire clip as a single sequence, with both video and audio, and (almost) all effects intact. Other than the gain corrections, I had to make one more tiny change: For some reason rendering the text proved hardest for this version, so I removed some overlapping transitions there, and after a few more attempts (every time clearing cache and restarting the software) eventually it worked without any errors! :D

Unfortunately, in that version - less is free than in 8.67, so some effects were removed, such as audio compression, and as mentioned the export formats are limited as well. But AVI/H.264 is perfectly acceptable, and audio compression.. yeah well too bad but I can live without it :).

Regarding this:

On 8/9/2020 at 9:42 PM, borate said:

For a short time, view and download this.

Thanks a LOT for exporting it for me again. It was really nice to see one more time how much you are willing to help.


Since my export succeeded, I haven't tried uninstalling 7.53 and installing 8.63. I don't know if I will do that now, but if I ever get to do that I will report back here. I do want to note however that 7.53, other than missing more features on the community version, is also noticeably more resource hungry and slower than 8.67. Playback via the software was incredibly jumpy to an unworkable level, even with the preview window set to its smallest possible size. Auto-rendering of a single clip after changing an effect or a transition takes much longer. So I guess.. if the developers manage to fix whatever it is that stops 8.67 from rendering properly - your software is definitely on the right track both qua performance, and qua allowed features in the community version :).


If you'd like to take a look at the final rendered version, you can download the actual export here:


Or view it on YouTube: (slightly lower quality but not very noticeable)



Other than that, if you have any questions for me that may help you / the developers / other users better understand how to solve or fix things - please ask and I will do my best to help.



PS: My father absolutely loved and was moved by the video. So if any VideoPad developers or product owners are reading this - know that you've helped make one awesome 70 year old guy extremely happy, and one geeky 39 year old guy as well. And borate, you too of course :).

Link to comment
Share on other sites

Glad that your dad enjoyed it.  Considerable improvements (not without glitches) have been made since the 7.x versions.  As you discovered, full backwards compatibility isn't possible.  It's best to edit and export with the same, or nearly the same, version.

This 16-bit program has memory limitations that should be resolved in a 64-bit version.  Thus, creating a multi-track/effect project, especially if files are UHD, is best handled by breaking a project into segments, to be later merged and exported, as suggested earlier.

License the program to gain full functionality.  https://www.nchsoftware.com/videopad/faq.html


Link to comment
Share on other sites

  • borate changed the title to Missing / garbled video export

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...