Jump to content

Emailing invoices not working


TWig
 Share

Recommended Posts

EXPRESS ACCOUNTS configuration completed with SMTP info. All verified.

Option to use MAPI (in my case OUTLOOK) is switched off as it didn't work.

Sending invoice by email (clicking RECORD AND EMAIL) returns a 553 error suggesting invalid recipient (which it isn't) or missing SMTP server login details (which are not missing).

Any help gratefully received.

Link to comment
Share on other sites


Please try the following steps:

1. Open your email settings in Express Invoice by clicking the Options button on the toolbar
2. Select Other from the list on the left
3. Click the Email Settings... button
4. Select the radio button for Use SMTP to send email directly to the mail server
5. Enter the server address in the SMTP mail host text box (this varies depending on your email client)

Since you are using the Outlook, what would be the email domain that you are using: 

-Gmail: smtp.gmail.com
-Yahoo: smtp.mail.yahoo.com or smtp.mail.yahoo.co.uk (if email address ends in yahoo.co.uk)
-Hotmail/MSN/Outlook.com: smtp.live.com
-AOL: smtp.aol.com
-Comcast: smtp.comcast.net
-Other: Contact your mail provider for your SMTP server address

6. Check the box labeled Server requires authentication
7. Enter your User Name, (e.g., youraddress@gmail.com), and your Password in the appropriate text boxes
8. Check the box labeled Use secure connection (SSL/TLS) if available
9. Enter your email address into the Default reply email textbox
10. Click OK to save your changes.

If you are using a Gmail account, you will need to do additional work:

-Log into your Gmail account, and go to this page.
-Make sure the option "Allow less secure apps" is set to ON.
-Confirm all settings within Express Invoice, and then test emailing an invoice.

Link to comment
Share on other sites

Try using the option at the bottom " Send directly to the other side (work as own smtp server) this works well for me. You will also need to put your email address in the box "Default reply email"

Link to comment
Share on other sites

I have one more idea for you.

I know I use thunderbird for my email program and I know also the express accounts and express invoice will send the invoices though it with no problem.

I am thinking if you installed Thunderbird and setup your outlook account in it ( I know outlook mail will work in it as I have setup someone with thunderbird) and then tried to send an email/invoice which maybe one way around it.

Thunderbird is free

 

Link to comment
Share on other sites

  • 6 months later...

CHECK ALL THE BOX 

-Gmail: smtp.gmail.com
-Yahoo: smtp.mail.yahoo.com or smtp.mail.yahoo.co.uk (if email address ends in yahoo.co.uk)
-Hotmail/MSN/Outlook.com: smtp.live.com
-AOL: smtp.aol.com
-Comcast: smtp.comcast.net
-Other: Contact your mail provider for your SMTP server address

Enter your User Name, (e.g., youraddress@gmail.com), and your Password in the appropriate text boxes
Enter your email address into the Default reply email textbox

Click OK to save your changes.

"EMAIL AUTHENTICATION USERNAME OR PASSWORD NOT ACCEPTED"

Then UN-CHECK the box label Use SMTP to send email directly bla...bla...bla...

Click OK again......

 Please try............................

Check registry edit (Regedit)

[HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\NCH Software\ExpressAccounts\Email]
"DefaultsSet"="1"
"SendDirect"="1"
"UseMAPI"="1"
"UseSMTPHost"="0"
"MailSMTPHost"="smtp.gmail.com"
"SMTPUserName"="xxxx@gmail.com"
"_SMTPPassword"=hex:XXXXXXXXXX (hidden my password :))
"ReplyToEmail"="xxxx@gmail.com"
"UseSSL"="1"
"SetViewed"="1"

Link to comment
Share on other sites

19 hours ago, S n C said:

CHECK ALL THE BOX 

-Gmail: smtp.gmail.com
-Yahoo: smtp.mail.yahoo.com or smtp.mail.yahoo.co.uk (if email address ends in yahoo.co.uk)
-Hotmail/MSN/Outlook.com: smtp.live.com
-AOL: smtp.aol.com
-Comcast: smtp.comcast.net
-Other: Contact your mail provider for your SMTP server address

Enter your User Name, (e.g., youraddress@gmail.com), and your Password in the appropriate text boxes
Enter your email address into the Default reply email textbox

Click OK to save your changes.

"EMAIL AUTHENTICATION USERNAME OR PASSWORD NOT ACCEPTED"

Then UN-CHECK the box label Use SMTP to send email directly bla...bla...bla...

Click OK again......

 Please try............................

Check registry edit (Regedit)

[HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\NCH Software\ExpressAccounts\Email]
"DefaultsSet"="1"
"SendDirect"="1"
"UseMAPI"="1"
"UseSMTPHost"="0"
"MailSMTPHost"="smtp.gmail.com"
"SMTPUserName"="xxxx@gmail.com"
"_SMTPPassword"=hex:XXXXXXXXXX (hidden my password :))
"ReplyToEmail"="xxxx@gmail.com"
"UseSSL"="1"
"SetViewed"="1"

Something worked. Please info if successful

Link to comment
Share on other sites

I can't send email anymore, but I changed the previous IMAP configuration settings to SMTP configuration. And it runs normally again ... I think this is a coincidence ... Because maybe I change the 2-factor verification on my Gmail to be inactive and allow less secure applications in the google account settings ( https://myaccount.google.com/lesssecureapps )

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...