Jump to content

VideoPad not running well on new PC


Velys
 Share

Recommended Posts

So for quite some time I've been using VideoPad, I love it for its easy to use features to create a video compared to another program which I don't use much. I'm still using an older version of VideoPad which has worked well for me (4.00). On my old laptop, it ran fairly well with only getting slow downs and "building preview" when projects got pretty big. When I my laptop fried this year I decided to get a new PC, something more powerful. 

When I reinstalled my 4.00 copy of VideoPad, I opened up a project I had been working on for a few months and I noticed that it ran slow. I was getting "building preview" and freezing issues far more often than I did on the laptop and I noticed it was causing the CPU temps to rise quite high. I tried Adobe Premiere and it ran great, better than before without issue so I figured its likely the program itself. Again I'm still using 4.00 but I've never had a problem before.

PC specs:

Win 10 x64

Ryzen 5 3600

Geforeforce GTX 1660 super

16GB ram

X570 a-pro motherboard

Link to comment
Share on other sites

Can't say why it's running poorly, and it is wise to edit and export a project from the same, or a close version.

But substantial improvements and enhancements have been made since 4.x.  Upload a trial version of 8.42 here.   Retain your old install file and registration info.

Under OPTIONS | EDITING tab,  toggle "use hardware accelerated video effects..." and see if that makes a difference.

Also, before loading a new or long-unsed project, click OPTIONS | DISK tab and Clear Unused Cache Files.

Then load the project and let it fully cache (solid green line above most thumbnails) before beginning to edit.

Also, if you share your sluggish project, someone will be glad to test it on their system.  This is easy, quick and can be private.  Don't upload the export, just the PORTABLE project folder.

Here's how...  http://nch.invisionzone.com/topic/23659-tips-for-getting-help-on-this-forum/

If it contains sensitive material link it in a personal message (PM).  Click the envelope above.  It won't be passed on or retained.  Use FILE|SAVE PORTABLE PROJECT AS, not simply SAVE PROJECT, and don't forget to share it.

Link to comment
Share on other sites

So I've tried just starting a new fresh project and even then, clips and previews are still somewhat slow and causes my cpu to heat up quite substantially. I tried the newer version you posted and it gives me the same result. I'm honestly confused as to why this is happening and only with VideoPad. It's likely something to do with the pc but I can't figure it out.

Link to comment
Share on other sites

I also got a new laptop with a more powerful cpu and graphics card and the video preview quaility is just terrible. I have the latest update. The audio is good, but the video lags and is out of sync. Also, the link Borate posted doesn't work.

Link to comment
Share on other sites

Hardware certainly can make a difference as video editing is resource intensive.  Ultra high-def files can be a challenge.

You didn't give your new PC's specs or mention what format and resolution make up the bulk of the clips.  Share your project and someone will give it a look.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...