Jump to content

Green screen showing through transition


phil_the
 Share

Recommended Posts

 

v8.31

I am using the Green screen effect to remove the background from a video clip. This works well, but when I add a crossfade transition to the next clip, the background is briefly visible during the transition. Is this a bug? Any ideas how to correct this?

Link to comment
Share on other sites

  • 3 weeks later...

Sorry for not getting back on this. I have been busy with other projects, so haven't had chance to look at this again. I will try updating to latest version once I've finished a couple of projects I'm working on at the moment then report back.
Thanks for your help.

Phil

Link to comment
Share on other sites

  • 4 weeks later...

Hello again,

Sorry for not getting back on this sooner. I can't find the project I was seeing this in now but it is pretty simple to reproduce the problem.

Example

In the example above I have two images one after the other on the timeline and another image overlaid over the first one in a separate track. The overlaid image is just a circle that will act as a hole that you can see the other image through. This is done by adding a green screen effect on the overlaid image. 

I then added a crossfade transition on the main track. I increased the length of the transition to 5 seconds so that you can see the problem better. 

What happens, is that during the first part of the transition you can see the part of the image through the hole slowly changing to the second image, as expected. At the mid-point though, because the overlay track has finished at this point, you suddenly see all of the first image appear (albeit partially faded).

Now that I have looked at this more closely I can see how to fix it. What I need to do is to extend the overlay track to the end of the transition, and add a fade on this for 2.5 seconds (half the crossfade length on the main track).

Phil.

Link to comment
Share on other sites

Hi

Your solution is correct but it is not a bug.:)

By default all of your clips, being images will have the same duration (set in Options) and therefore the  overlay image (the hole) will automatically end at the join as one would expect - mid way through any transition you may have added between the main track clips.

At this point the overlay image (the hole) will suddenly disappear  leaving the transition to complete. As you correctly surmise you have to extend the overlay to the end of the transition. This is easy to do by simply dragging the right hand end out so it finishes where the blue transition bar stops. (It will automatically lightly grab that point when you do this) The complete transition will now take place within the circle and as you have found out this will then suddenly disappear  so will need to be faded out.  This is easily done without resorting to trial and error or calculating durations.

Select the overlay clip and then in Clip Preview slide the previrew red cursor bar along until  the timeline cursor is at the join between the clips. (They move together) Add a transparency effect and set it at 100% Opacity without moving the red line cursor. Create a keyframe and then drag the end of the Opacity line vertically down to 0% Opacity. Your overlay track will now fade out with the transition. (This is quicker than trying to guess it or work figures out.)

Nat

Link to comment
Share on other sites

Thanks for the response Nat.

I'm not going to argue that it's not a bug. It is only expected though if you know what to expect 🙂 

I would suggest that it is not really desired behaviour, but I do understand why it works like this. It was definitely unexpected when I first saw it, and the solution isn't obvious until you zoom right in, and watch what is happening by slowly moving the slider or moving frame by frame. 

I just used the images in the example for convenience. When I first encountered it, it was with video clips where I was using the green screen to remove the background. It all worked fine, until the last thing I did was add an additional clip at the end with a cross-fade, and didn't notice the problem until I'd done the export, so it was rather annoying at the time.

I think adding a fade at half the duration of the cross-fade is slightly simpler than your solution. Dividing by two isn't exactly a difficult calculation 🙂 but both methods would work, and your solution would be better if using separate overlapping tracks rather than a simple cross-fade.

Anyway, hopefully this thread might help someone else in the future if they encounter the same issue.

Cheers
Phil

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...