Jump to content

Waiting for stream to start.


Recommended Posts

I am definitely setup, and ready to listen. The power is on, I created a preset, clicked on Options, selected "Speaker & Headphones".  "Waiting for stream to start" still displays. 

What am I missing?  I am using Spotify. 

 

Joel 

 

 

Link to post
Share on other sites

In attempt to fix this issue, please try the steps below:

Uninstall DeskFX, then delete 3 folders named "DeskFX" and 1 named "Components" from these locations:
**C:\Users\<username>\AppData\Roaming\NCH Software\DeskFX\
**C:\Program Files (x86)\NCH Software\DeskFX\
**C:\Program Files (x86)\NCH Software\Components
**C:\ProgramData\NCH Software\DeskFX\
**If you can't find any of the folders, just continue. 

After that, restart your computer and reinstall the program using this link: https://www.nchsoftware.com/deskfx/deskfxsetup.exe

Once done, restart your system one more time and try again.

Link to post
Share on other sites
  • 3 weeks later...

Here's how I fixed mine.

In DeskFX top menu, I click on File. Then in File menu, I clicked on Options. I was then presented an Options window to select which audio output devices will use DeskFX.  The options listed my 2 output devices: Intel Display Audio and Realtek Audio.  

You can select multiple by checking on the check box. I selected HDMI. My default Audio output at this time is the HDMI. After selecting, I closed the Options window and went back to the main window.  I then restarted my computer.

After restarting, I went back to DeskFX and clicked on the power icon to turn on the effect. It still didn't work. I went back to the Options window and was surprised the HDMI box was unchecked.  I checked it again and went back to main window but still didn't work. Went back to the Options window and HDMI box was again unchecked. I began to suspect that you cannot select your current default Audio output after installation. 

I opened Windows Settings and opened Sound. I then selected RealTek as my Sound output device. Then I went back to DeskFX Options window and selected HDMI. I closed the Options window and then reopened it to check if the HDMI was still checked. It's still checked. I went back to Windows Sound settings to select HDMI as my Sound output device then I went back to DeskFX and it worked.

Link to post
Share on other sites
  • 2 weeks later...

I have downloaded and installed DeskFX twice.  My PC runs Win7 Professional.  I have selected all 3 device options but none of them have audio modified by DeskFX.  There is no audio indications on the DeskFX level bar, and it doesn't matter whether I am playing a local audio file or something via browser.   The suggestions above did not help. 

I will leave it installed for a while, pending any help from NCH or other users as there is nothing else I can do.  Thanks to anyone out there who can help ...

Link to post
Share on other sites

Actually, I have decided to uninstall it since the forum seems pretty sparse here and it looks like it might be a long time waiting.  Unfortunately DeskFX would not uninstall politely so it seemed best to use System Restore to clear the registry as much as possible to return my PC to previous condition.  No further help is needed.

Link to post
Share on other sites
  • 3 months later...

Hi folks, I had the same problem.  I tried Luckyboys method and checked the File > Options and ticked the inputs I use.  It worked.

I think the options somehow deselect when your changing inputs from headphones and speakers etc.  But all systems are unique

and this may not work on all systems.

Regards,

Rich

Link to post
Share on other sites
  • 1 month later...

Hello. May I join in. I have similar problem with DeskFx Audio Effects. Switched on power. Selected my device. It kept showing Waiting for streaming. I was lost figuring out how to connect it to YouTube music. Other apps would automatically display the current audio channels. Tried to uninstall but it remained installed. Hopefully I might get solution from tech savvy guys out there. I'm somehow relieved knowing I am not the only one with this issue. Thank you for sharing. 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...