Jump to content

Uninstall bug plus driver hogging cpu when prog. not running


Recommended Posts

Hi, I wanted to report this because this is a significant bug and it has been plaguing me for about 3 weeks and seems to have been causing stuttering in my video game, although I'm not 100% certain on that just yet.  I'll need more time for testing.


I installed RecordPad and tested it out a bit.  I then stopped using it for the next 3 weeks but left it installed

Sometime after the install, I began to notice that the "system" process in task manager was using 13-25% cpu for an unknown reason.  This usage seemed to be constant anytime I had a video game or video playing.  I did not make the connection to this software right away and began spending copious amounts of time trying to troubleshoot this new issue.

A few days ago, I downloaded 'process viewer' for Windows.  Exploring the thread viewer for the 'system' process showed the top listing using the most cpu to be referencing the following driver:  stdriver64.sys

I looked this driver up on the web and saw that it was a SoundTap driver, which then helped me make the connection to RecordPad.  This surprised me because I I had not used this software since the first day so the driver should not have been running.

I decided to try the quick fix and uninstalled the software.  The first attempt failed, as I discovered, because for some reason the entire folder was 'locked'.  A 2nd attempt only removed the driver in the NCH folder (and the whole folder), but not in the Win folder.  When I tried manually deleting the driver, it gave an error saying the driver was in use.  A 3rd attempt worked, but after rebooting, even though a pc search for the driver showed that it was gone in both locations, the system process was still high and the thread viewer still showed the reference!  So something very strange was going on there.

After getting some advice, I decided to try installing and uninstalling the SoundTap prog. to see if its' uninstaller might do a better job and both progs. seemed to be using the same driver.  After cycling through that and rebooting, the problem was fixed.  All software and drivers were removed, and the cpu usage stopped.


This has caused me quite a bit of headaches and was very frustrating trying to track this down.  Please let your techs know about this.  It seems to me that there is no failsafe uninstall checker built in after the primary uninstaller is invoked.  IMO, a separate process should come afterwards which verifies the main uninstaller's work.  Also, the driver should not be running and using cpu when the program is not open.  The driver seems to have been stuck ON.


(edit:  I cannot figure out why some of the text is semi bolded.  I tried to bold and unbold to fix it, but that bold is actually much darker and thicker than what is here.  Maybe a forum bug?)

Edited by spaceboy
font issue
Link to comment
Share on other sites

  • 2 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...