Jump to content

Express Talk Crashes over Wireless


Recommended Posts

I've been using Express Talk on my desktop running XP PRO for sometime and love it! My SIP provider is iiNet and it seems to work well.

 

I recently bourght an Acer Notebook and installed it, infact I think it was the first thing I installed. It worked fine untill I restarted the computer, then it started to give me some problems.

 

The program runs fine and connects to the SIP server without any problem. However, when I make a call and the other party answer, my computer blue screens with the folowing:

 

"Hardware Malfunction

NMI: Parity check / Memory parity error

The System has halted"

 

The same applies to incoming calls. As soon as I answer the call, the computer blue screens. I re installed the operating system and tried it again. It worked fine untill I restarted the computer for the first time. Then the same thing occured.

 

I've been able to narrow it down to the wireless. When the Notebook is plugged into the lan it works fine again, when I revert back to wireless. As soon as I answer a call or the party I'm calling answers, it blue screens.

 

I tried using other SIP software such as X-PRO and BOL, both work fine, but I much prefer Express Talk.. Always the way though, can't have the one you want!!

 

I can't work it out... Any ideas?

Link to post
Share on other sites

Hi,

 

If you search google there are a lot of answers to this question regarding Faulty Ram as the cause of the crashing.

Find a Ram testing program and give it a run to confirm their findings.

:)

Link to post
Share on other sites
  • 4 weeks later...

I also purchased an Acer notebook, model 2423, in Feb 2006,

and have suffered NMI Parity Error on and off for months.

 

Of course I downloaded all the diagnostic software I could find that

looked useful. Microsoft has a memory diagnostic, an ISO image

you can use to cut a bootable cd-rom. Then I also downloaded

and used a couple open source solutions.

 

There was no memory problem detected, not after days of testing.

 

The machine has been sent back to Acer twice. The first time

they replaced the disk and memory. Of course it did not fix anything.

 

The next time they just replaced the disk. They don't seem to pay

much attention to the detailed problem reports.

 

This time I am going to have a long phone conversation with them.

 

I am no hardware idiot. I have build devices from chips

and written microcode and hardware diagnostics during the era

of mini computers.

 

So I understand how difficult it is for the operating system to figure out

what is actually wrong, sometimes. The fact that you point to the

network board is interesting. I suspected as much myself, because the thing

does appear to crash more often when it is downloading a large file.

 

It definitely is possible for NMI Parity Error to be caused by other stuff

on the I/O bus. Microsoft does have some references to that for some

kinds of hardware. It is not always memory at fault.

 

Oh, I can also get the machine to fail more often by cooling it to 40 degrees,

and then warming it to 80 degrees, which is well within the claimed operating

temp limits. I never use a direct connection to ethernet, always use

wireless.

Link to post
Share on other sites
  • 1 month later...
this is a very strange problem indeed, I would have said its a memory problem myself, but you appear to have eliminated the memory already.

 

 

I also have just purchased an Acer Laptop model 2424 with 1GB ram, (2 weeks ago) location UK, and get exactly the same problems, I also have done the memory tests and no faults have been found.

 

My initial version was 1.4 so put on the latest version, both give the same problem as per original poster. No other programs I run which use the wireless have caused this problem, Skype, stanaphone and any programs that use the sound card.

 

I have not tried the cable only with the wireless disabled, and will try with a usb wirless dongle tomorrow.

 

Will advise further

 

update - tested with wireless disabled and on cable - no problem at all - other wireless adapter to be tried tomorrow

 

update 2 30th August UK time 08:43

 

I have tried with 3 other wireless cards, a cnet usb dongle and d-link usb dongle (same chipsets) no problems, also tried with an old Orininoco Silver PCMCIA card again with no problems.

 

I will try and find a card/dongle with Atheros chipset to see if that works or not.

 

UPDATE 30th AUG

 

Could not find a card with Atheros chipset, so went hunting for drivers.

 

 

Found Atheros generic driver which covers many cards. version 4.2.2.7

 

changed the driver on the laptop, and so far NO problems with Express Talk and the NMI/hardware error.

 

Driver only can be downloaded from here

 

http://www.laptopvideo2go.com/drivers/wlan..._driveronly.zip

 

 

Discussion here

http://www.laptopvideo2go.com/forum/index....amp;#entry37915

Link to post
Share on other sites

thats quite a fascinating find there, good research.

 

Just to clarify some things, Express Talk uses the UDP protocol for all its call signaling and the RTP protocol for the audio data. These two protocols are designed to work independently of whether the network connection used is wireless or wired, and there are no specific techniques (that we know of) for making one type of connection work better than another. The fact that you were only getting Express Talk crashing and not other softphones appears to me as being just pure "bad luck".

 

Glad to hear the driver upgrade fixed it though, that confirms what I just said.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...