Jump to content

Choppy slowmotion when video effects are applied

Recommended Posts

VideoPad v7.01

If I take a clip (.mp4, 1280x720, 240fps), set the speed to 30% and export (.mp4, 1280x720, Variable Frame Rate (Max 48fps)), then the result is fine, i.e. as you would expected.

If I apply the video effect "Auto Levels" and do everything else exactly as above, then the result is choppy. It looks rather like a video with 10 fps or less.
The same happens with the video effect "Temperature" and probably some other effects.

Any ideas how this can be resolved?

Link to post
Share on other sites
  • 2 weeks later...

Using v.7.11, exported a 1280x720 29.97fps clip, slowed to 30% with 'auto level' applied.  It looked as fluid as the export without the AL effect.

Also exported a 24fps (assuming that your "240" is a typo) at variable max 48fps.  Applied both temperature and auto level.  Same result - looked about as expected.

Link to post
Share on other sites


Checked this out in VP 7.11 with a 1280 x 720 mp4  15 second clip outputted as mp4 of same resolution at 48fps final duration 50 seconds . Perfectly smooth  slow motion.

  • Applying auto levels with speed change made no difference to the slow -mo..It was just as smooth.
  • Applying temperature (variable with keyframes) with speed change made no difference to the slow -mo..It was just as smooth.

Trimmed the clip to 3 seconds and applied the same effects with 30% speed setting. The slo-mo in the resulting 10 second clip was excellent with no obvious pauses.

Can't think of a reason why your export is choppy.


Link to post
Share on other sites
  • 3 months later...

Thanks guys for your replies and sorry for getting back so late. I didn't realise until now, that my post had actually gone through. I'm glad that it did, though, because I'm still experiencing the same issue.

However, I have gained additional insights:

1. The issue is unrelated to any effects as I originally assumed. Just the first time it showed up was when I added effects to an existing slowmo project that until then had exported fine. This means, I'm now always getting choppy slowmo exports even without additional effects applied

2. Original footage was shot at 240 fps. Speed is changed to 12.5%.

3. If I export at 60fps, the result is only half as choppy as 30fps-exports. To me it looks like VP, upon rending/exporting, first sets the frame rate to the desired value and THEN applies the speed change. The correct way would be the other way around. To elaborate: 240fps, speed change: 12.5%, desired result: Video at 1/8 of original speed which should look smooth in a 30fps-export. What I rather think is happening (and is confirmed by playback at reduced speed): 240 fps is reduced to 30fps (60fps, respectively), by eliminating 7 out of 8 frames (3 out of 4). Then speed change is applied resulting in 30/8 fps (60/8fps). Then the export tuns it into 30 (60) fps by adding 7 still frames making the result look choppy because only about 4 (8) frames per second represent changes from the previous frame. Replaying the exports in VLC at reduced speed confirms these assumptions.

4. I uninstalled video pad, deleted related files in the folders C:\ProgramData\NCH Software and C:\Users\(My computer profile)\AppData\Roaming\NCH Software\VideoPad, restarted my computer and then installed v7.11. Same issue.

5. As mentioned under 1.: Things used to work fine. I don't know what caused the choppy slowmotion in May. There might have been a software and/or windows update or windows configuration. Definitely no hardware changes. 

I'm happy to share whatever files may help to pinpoint the rootcause of this problem.

Thanks in advance,



Link to post
Share on other sites

I uploaded a demo project and its export here


Usually, I don't pay much attention to the quality of the preview. Just now I noticed that, before the end of the caching-progress-bar, the preview is as choppy as the final export. Beyond the end of the progress bar, the preview showed smooth slow motion.

Anyway, I hope the uploaded project allows you experts to get an idea of what might be the problem here. I didn't specify my export settings because the problem occurs for any settings.

Link to post
Share on other sites


Your clip downloaded OK.....Three files..

  1. 6 Peer Hockey oben~2.mp4
  2. Export.mp4
  3. SlowMo Test.vpj

Only 6 Peer Hockey oben~2.mp4 loaded to VP (7.3) with the vpj file

In the bin the duration of the basic clip was 1.027 seconds. On the track it was slowed to 12.5% with a final duration of 8.215 seconds

The original clip in the bin contained 32 frames.  (i.e. 30fps approx)  Slowing this down by 8X (12.5%) means 8 frames would need to be duplicated for each frame of the clip. This creates a jerky playback when the speed is reduced to this extent. A speed reduction of 50%  (2X frame duplication) would appear much smoother. A 25% reduction is about as slow as you can make it without obvious jerkiness.

The way around this problem is to shoot the original clip in Slo-Mo in the camera giving a longer clip duration for the short action time.  (You may have done this...but the clip you uploaded is full speed at 30fps)

Your mp4 export reflects this and is exactly what is seen in the VP preview of your fully  slowed down clip. Try setting the speed change to around 25% and see the difference. (OK it's not as slow but it's less jerky)




Link to post
Share on other sites

Sorry Borate

I can't upload or view this this as I get a code error and your post shows it as Unavailable. :(  Might be my old PC and old browser:(

However, I re-exported the downloaded project at 60fps  and the result is very smooth.  So...what is actually happening during the export?

The original one second clip with 30 frames is slowed down on the timeline by being given extra frames. In this case 7-8 copies of each frame are added. ( The copies after each original frame can be seen when the timeline is checked frame by frame)  This makes it slow down but jerky when previewed at 30fps)

If the export is going to have 60fps,  and is going to retain its timeline duration are more frames being generated to keep the clip the same duration and if so why is it not just as jerky or even jerkier? (Or am I missing something?)


Link to post
Share on other sites

Hi Nationalsolo and Borate,

please be aware: The orignal file ("6 Peer Hockey oben~2.mp4" included in the zip file) has 240fps. This was the setting of the camera and this value is stated in the properties displayed by windows. And if I replay this file in the VLC media player at 0.12 speed, it looks super smooth. Even at 0.06, there is only very slight jerkyness, which is in agreement with about 15 updates per second. And this is what I want my VP export to look like.

If you change the preview settings in VP to 240fps, you will see that the original clip in the bin contains about 240 unique frames, i.e. no copies, one every 4 milliseconds.

When we now change the clip speed to 12.5% VP ads 7 copies of every frame. This indeed results in a slow motion and an 8 times longer clip length while maintaining the preview settings of 240fps. Hence, so far everything is fine.

Now, if I export, I get the same result as described in my post from yesterday: Jerky with about 4 updates per seconds for 30 fps and half as jerky with about 8 updates per second for 60 fps (this is what Borate did).

In conclusion: Even though the the original clip in the bin has 240 fps, which should result in a smooth 12.5%-slowmo (with 30 updates per second), VP exports a jerky result by first reducing the frame rate to the export value and THEN applying the speed change. Performing it the other way around would result in the desired outcome.

Is there any way to change the order of these rendering steps? As I stated earlier, I used to be able to export smooth 12.5%-slowmo (with 30 updates per second).

Link to post
Share on other sites


@Borate  Your link eventually played OK (like my export here with the same settings.) But this is based on a 30fps short original clip.....

 Mediainfo  shows that the  original clip is indeed 240 fps./.. In VP it's 1.33 seconds long with 30 odd frames.????



"....... If you change the preview settings in VP to 240fps, you will see that the original clip in the bin contains about 240 unique frames, i.e. no copies, one every 4 milliseconds. ....."

Where are those controls please  I don't remember ever seeing them (VP 7.30) .....?   Still only get a frame to frame of 0.033 sec.


Link to post
Share on other sites

@Nationalsolo: right click on preview window --> change preview settings...

@borate: Ok, the 60fps-export (your link above) is somewhat smooth, i.e. 8 unique fps.
Let me show you, though, what I'm actually expecting, by this little video:


See how much smoother the slowmo is as 12% speed (30 unique fps)  and even at 6% speed (still 15 unique fps)? I used to be able to create these type of smooth slomos using VideoPad until about May this year. So it must be possible. But how?

Can you guys tell if this is a bug in the current versions of VP? If so, I'd expect many complains from other users. Are older versions available anywhere?

Or could it be an issue of my operating system or other installed programs?

Link to post
Share on other sites

Two thoughts...

Under OPTIONS|EDITING, toggle the Use Hardware Accelerated Video Effects box and see if that has an impact on your result.

Here is the 7.31 beta version, which is subject to change on a regular basis and may have its share of bugs.  It's under development.

Link to post
Share on other sites

v7.31 beta w hardware acceleration: smooth slowmo failed

v7.31 beta w/o hardware acceleration: smooth slowmo failed

v7.00 beta w hardware acceleration: smooth slowmo successful :)

v7.00 beta w/o hardware acceleration: smooth slowmo successful :)

support of my projects done in v7.11 by v7.00: failed ☹️

Any thoughts?

Link to post
Share on other sites

Hi LeFouu

".... In v7.30, the frame rate of the preview cannot be changed anymore. Only the replay speed can be altered, while the number of frames remains unchanged....."

Thanks. I realised that must have been the case..:)

"..(@Borate)..... What you posted is exactly the type of result I want to get out of VP but don't for whatever reason. I'm going to play with different versions now and see what I'll find out.... "

Both Borate and myself loaded your test project and exported it (with VP 7.30) at a constant  60fps  with the result that you thought was OK....It played pretty smooth here despite having the extra duplicated frames.   See settings in the export Video window.....


HOWEVER....Although your test looked OK at 60fps (which we both tried) you can set a maximum export fps to 144 fps

If you select Custom (the bottom option) and enter 240 it defaults to 144fps. The export result is now (or seems to be here) absolutely great. Flecks of snow individually arcing from the skis with any trace of jerkiness. You can even see some particles actually turning.

Worth trying.  

  1. Load your camera clip
  2. Change speed to slow it down on the Video track (e.g. 12.5%)
  3. Export as mp4 at Custom 240 fps  This will default to 144fps in the box (But I think there may be a slight difference if you actually enter 144....Give it a try.





Link to post
Share on other sites

Thank you @borate and @Nationalsolo for your great efforts and help.

I'm currently getting the results I want with v7.10 even when exporting at 30fps. This is why I'll stick with that version now. I'm pretty certain now, that from v7.10 to v7.11 there was an ill-advised change in the order that speed change and frame rate are applied during the rendering process. (Hmmm, this is in disagreement with the fact, that borate managed smooth slowmo with v7.30... Anyway, I have a working solution now and am tired of testing around.)

Once, I feel the need to upgrade, I'll go with what Nationalsolo suggested. However, that would still be a workaround. It may leave only 144fps from my original 240fps. And it would require an additional rendering step in order to bring down the frame rate from 144fps to 30fps for a reasonable file size of the final video.

Thanks again.


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...