Jump to content

Mysterious (and mysteriously solved) audio problem


Recommended Posts

OK, so this goes under the Beats-me-what-I-did-but-I-did-something-that-worked category.

The problem: 
I'm switching computers, so I installed Videopad  on the new box  registered it, and transferred about 350 gigs of video files (processed and originals) from the old box to the new one. when I went to test out the new machine with VP, I found that projects where the original (imported) files were avi, wmv, etc worked fine, however, the projects where the imported files were Quicktime files previewed with no audio (the little warning came up that the audio was processing, but the audio track window just showed a straight line). All I got was a buzzing in the speakers.

Details:
-- Videopad version (old box)  - 6.10 - (site of the original work)
-- Videopad version (new box)  - 6.32
-- OS -- (old box) Windoze 8
-- OS -- (new box) Windoze 10
-- Problematic file types -- Quicktime .mov
-- Audio format -- PCM

What I did: 
I went thru the usual routine - clear the cache, reboot, re-install, pray, curse, scratch my head, Google every combination of terms I could come up with, all with no joy. The files previewed fine in VP on the old box, but not on the new. I used MediaInfo to compare the old/new and found no differences. The .mov files would play fine on the new box using Windoze Media Player and VLC Media Player.

After a day or so, I finally thought "What would happen if I started a new project using one of these .mov files?" When I did that, POOF!!, it worked no problem - video AND audio!! 

Then came the amazing thing -- POOF! again!! My other vpj projects magically worked!! Video AND audio in the preview!!

So, I have no idea if the starting a new project thing did anything, but I thought I'd post this just in case anybody else is out there scratching their head. 

Link to post
Share on other sites

 

1 hour ago, borate said:

Humm... perhaps a codec (missing on the new box) was downloaded?

Based on what little I know about how this works, I suspect you are on the money.

When I was having the problem, I checked but did not fine a  /Components directory under C:\Program Files (x86)\NCH Software\ on the new machine. Now, there are two new directories:

  • \ffmpeg23; and
  • \mp3el2

The files in those directories (about a half dozen .dll files) have a Date Created of today, which further supports your theory.

I'm thinking that there's a flag in the metadata of the old (transferred) files that basically says "I got these already", which was wrong, but when I created a new project, it downloaded them.

I don't know if NCH has a transfer path for moving onto a new system (I didn't really search for one). Hoping this can help somebody who might be in the same boat sometime.

Thanks!!!!!!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...