Jump to content

Transition No Room

Recommended Posts

I'm a new user working on a project and have been coming along fine until I reached this section where I can't add a transition. The message I get when I click the transition icon is "not enough space for adding transition." I've tried what little I know to create room to no avail. Help please. Thanks. T. A. 


Link to post
Share on other sites

I got that, too, the first few times I tried to a transition but haven't gotten it since.

I *think* what it is, is that you have a default setting for the duration of the transition, and the clip that follows where you're trying to do the transition is shorter than that. I believe the message offers the option of automatically making a change that will allow the transition.

I'm sure other more advanced users will probably chime in!

Link to post
Share on other sites

I've experienced this, too and found that the problem was a tiny gap/void in between clips. Sliding the clips together resolves. An easy way to see this is revealed by the "X" transition icon located at the end and beginning of your clips. The "X" at the end of the previous clip will be unaffected but the "X" at the beginning of the next clip will appear cut in half. This is impossible to see if the view is zoomed in. You need to zoom out to see it. I've had "micro" gaps between clips that I couldn't see until zooming all the way out. I've been mindful when splitting to use split with ripple.

Link to post
Share on other sites
  • 2 weeks later...

Thanks again everyone. Helpful hints all! I've started learning to enlarge the track to help me see the gaps and learning to move things around to give me room for the transitions. Thanks again. Just posted about laptop shutting down. Trying to get my first VideoPad project completed for showing and can't due to shut downs. Answers? Thanks again. T. A.

Link to post
Share on other sites


In the most recent version of VP (and possibly some of the earlier versions), inserting a clip between two others at a visible join by dragging and dropping results in the new clip inserting a tiny distance from the actual join. One is logically led to drop the clip when the white dotted line with the arrows appears. Unfortunately the actual insertion point is the head of the "grab arrow" that appears  in the clip being dropped. The error becomes more marked as the timeline is zoomed in.

In essence this means that a sliver of the following clip  (or, depending which side of the join the drag arrow point is, the leading clip) is left at the join. With no zoom that sliver of clip is not visible but can mess up any transition placed where the join appears to be. Here is an example...


  • Top:         The join before making an insertion
  • Middle:    Man with cap is dragged to the join. The white line with arrows appear seemingly indicating the clip is at the join and ready to drop. (However note the position of the "drag arrow" It is not actually at the join.
  • The clip has been dropped but you can see that a sliver of the following clip has been  left behind.

I have exaggerated the error by zooming in but at normal zoom the sliver is hardly evident......if at all.


This means that trying to add a transition at the X will not work as there is insufficient space. Going into Storyboard mode clearly shows the sliver as a tiny clip of 0.027 seconds duration.


The best way to avoid this problem is to position the red cursor line at the join using  the >II or II< buttons in sequence preview and then use the clip  right click menu option to Place on Sequence at Cursor

I think this needs altering a little so that the white line with arrows only appears when the clip being inserted is actually going to be dropped at the join. i.e. an indication that it will be snapped there.


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...