Jump to content

Wavepad Only Loading First 21 Seconds of File


Recommended Posts

I have recorded multiple sound files using both WavePad and SoundTap that are more than a few minutes long.  When I try to load a file into WavePad for editing, it only loads the first 21.539 seconds of the file and nothing else.

I have performed a full disc cleanup (Windows 10); uninstalled and reinstalled the software (multiple times); and even tried recording small test files (longer than 30 seconds)-saving them-and immediately opening them in WavePad for editing.....and still only the first 21.539 seconds of the file appear in the editing window.  If I play the file, the sound stops at the 21.539 mark.

I AM able to play the FULL sound file from within SoundTap, Windows Media Player, etc.

I was having this same problem with older Windows 7.0 versions of the software and thought it was an upgrade issue, so I bought all new Windows 10 versions of the various NCH programs I use.  The problem persists.

What do I need to do to fix this problem so I can record/input/edit sound files and be able to edit the full file, not just the first 21+ seconds??

PLEASE HELP!  I'm trying everything I know how to do from this end.  Nothing is working.  ?

Link to comment
Share on other sites

Follow the steps below,

1. From WavePad, select the Options menu > Audio tab > "Audio working folder" section, check mark the "Use this specified folder" box and copy the folder path.

C:\Users\YourUserName\AppData\Roaming\NCH Software\WavePad.

2. Paste the path on your windows folder explorer, this will open the Cache content files.

3. Delete all files within this folder.

4. Close WavePad and re open it again.

5. Re load the file and let us know the outcome. 


Hope this helps!

Link to comment
Share on other sites


Many thanks.  This appears to have worked (knock on wood, "for now").

When I reopened WavePad and went to the Options/Audio tab, I noticed that the radio button in the "working folder" section had reverted back to the "Use default user data folder" instead of staying on the "Use this specified folder" as you had instructed.  Was it supposed to do that or am I going to have to manually change it each time I run the program?

Again, many thanks.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...