Jump to content

Just installed Voxal Voice Changer now everything I record is messed up


Recommended Posts

Just installed Voxal Voice Changer and when I tried to do a test there was so much noise and static. I closed the program and tested my Yeti Blue Mic on Windows 10 voice recorder which was working fine right before the install and now it as well as all kinds of noise and static when I record. My first instinct is to uninstall the software.  I hope someone can help me, I'd like to keep the software and enjoy it but not at the risk of messing up all my audio recordings.

Link to post
Share on other sites

Hello, 

The first thing I would recommend you do is to make sure you have the latest drivers for your Mic, then uninstall the program and  install it again, after installation make sure to restart your PC and hopefully that will fix your issue.

If you keep having issues, I would recommend you contact NCH tech support by creating a ticket. You can do that using this link: https://www.nch.com.au/support/index.html  

Link to post
Share on other sites
  • 4 weeks later...
  • 5 months later...
On 8/16/2018 at 7:04 PM, N_C_H_yusuf said:

Hi Logicalron,

  We are sorry to hear that you face this problem. This problem will be fixed with the next release which will be available very soon. We are sorry for the inconvenience caused.  But rest assured, you can keep the software and update it in the coming weeks.

Regards,

Yusuf

I Have the same problem where there is a horrendous screeching sound in my mic even after i uninstalled the program

Link to post
Share on other sites

Hi RyanFD,

  I replied to your thread. The problem here in this thread is different to your situation, for this problem there was a bug in some voice files in version 3.00 which caused static noise when Voxal was running. If you can answers my questions in your thread, I will do my best to help you.

Regards,

Yusuf

Link to post
Share on other sites
  • 1 year later...

Hello,

when I start up my program for the voxal voice changer and I choose my voice I end up getting a lot of static in my ear and also for others hearing me use the voice. This never used to occur until my windows update at the start of 2020, it had occurred a couple times after I first installed the program though, too. I believe there is no problem with my mic as it is high quality. Is there any way to fix problem? I have deleted and reinstalled the program many times and it continues so I don't think that's a solution fit for me. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...