Jump to content

uplink and axon settings


Recommended Posts

Below is some info on how uplink (sip > skype) can work together with axon using the uplink "use the dialed number" option

 

First thing to do is go to axon web interface > extensions

 

add an extension

 

extension id: skype (when using another name please use this name below in the uplink sip account numer box and also in the external line user id below)

display name: skype

password: (typ your password here) 1234 in this example

outbound dialing plan: default

 

In uplink under sip you can add the above settings

 

display name: skype

sip account number: skype (or other name you supplied under add an extension)

server: (the ip address of your axon server)

password (the password you supplied during axon add extension) 1234 in this example

 

Also you have to use the dialed number option.

 

Restart uplink.

 

Uplink will now login to the skype account (on your axon server).

Read the SIP PRIVATE IP

 

Go back to the axon webinterface.

Add an external line

 

Line name: Skype

Server: (type the SIP PRIVATE IP supplied by uplink here)

User ID: Skype (the user id should be the same as the user id that you use for uplink to login to axon)

Password (the password should be the same as the one you used for the uplink extension in axon) 1234 in this example

 

In the axon webinterface now go to dialing plans

 

go to default

 

add dial rule.

 

if the number starts with: 8 (can be a different number but preferably not 1 as these are normally internal axon extensions)

remove digits: 1

dial on line: (select your skype line here)

 

Above dialplan is for people using regular touchtochtone phones without display. Whenever you dial 8 and after that the skype speed dial number you will be connected.

 

You can also add the following option:

 

add dial rule.

 

if the number starts with: skype_

remove digits: 6

dial on line: (select your skype line here)

 

this means whenever you type skype_ and after that the skype user name or skype speed dial number you will be connected.

 

It took a few hours to figure this out but it works now. Any comments please post them.

Link to post
Share on other sites
  • 1 month later...
Below is some info on how uplink (sip > skype) can work together with axon using the uplink "use the dialed number" option

 

First thing to do is go to axon web interface > extensions

 

add an extension

 

extension id: skype (when using another name please use this name below in the uplink sip account numer box and also in the external line user id below)

display name: skype

password: (typ your password here) 1234 in this example

outbound dialing plan: default

 

In uplink under sip you can add the above settings

 

display name: skype

sip account number: skype (or other name you supplied under add an extension)

server: (the ip address of your axon server)

password (the password you supplied during axon add extension) 1234 in this example

 

Also you have to use the dialed number option.

 

Restart uplink.

 

Uplink will now login to the skype account (on your axon server).

Read the SIP PRIVATE IP

 

Go back to the axon webinterface.

Add an external line

 

Line name: Skype

Server: (type the SIP PRIVATE IP supplied by uplink here)

User ID: Skype (the user id should be the same as the user id that you use for uplink to login to axon)

Password (the password should be the same as the one you used for the uplink extension in axon) 1234 in this example

 

In the axon webinterface now go to dialing plans

 

go to default

 

add dial rule.

 

if the number starts with: 8 (can be a different number but preferably not 1 as these are normally internal axon extensions)

remove digits: 1

dial on line: (select your skype line here)

 

Above dialplan is for people using regular touchtochtone phones without display. Whenever you dial 8 and after that the skype speed dial number you will be connected.

 

You can also add the following option:

 

add dial rule.

 

if the number starts with: skype_

remove digits: 6

dial on line: (select your skype line here)

 

this means whenever you type skype_ and after that the skype user name or skype speed dial number you will be connected.

 

It took a few hours to figure this out but it works now. Any comments please post them.

 

I have done all that and followed the instruction even to a "T" using your user and passwords, but when i try to call otu or in i get the error "491 Request Pending" Do you have any idea why?

Link to post
Share on other sites
I have done all that and followed the instruction even to a "T" using your user and passwords, but when i try to call otu or in i get the error "491 Request Pending" Do you have any idea why?

 

Hello, I got the same problem with my SKYPE ULINK.

On Vonage and Broadvoice, I get "488 Not Acceptable Here"

Any Idea?

Link to post
Share on other sites
  • 2 weeks later...

I have tried this over and over again. I have spent hours on end trying to get this to work with no results. I get the same error also. error "491 Request Pending"

 

Please help I really want to get this to work with Express Talk and Axon. Thanks

Link to post
Share on other sites

I finally got it please disregard the last post. In case this helps the others I will let tell what fixed my problem.

 

I followed directions form crshman to a tee. What I did not do that corrected the problem is where he says:

 

"Uplink will now login to the skype account (on your axon server).

Read the SIP PRIVATE IP"

 

But in this section

 

Go back to the axon webinterface.

Add an external line

 

"Line name: Skype

Server: (type the SIP PRIVATE IP supplied by uplink here)

User ID: Skype (the user id should be the same as the user id that you use for uplink to login to axon)

Password (the password should be the same as the one you used for the uplink extension in axon) 1234 in this example"

 

In the Server: (type the SIP PRIVATE IP supplied by uplink here)

 

Make sure you put the port number also.

 

I put the IP address there but not the port and it did not work. When I put the port number after that it worked perfectly.

 

I spent hours on this I hope this helps. There may be a setting that the port number is different some where but I need to look but I finally got it. Hope this helps others

Link to post
Share on other sites

I've gotten Skype, Uplink ans the Axon to work together. Now comes the next logical question:

 

How many incoming calls can be received (into Skype? into Axon through Skype?) when there occur multiple simultaneous calls to the Skype-In number?

 

Are multiple Skype accounts (and/or Skype-In numbers) needed? Does one define multiple external lines in Axon? Multiple Skype extensions with slightly different names?

 

John McNeely

 

I finally got it please disregard the last post. In case this helps the others I will let tell what fixed my problem.

 

I followed directions form crshman to a tee. What I did not do that corrected the problem is where he says:

 

"Uplink will now login to the skype account (on your axon server).

Read the SIP PRIVATE IP"

 

But in this section

 

Go back to the axon webinterface.

Add an external line

 

"Line name: Skype

Server: (type the SIP PRIVATE IP supplied by uplink here)

User ID: Skype (the user id should be the same as the user id that you use for uplink to login to axon)

Password (the password should be the same as the one you used for the uplink extension in axon) 1234 in this example"

 

In the Server: (type the SIP PRIVATE IP supplied by uplink here)

 

Make sure you put the port number also.

 

I put the IP address there but not the port and it did not work. When I put the port number after that it worked perfectly.

 

I spent hours on this I hope this helps. There may be a setting that the port number is different some where but I need to look but I finally got it. Hope this helps others

:)

Link to post
Share on other sites
  • 2 weeks later...
I've gotten Skype, Uplink ans the Axon to work together. Now comes the next logical question:

 

How many incoming calls can be received (into Skype? into Axon through Skype?) when there occur multiple simultaneous calls to the Skype-In number?

 

Are multiple Skype accounts (and/or Skype-In numbers) needed? Does one define multiple external lines in Axon? Multiple Skype extensions with slightly different names?

 

John McNeely

:)

 

Ok I have been battling with this for a while. The VERY IMPORTANT thing to note here is that if you want to use skype, axon, and uplink on the same windows pc, you have to change the TCP port in Uplink on which to listen for incoming connections. If you don't Axon will try to connect to itself for outgoing calls.

So just like above, where it says to put in your private ip address and then the port, like 192.168.1.2:5070.

I am still not getting this to completely work yet - skype says it is dialing, but the test number isn't ringing.

Link to post
Share on other sites
  • 6 months later...
Ok I have been battling with this for a while. The VERY IMPORTANT thing to note here is that if you want to use skype, axon, and uplink on the same windows pc, you have to change the TCP port in Uplink on which to listen for incoming connections. If you don't Axon will try to connect to itself for outgoing calls.

So just like above, where it says to put in your private ip address and then the port, like 192.168.1.2:5070.

I am still not getting this to completely work yet - skype says it is dialing, but the test number isn't ringing.

 

 

PLEASE YOU DID NOT REPLY TO JOHNS REQEST VERY WELL

i AM ALSO WONDERING HOW TO SET THIS UP TO SEND CALLS FROM SKYPE IN NUMBER TO MOBILE PHONES

ALSO I WANT TO KNOW HOW TO SUBDIVIDED SIP MINUTES I GOT FROM GIZMO INTO SIP EXTENSIONS

 

MADAKO

 

Ok I have been battling with this for a while. The VERY IMPORTANT thing to note here is that if you want to use skype, axon, and uplink on the same windows pc, you have to change the TCP port in Uplink on which to listen for incoming connections. If you don't Axon will try to connect to itself for outgoing calls.

So just like above, where it says to put in your private ip address and then the port, like 192.168.1.2:5070.

I am still not getting this to completely work yet - skype says it is dialing, but the test number isn't ringing.

 

 

PLEASE YOU DID NOT REPLY TO JOHNS REQEST VERY WELL

i AM ALSO WONDERING HOW TO SET THIS UP TO SEND CALLS FROM SKYPE IN NUMBER TO MOBILE PHONES

ALSO I WANT TO KNOW HOW TO SUBDIVIDED SIP MINUTES I GOT FROM GIZMO INTO SIP EXTENSIONS

 

MADAKO

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...