Jump to content

Capture Card Not Found


Dive Operations
 Share

Recommended Posts

Hi,

There is no list of compatible devices, but most of USB devices will work.

Check your ez capture card/ ez grabber capture card drivers, make sure you have the correct drivers based on your current OS. When done, download and install the latest version of Debut from the website → http://www.nchsoftware.com/capture/index.html

 

 

Link to comment
Share on other sites

  • 5 weeks later...

Telephony - Thx for the response. Forums are a wonderful thing.

In Debut Prefs (Mac OS), nothing is shown under Capture Device in the video pane (greyed out), so you're probably right. The only option is screen capture. The NCH website specifically lists the Elgato device as compatible, so I was a little confused and thought I was doing something wrong.

Link to comment
Share on other sites

I'm having the same problem. Installed Elgato usb digitizer (on my mac) which is on their list of approved devices. The Elgato software driver installs and records using their software but Debut doesn't recognize the device.

 

Link to comment
Share on other sites

I just tried another digitizer, the SIIG video capture device. Again Debut doesn't recognize it. I'm told that their tech support people are working on this. I wonder is there anyone who has a digitizer board connected to a mac is that is recognized by the Debut software? 

 

Link to comment
Share on other sites

OK, so my final experiment is that I tried both usb digitizers with Debut on a Windows machine. Neither works. So based on my research only builtin or external usb web cams work with Debut as well as the screen capture functions.

Link to comment
Share on other sites

I made some progress with Elgato device. Turns out that how the audio is set can cause the unable to connect error. So now I'm able to record video but without sound. I followed the advice posted elsewhere to enable the Stereo Mix System Mixer in windows and chose that as the audio input in Debut and checked speakers. Still no sound but also I get a feedback loop when i turn on the speakers. ugh

Link to comment
Share on other sites

  • 2 years later...
On 12/17/2017 at 11:06 PM, jlam said:

I'm having the same problem. Installed Elgato usb digitizer (on my mac) which is on their list of approved devices. The Elgato software driver installs and records using their software but Debut doesn't recognize the device.

 

 

On 12/17/2017 at 11:06 PM, jlam said:

I'm having the same problem. Installed Elgato usb digitizer (on my mac) which is on their list of approved devices. The Elgato software driver installs and records using their software but Debut doesn't recognize the device.

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...