Jump to content

Recommended Posts


I tried to open a project of mine that I was working on for a few weeks yesterday, when it came up with this message: 


The file provided is not a valid VideoPad project file

It is saved on an external hard drive so I used another PC to try and open the project, but the same message came up. I tried to open previous projects and they opened up perfectly fine. I didn't notice anything strange when I saved my project last. Is there any way I can fix this problem and retrieve back the project I was working on?


Link to post
Share on other sites


Seems as if the .vpj file is faulty.  Normally there shouldn't be any problem if you saved your project (your .vpj file) to an external drive. It should load exactly as if it was saved to your main PC drive if you use the same PC.. This works OK here.

Plug in your drive to the PC that is running VP. Open the drive and check that you actually have a .vpj file.  Now open VP and navigate to the .vpj file. Select it. ...It should open even if it cant find your clips. (Remember If you use a different PC your clips may not be there.)

You may be able to open the project from the auto saved .vpj files which is independant of the user saved .vpj file. However, I think these are deleted when VP is exited normally and are only prompted for if the program crashes which I don't thik is the case with this problem

 Check the "Welcome" screen that opens with VP. Recent projects are listed..hopefully with yours. Use the original PC of course Worth a try but it may give the same result.

If the project is not huge you could also open the faulty .vpj folder into notepad and upload it so NCH could take a look at it.


Note: that if you are intending to use different PCs when you work with your projects it is probably best to save your work using

"Save Portable Project as" 

Create a new named folder on the drive (e.g. "My Project") and use "Save Portable Project as"

Select this new folder and Save. ....All the project files including all the clips and images used as well as .vpj file will be saved in a dated folder within "My Project"  Each time you subsequently save use "My Project" as the containing folder. Each time you use "Save Portable Project" you will create a new dated folder containing the complete project. The .vpj files in any of these dated folders will open the particular project on any PC as each of the dated folders  is complete copy . (The PC used must have VP running....and preferably the same version)


Link to post
Share on other sites


Thanks for replying. I do have the file in my drive, so that isn't the problem. I also tried opening it from VP by navigating to the file, but that didn't work either. It came up with the same error message as before. I also tried to open from the recent projects, but also not working. Is there anything else I can do? Can I use applications like recuva to recover the file? I found this solution here: https://www.piriform.com/docs/recuva/using-recuva/recovering-files-from-damaged-or-reformatted-disks



I attempted to recover using recuva, but it didn't work I'm afraid

Edited by Abdul Bhatti
Link to post
Share on other sites


If you deleted it you wouldn't see it on your PC and Recuva might probably find it. This doesn't seem a case of a deleted file as you say it exists  on your drive. It may just be corrupted and not recognised

Try right clicking the file and then "Open with" and selecting Notepad. This should (normally) bring up the text of the .vpj file.

It will look something like this....e.g.


This for a single unedited clip on the timeline called ASP-002.  If yours is not a huge project with lots of effects copy it to the forum and NCH might be able to see if its corrupted or not. At least copy the first 20-30 lines and the last 20-30 lines.


Link to post
Share on other sites


It looks like VP didn't save any data at all in the  .vpj file  the file created is empty. (Check how big it is by listing it with its details - It will probably be 0kb).

I have no idea why this is  and of course VP won't recognise it or open it.

Sorry :-(   It seems you may have to start over again.


Link to post
Share on other sites
  • 2 years later...

So this happened to me twice. The same project basically. All my project is, is audio but normally after hours of working on the project, it just stops working. The Auido is fine when suddenly everything is just gone. The boxes are still there but no sound waves or lines, theres no sound, and it wont save. So the first time this happened I hadn't saved, we assumed the program crashed. Today I decided to restart the entire project. U had been working for hours and saving every few minutes. Suddenly it happened again. All of my audio boxes just go blank. Since I saved this time, I just go to restart the program. But when I re open it, suddenly the project no longer is valid for it. 

Obviously now I'm wary of trying this huge project again for the 3rd time from scratch, I bought the program a while back and this has never happened. The project isnt intense besides the audio is long and all I'm doing really is cutting the audio to make it shorter so when that's done I can add video and effects but the project just no longer works not even half way through editing the audio. Please tell me some one has figured this out.

Link to post
Share on other sites

What version of VP?   Did you go to OPTIONS|DISK tab and Clear Unused Cache Files after restarting VP but before loading the profile?

Try that.  Occasionally the cache can become corrupt.  Also be certain that there is ample free space on your C:\ drive.

You might also try reinstalling the program after UNinstalling via Control Panel|PROGRAMS AND FEATURES.  Delete all data as well.

Link to post
Share on other sites


Are you Saving Project    or  Saving Project as  ? 

The former overwrites the vpj file that you previously saved, (which you may have done) whilst the latter option allows you give a new name to the vpj file saved so you have a different vpj file. i.e. you can make incremental saves,  each one at a different point in the development of your project.

Assuming everything has been properly saved and you still have the original component clips, even if you have cleared the cache, opening any of the vpj files should reconstruct your project at the point at which it was saved. The cache is re-generated anew.

If you overwrite the file each time any corruption to it (rare) will prevent you reloading the project. Incremental saves can overcome this problem. The state of the cache is of no consequence, it only speeds up the file recovery.


Link to post
Share on other sites
  • 11 months later...

Hey....i have a problem with videopad ..,yesterday I completed working on a project and when i tried to export my file only a few minutes of the file were beig exported a,i tried multiple times to export but all in vain so I uninstalled and reinstalled videopad with hopes that it would export the file but this time I couldn't even get the vpj file to open in videopad im soooooooo stranded any help😪😭😭😭😭

Link to post
Share on other sites

Did you create other VPJ files by Saving Project Files AS routinely and giving them a unique # or name, so as to not overwrite prior saves?

VP often creates back ups.  Look in the source files folder, or search the PC for VPJ and try several of those files.

If no luck, please upload the folder that contains the source files and the VPJ to a free server, such as Google Drive or MS OneDrive.  Get a shared link that's public and can be viewed by anyone, copy that link and paste it here or in private.  Someone will check it out.


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...