Jump to content

lossless mp4 failed: unknown error, downloads x264enc7


fredgolightly
 Share

Recommended Posts

Using 5.01 of VideoPad I cannot get anything to export. I'm using m2ts files and mostly .mp4 avc files from a Nexus 5X.

The problem is opaque - I drop an mp4 file into the timeline, and click export to video file. I have enable lossless ticked in settings. I click detect for settings (which doesn't matter, no settings work) and everything else is default. All I want is a direct stream copy ie lossless.

It 'creates' it in seconds, then says it's running on demand. Looks like it's downloading a file but then says 'failed: unknown error'. It then opens a browser window and downloads x264enc7.exe from http://www.nch.com.au/components/x264enc7.exe but nothing happens/it fails transparently.

 

Next time I try to export again nothing, no file, fails with unknown error, and re-downloads x264enc7 yet again.

 

What can I do to either log this error or do to fix it - it's clearly thinking x2647enc isn't available but it downloads fine and can run it. I'm at a loss as nothing works!

 

edit: I've tried copying x264enc7.exe to C:\Users\username\AppData\Roaming\NCH Software\Components\x264enc7 but no luck

edit: I've uploaded my portable project here - I can't see how it can help as it's simply an mp4 dropped into the timeline but we'll see!

Link to comment
Share on other sites

19 minutes ago, borate said:

Any help in this thread?

Tried that, hence the info in post. No luck. Where should this file reside? It shouldn't be this hard to get a simple app to work. I set all permissions to allow on both locations of this enc file but no change, even in admin mode.

 

Is there a way to enable debugging/logging as I feel there'll be no real solution to this from the makers...

Link to comment
Share on other sites

What? I'm not on a mac, as indicated by the Windows file path and .exe extension. I'm on Windows 10. I've found all the threads, but none work. Don't need the file as, per my op, it's downloaded every single export attempt. Its in the locations I've seen and you've posted but no configuration works.

Link to comment
Share on other sites

Confusion on release numbers.  5.01 is indeed the latest for both Windows and Mac.

Apparently you have tried the suggestions offered by c_major...

  1. Delete C:\Users\[user Name]\AppData\Roaming\NCH Software\Components  (My installation shows no 'components' in that path.)
  2. Delete C:\Program Files\NCH Software\Components (Since this is a 32-bit program, the path here is Program Files(86), etc.)
  3. Restart VideoPad and import the files. Make sure stay online so the components can be downloaded on demand.

Others may chime in.

 

Link to comment
Share on other sites

13 hours ago, c_major said:

Lossless mp4 transcoding is an experimental feature and a work in progress.

Please turn it off if you encountered any issue when you export your project.

No luck with it off. Cannot find any way to export any mp4. I've also tried uninstalling, rebooting, re-downloading, uninstalling with Revo Uninstaller.

Can I enable logging somehow and help you guys look into it? There's nothing in the project file I can see would cause this - i simply dropped one mp4 in and it doesn't work, but I've uploaded my portable project here.

Link to comment
Share on other sites

Have you checked that you can download .exe files and isn't blocked/removed by anti-virus or firewall?

There are two possible place on your local disk that the x264 encoder(x264enc7.exe) can be:

  • C:\Users\[user Name]\AppData\Roaming\NCH Software\Components\x264enc7\x264enc7.exe
  • C:\Program Files\NCH Software\Components\x264enc7\x264enc7.exe

Please make sure at least one of them is in place. Try another codec if you don't have to use x264.

 

Link to comment
Share on other sites

1 minute ago, c_major said:

It seems none of the on demand download components works on your PC. However they did download and exist on the local drive...

I'll PM you and send you a diagnostic build which generates debugging information.

Thanks. I've just tried 5.02D from Allen Brett via email and have sent him some logs - should I pm you the same or will the be shared at NCH office?

That's what I was thinking- it;s strange how they download and run after the export 'runs' and are on the desktop.

Link to comment
Share on other sites

Great, thanks again! I'm trying not to create two paths for people to follow concurrently. I'm looking through the log too trying to work out the similarities with the 'failed' message using 246 and mpeg...you guys might beat me to it!

 

ps Phenomenal support guys, truly above and beyond via forums & emails, I'm super impressed and will be spreading the NCH Soft word!

Link to comment
Share on other sites

  • 4 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...